Tarantool development patches archive
 help / color / mirror / Atom feed
From: Serge Petrenko via Tarantool-patches <tarantool-patches@dev.tarantool.org>
To: Vladislav Shpilevoy <v.shpilevoy@tarantool.org>, gorcunov@gmail.com
Cc: tarantool-patches@dev.tarantool.org
Subject: Re: [Tarantool-patches] [PATCH v3 08/10] Support manual elections in `box.ctl.clear_synchro_queue()`
Date: Fri, 16 Apr 2021 18:50:29 +0300	[thread overview]
Message-ID: <e1ee8dc2-573f-0e51-803a-28dc47224708@tarantool.org> (raw)
In-Reply-To: <815ca075-7d25-a584-b75a-9a4a28e6cdaf@tarantool.org>



16.04.2021 18:40, Serge Petrenko via Tarantool-patches пишет:
>
>
> 16.04.2021 18:38, Serge Petrenko via Tarantool-patches пишет:
>>
>>
>> 16.04.2021 02:30, Vladislav Shpilevoy пишет:
>>>> diff --git a/src/box/raft.h b/src/box/raft.h
>>>> index 15f4e80d9..8fce423e1 100644
>>>> --- a/src/box/raft.h
>>>> +++ b/src/box/raft.h
>>>> @@ -97,6 +97,9 @@ box_raft_checkpoint_remote(struct raft_request 
>>>> *req);
>>>>   int
>>>>   box_raft_process(struct raft_request *req, uint32_t source);
>>>>   +void
>>>> +box_raft_wait_leader_found();
>>>> +
>>>>   void
>>>>   box_raft_init(void);
>>>>   diff --git a/src/lib/raft/raft.c b/src/lib/raft/raft.c
>>>> index e9ce8cade..7b77e05ea 100644
>>>> --- a/src/lib/raft/raft.c
>>>> +++ b/src/lib/raft/raft.c
>>>> @@ -846,7 +846,7 @@ raft_cfg_is_enabled(struct raft *raft, bool 
>>>> is_enabled)
>>>>   }
>>>>     void
>>>> -raft_cfg_is_candidate(struct raft *raft, bool is_candidate)
>>>> +raft_cfg_is_candidate(struct raft *raft, bool is_candidate, bool 
>>>> demote)
>>> 5. I know it might lead to some code duplication, but probably
>>> better move that to other functions. For example,
>>>
>>>     raft_cfg_is_temporary_candidate()
>>>
>>> or something like that. Otherwise it appears surprisingly hard
>>> to follow these 2 flags together. Although I might be wrong and
>>> it would look worse. Did you try?
>>>
>>> Or another option:
>>>
>>>     raft_cfg_is_candidate(box_raft(), true, false);
>>>     raft_cfg_is_candidate(box_raft(), false, false);
>>>
>>> turns into
>>>
>>>     raft_start_candidate(box_raft())
>>>     raft_stop_candidate(box_raft())
>>>
>>> Also it would be good to have unit tests for the changes in raft.h
>>> and raft.c.
>>
>> This variant sounds good. I'll implement in in a new commit.
>
> The commit I was talking about:

Incremental diff on top:

=====================================

diff --git a/src/lib/raft/raft.c b/src/lib/raft/raft.c
index 8deb06eb5..b21693642 100644
--- a/src/lib/raft/raft.c
+++ b/src/lib/raft/raft.c
@@ -862,7 +862,13 @@ raft_start_candidate(struct raft *raft)
         if (raft->is_candidate)
                 return;
         raft->is_candidate = true;
-       assert(raft->state == RAFT_STATE_FOLLOWER);
+       assert(raft->state != RAFT_STATE_CANDIDATE);
+       /*
+        * May still be the leader after raft_stop_candidate
+        * with demote = false.
+        */
+       if (raft->state == RAFT_STATE_LEADER)
+               return;
         if (raft->is_write_in_progress) {
                 /*
                  * If there is an on-going WAL write, it means there was


-- 
Serge Petrenko


  reply	other threads:[~2021-04-16 15:50 UTC|newest]

Thread overview: 36+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2021-04-14 14:17 [Tarantool-patches] [PATCH v3 00/10] raft: introduce manual elections and fix a bug with re-applying rolled back transactions Serge Petrenko via Tarantool-patches
2021-04-14 14:17 ` [Tarantool-patches] [PATCH v3 01/10] wal: enrich row's meta information with sync replication flags Serge Petrenko via Tarantool-patches
2021-04-15 23:18   ` Vladislav Shpilevoy via Tarantool-patches
2021-04-16  7:08     ` Serge Petrenko via Tarantool-patches
2021-04-16  7:11       ` Serge Petrenko via Tarantool-patches
2021-04-16  8:57       ` Serge Petrenko via Tarantool-patches
2021-04-14 14:17 ` [Tarantool-patches] [PATCH v3 02/10] xrow: introduce a PROMOTE entry Serge Petrenko via Tarantool-patches
2021-04-15 23:19   ` Vladislav Shpilevoy via Tarantool-patches
2021-04-16 16:18     ` Serge Petrenko via Tarantool-patches
2021-04-14 14:17 ` [Tarantool-patches] [PATCH v3 03/10] box: actualise iproto_key_type array Serge Petrenko via Tarantool-patches
2021-04-14 14:17 ` [Tarantool-patches] [PATCH v3 04/10] box: make clear_synchro_queue() write a PROMOTE entry instead of CONFIRM + ROLLBACK Serge Petrenko via Tarantool-patches
2021-04-15 23:20   ` Vladislav Shpilevoy via Tarantool-patches
2021-04-16  9:28     ` Serge Petrenko via Tarantool-patches
2021-04-16 14:03       ` Serge Petrenko via Tarantool-patches
2021-04-14 14:17 ` [Tarantool-patches] [PATCH v3 05/10] box: write PROMOTE even for empty limbo Serge Petrenko via Tarantool-patches
2021-04-15 23:21   ` Vladislav Shpilevoy via Tarantool-patches
2021-04-16  9:33     ` Serge Petrenko via Tarantool-patches
2021-04-14 14:17 ` [Tarantool-patches] [PATCH v3 06/10] raft: keep track of greatest known term and filter replication sources based on that Serge Petrenko via Tarantool-patches
2021-04-15 23:27   ` Vladislav Shpilevoy via Tarantool-patches
2021-04-16 14:16     ` Serge Petrenko via Tarantool-patches
2021-04-16 22:13       ` Vladislav Shpilevoy via Tarantool-patches
2021-04-14 14:17 ` [Tarantool-patches] [PATCH v3 07/10] replication: introduce a new election mode: "manual" Serge Petrenko via Tarantool-patches
2021-04-15 23:27   ` Vladislav Shpilevoy via Tarantool-patches
2021-04-16 14:18     ` Serge Petrenko via Tarantool-patches
2021-04-14 14:17 ` [Tarantool-patches] [PATCH v3 08/10] Support manual elections in `box.ctl.clear_synchro_queue()` Serge Petrenko via Tarantool-patches
2021-04-15 23:30   ` Vladislav Shpilevoy via Tarantool-patches
2021-04-16 15:38     ` Serge Petrenko via Tarantool-patches
2021-04-16 15:40       ` Serge Petrenko via Tarantool-patches
2021-04-16 15:50         ` Serge Petrenko via Tarantool-patches [this message]
2021-04-14 14:17 ` [Tarantool-patches] [PATCH v3 09/10] box: remove parameter from clear_synchro_queue Serge Petrenko via Tarantool-patches
2021-04-14 14:18 ` [Tarantool-patches] [PATCH v3 10/10] box.ctl: rename clear_synchro_queue to promote Serge Petrenko via Tarantool-patches
2021-04-15 23:31   ` Vladislav Shpilevoy via Tarantool-patches
2021-04-16 16:13     ` Serge Petrenko via Tarantool-patches
2021-04-14 18:21 ` [Tarantool-patches] [PATCH v3 00/10] raft: introduce manual elections and fix a bug with re-applying rolled back transactions Cyrill Gorcunov via Tarantool-patches
2021-04-15 23:16 ` Vladislav Shpilevoy via Tarantool-patches
2021-04-16 16:35   ` Serge Petrenko via Tarantool-patches

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=e1ee8dc2-573f-0e51-803a-28dc47224708@tarantool.org \
    --to=tarantool-patches@dev.tarantool.org \
    --cc=gorcunov@gmail.com \
    --cc=sergepetrenko@tarantool.org \
    --cc=v.shpilevoy@tarantool.org \
    --subject='Re: [Tarantool-patches] [PATCH v3 08/10] Support manual elections in `box.ctl.clear_synchro_queue()`' \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox