From: Serge Petrenko via Tarantool-patches <tarantool-patches@dev.tarantool.org> To: Vladislav Shpilevoy <v.shpilevoy@tarantool.org>, gorcunov@gmail.com Cc: tarantool-patches@dev.tarantool.org Subject: Re: [Tarantool-patches] [PATCH v3 04/10] box: make clear_synchro_queue() write a PROMOTE entry instead of CONFIRM + ROLLBACK Date: Fri, 16 Apr 2021 12:28:47 +0300 [thread overview] Message-ID: <704bbea0-f575-4253-630c-eff5c6a269bd@tarantool.org> (raw) In-Reply-To: <bcdeb413-fa13-79d8-becb-a60fc52fd565@tarantool.org> 16.04.2021 02:20, Vladislav Shpilevoy пишет: > Thanks for working on this! > > See 2 comments below. > >> diff --git a/src/box/box.cc b/src/box/box.cc >> index 70b325180..9adb6ba46 100644 >> --- a/src/box/box.cc >> +++ b/src/box/box.cc >> @@ -1556,7 +1556,19 @@ box_clear_synchro_queue(bool try_wait) >> "new synchronous transactions appeared"); >> rc = -1; >> } else { >> - txn_limbo_force_empty(&txn_limbo, wait_lsn); >> + /* >> + * Term parameter is unused now, We'll pass >> + * box_raft()->term there later. >> + */ >> + txn_limbo_write_promote(&txn_limbo, wait_lsn, 0); >> + struct synchro_request req = { >> + .type = 0, /* unused */ >> + .replica_id = 0, /* unused */ >> + .origin_id = instance_id, >> + .lsn = wait_lsn, >> + .term = 0, /* unused */ > 1. Aren't the unused fields nullified anyway according to > the standard? We had this conversation with Cyrill recently. I don't have a good explanation for this anyway, but here's the one I have: >> Is there some particular meaning of zeroifying designated assignments? >> I mean why not simply >> >> struct synchro_request req = { >> .origin_id = instance_id, >> .lsn = wait_lsn, >> }; >> >> or you wanted to pay attention that the left of the fields are >> unused? Just curious, I'm fine with current code. > I went for your option at first, and it's the one I'd prefer. > But with it I got failed builds in some CI jobs. > > It said something like "sorry, not yet implemented: struct partial > initialization" > > >> + }; >> + txn_limbo_read_promote(&txn_limbo, &req); >> assert(txn_limbo_is_empty(&txn_limbo)); >> } >> } >> diff --git a/src/box/txn_limbo.c b/src/box/txn_limbo.c >> index d29722ef7..bfe0ad302 100644 >> --- a/src/box/txn_limbo.c >> +++ b/src/box/txn_limbo.c >> @@ -464,6 +470,32 @@ txn_limbo_read_rollback(struct txn_limbo *limbo, int64_t lsn) >> box_update_ro_summary(); >> } >> >> +void >> +txn_limbo_write_promote(struct txn_limbo *limbo, int64_t lsn, uint64_t term) >> +{ >> + limbo->confirmed_lsn = lsn; >> + /* >> + * We make sure that promote is only written once everything this >> + * instance has may be confirmed. >> + */ >> + struct txn_limbo_entry *e = txn_limbo_last_synchro_entry(limbo); >> + assert(e == NULL || e->lsn <= lsn); >> + (void) e; >> + txn_limbo_write_synchro(limbo, IPROTO_PROMOTE, lsn, term); >> + limbo->is_in_rollback = false; > 2. How is it possible that there was a rollback in progress at > the same time? Sorry, I was trying to replicate txn_limbo_write_confirm/rollback behaviour, but forgot to set limbo->is_in_rollback = true before the journal write: ======================================= diff --git a/src/box/txn_limbo.c b/src/box/txn_limbo.c index e6f644bc0..93c8994b7 100644 --- a/src/box/txn_limbo.c +++ b/src/box/txn_limbo.c @@ -474,6 +474,7 @@ void txn_limbo_write_promote(struct txn_limbo *limbo, int64_t lsn, uint64_t term) { limbo->confirmed_lsn = lsn; + limbo->is_in_rollback = true; /* * We make sure that promote is only written once everything this * instance has may be confirmed. -- Serge Petrenko
next prev parent reply other threads:[~2021-04-16 9:28 UTC|newest] Thread overview: 36+ messages / expand[flat|nested] mbox.gz Atom feed top 2021-04-14 14:17 [Tarantool-patches] [PATCH v3 00/10] raft: introduce manual elections and fix a bug with re-applying rolled back transactions Serge Petrenko via Tarantool-patches 2021-04-14 14:17 ` [Tarantool-patches] [PATCH v3 01/10] wal: enrich row's meta information with sync replication flags Serge Petrenko via Tarantool-patches 2021-04-15 23:18 ` Vladislav Shpilevoy via Tarantool-patches 2021-04-16 7:08 ` Serge Petrenko via Tarantool-patches 2021-04-16 7:11 ` Serge Petrenko via Tarantool-patches 2021-04-16 8:57 ` Serge Petrenko via Tarantool-patches 2021-04-14 14:17 ` [Tarantool-patches] [PATCH v3 02/10] xrow: introduce a PROMOTE entry Serge Petrenko via Tarantool-patches 2021-04-15 23:19 ` Vladislav Shpilevoy via Tarantool-patches 2021-04-16 16:18 ` Serge Petrenko via Tarantool-patches 2021-04-14 14:17 ` [Tarantool-patches] [PATCH v3 03/10] box: actualise iproto_key_type array Serge Petrenko via Tarantool-patches 2021-04-14 14:17 ` [Tarantool-patches] [PATCH v3 04/10] box: make clear_synchro_queue() write a PROMOTE entry instead of CONFIRM + ROLLBACK Serge Petrenko via Tarantool-patches 2021-04-15 23:20 ` Vladislav Shpilevoy via Tarantool-patches 2021-04-16 9:28 ` Serge Petrenko via Tarantool-patches [this message] 2021-04-16 14:03 ` Serge Petrenko via Tarantool-patches 2021-04-14 14:17 ` [Tarantool-patches] [PATCH v3 05/10] box: write PROMOTE even for empty limbo Serge Petrenko via Tarantool-patches 2021-04-15 23:21 ` Vladislav Shpilevoy via Tarantool-patches 2021-04-16 9:33 ` Serge Petrenko via Tarantool-patches 2021-04-14 14:17 ` [Tarantool-patches] [PATCH v3 06/10] raft: keep track of greatest known term and filter replication sources based on that Serge Petrenko via Tarantool-patches 2021-04-15 23:27 ` Vladislav Shpilevoy via Tarantool-patches 2021-04-16 14:16 ` Serge Petrenko via Tarantool-patches 2021-04-16 22:13 ` Vladislav Shpilevoy via Tarantool-patches 2021-04-14 14:17 ` [Tarantool-patches] [PATCH v3 07/10] replication: introduce a new election mode: "manual" Serge Petrenko via Tarantool-patches 2021-04-15 23:27 ` Vladislav Shpilevoy via Tarantool-patches 2021-04-16 14:18 ` Serge Petrenko via Tarantool-patches 2021-04-14 14:17 ` [Tarantool-patches] [PATCH v3 08/10] Support manual elections in `box.ctl.clear_synchro_queue()` Serge Petrenko via Tarantool-patches 2021-04-15 23:30 ` Vladislav Shpilevoy via Tarantool-patches 2021-04-16 15:38 ` Serge Petrenko via Tarantool-patches 2021-04-16 15:40 ` Serge Petrenko via Tarantool-patches 2021-04-16 15:50 ` Serge Petrenko via Tarantool-patches 2021-04-14 14:17 ` [Tarantool-patches] [PATCH v3 09/10] box: remove parameter from clear_synchro_queue Serge Petrenko via Tarantool-patches 2021-04-14 14:18 ` [Tarantool-patches] [PATCH v3 10/10] box.ctl: rename clear_synchro_queue to promote Serge Petrenko via Tarantool-patches 2021-04-15 23:31 ` Vladislav Shpilevoy via Tarantool-patches 2021-04-16 16:13 ` Serge Petrenko via Tarantool-patches 2021-04-14 18:21 ` [Tarantool-patches] [PATCH v3 00/10] raft: introduce manual elections and fix a bug with re-applying rolled back transactions Cyrill Gorcunov via Tarantool-patches 2021-04-15 23:16 ` Vladislav Shpilevoy via Tarantool-patches 2021-04-16 16:35 ` Serge Petrenko via Tarantool-patches
Reply instructions: You may reply publicly to this message via plain-text email using any one of the following methods: * Save the following mbox file, import it into your mail client, and reply-to-all from there: mbox Avoid top-posting and favor interleaved quoting: https://en.wikipedia.org/wiki/Posting_style#Interleaved_style * Reply using the --to, --cc, and --in-reply-to switches of git-send-email(1): git send-email \ --in-reply-to=704bbea0-f575-4253-630c-eff5c6a269bd@tarantool.org \ --to=tarantool-patches@dev.tarantool.org \ --cc=gorcunov@gmail.com \ --cc=sergepetrenko@tarantool.org \ --cc=v.shpilevoy@tarantool.org \ --subject='Re: [Tarantool-patches] [PATCH v3 04/10] box: make clear_synchro_queue() write a PROMOTE entry instead of CONFIRM + ROLLBACK' \ /path/to/YOUR_REPLY https://kernel.org/pub/software/scm/git/docs/git-send-email.html * If your mail client supports setting the In-Reply-To header via mailto: links, try the mailto: link
This is a public inbox, see mirroring instructions for how to clone and mirror all data and code used for this inbox