From: Vladislav Shpilevoy via Tarantool-patches <tarantool-patches@dev.tarantool.org> To: Serge Petrenko <sergepetrenko@tarantool.org>, gorcunov@gmail.com Cc: tarantool-patches@dev.tarantool.org Subject: Re: [Tarantool-patches] [PATCH v3 02/10] xrow: introduce a PROMOTE entry Date: Fri, 16 Apr 2021 01:19:23 +0200 [thread overview] Message-ID: <704d7361-d27e-9fb5-0957-487af57b4628@tarantool.org> (raw) In-Reply-To: <78fd722e0cd1e6edcdd8e081c7e40a5d0bcf7ec7.1618409665.git.sergepetrenko@tarantool.org> I appreciate the work you did here! See 2 comments below. > diff --git a/src/box/xrow.c b/src/box/xrow.c > index cc8e43ed4..5d515ce92 100644 > --- a/src/box/xrow.c > +++ b/src/box/xrow.c > @@ -884,28 +884,63 @@ xrow_encode_dml(const struct request *request, struct region *region, > return iovcnt; > } > > -void > -xrow_encode_synchro(struct xrow_header *row, > - struct synchro_body_bin *body, > - const struct synchro_request *req) > +static void > +xrow_encode_synchro_body(struct synchro_body_bin *body, > + const struct synchro_request *req) > { > /* > - * A map with two elements. We don't compress > + * A map with two or three elements. We don't compress > * numbers to have this structure constant in size, > * which allows us to preallocate it on stack. > */ > - body->m_body = 0x80 | 2; > + body->m_body = 0x80 | (req->type == IPROTO_PROMOTE ? 3 : 2); > body->k_replica_id = IPROTO_REPLICA_ID; > body->m_replica_id = 0xce; > body->v_replica_id = mp_bswap_u32(req->replica_id); > body->k_lsn = IPROTO_LSN; > body->m_lsn = 0xcf; > body->v_lsn = mp_bswap_u64(req->lsn); > +} > + > +void > +xrow_encode_synchro(struct xrow_header *row, > + struct synchro_body_bin *body, > + const struct synchro_request *req) > +{ > + assert(req->type == IPROTO_CONFIRM || req->type == IPROTO_ROLLBACK); > + > + xrow_encode_synchro_body(body, req); > > memset(row, 0, sizeof(*row)); > + row->type = req->type; > + row->body[0].iov_base = body; > + row->body[0].iov_len = sizeof(*body); > + row->bodycnt = 1; > +} > + > +static inline void > +xrow_encode_promote_body(struct promote_body_bin *body, > + const struct synchro_request *req) 1. I would propose to inline it. It is used in a single place, and now it looks like if we would have more than 1 place where we would need the promote body. But more interestingly, it looks you could keep it a single function xrow_encode_synchro. Although we wouldn't be able to have a PACKED struct with predefined fields. Not a big deal anyway. The reasoning is similar to xrow_encode_dml(). It also uses a single struct request for all kinds of DML, and conditionally encodes the non-zero fields. I think your case is the same. It would simplify some code, and remove branching from other places. For example, from txn_limbo_write_synchro(), where you branch between PROMOTE and non-PROMOTE when decide what to encode. We even had the same issue when tried to encode CONFIRM and ROLLBACK via separate functions. > +{ > + xrow_encode_synchro_body(&body->base, req); > + > + body->k_term = IPROTO_TERM; > + body->m_term = 0xcf; > + body->v_term = mp_bswap_u64(req->term); > +} > + > > +void > +xrow_encode_promote(struct xrow_header *row, struct promote_body_bin *body, > + const struct synchro_request *req) > +{ > + assert(req->type == IPROTO_PROMOTE); > + > + xrow_encode_promote_body(body, req); > + > + memset(row, 0, sizeof(*row)); > row->type = req->type; > - row->body[0].iov_base = (void *)body; > + row->body[0].iov_base = body; 2. Unnecessary change. But I don't mind, up to you. > row->body[0].iov_len = sizeof(*body); > row->bodycnt = 1; > }
next prev parent reply other threads:[~2021-04-15 23:19 UTC|newest] Thread overview: 36+ messages / expand[flat|nested] mbox.gz Atom feed top 2021-04-14 14:17 [Tarantool-patches] [PATCH v3 00/10] raft: introduce manual elections and fix a bug with re-applying rolled back transactions Serge Petrenko via Tarantool-patches 2021-04-14 14:17 ` [Tarantool-patches] [PATCH v3 01/10] wal: enrich row's meta information with sync replication flags Serge Petrenko via Tarantool-patches 2021-04-15 23:18 ` Vladislav Shpilevoy via Tarantool-patches 2021-04-16 7:08 ` Serge Petrenko via Tarantool-patches 2021-04-16 7:11 ` Serge Petrenko via Tarantool-patches 2021-04-16 8:57 ` Serge Petrenko via Tarantool-patches 2021-04-14 14:17 ` [Tarantool-patches] [PATCH v3 02/10] xrow: introduce a PROMOTE entry Serge Petrenko via Tarantool-patches 2021-04-15 23:19 ` Vladislav Shpilevoy via Tarantool-patches [this message] 2021-04-16 16:18 ` Serge Petrenko via Tarantool-patches 2021-04-14 14:17 ` [Tarantool-patches] [PATCH v3 03/10] box: actualise iproto_key_type array Serge Petrenko via Tarantool-patches 2021-04-14 14:17 ` [Tarantool-patches] [PATCH v3 04/10] box: make clear_synchro_queue() write a PROMOTE entry instead of CONFIRM + ROLLBACK Serge Petrenko via Tarantool-patches 2021-04-15 23:20 ` Vladislav Shpilevoy via Tarantool-patches 2021-04-16 9:28 ` Serge Petrenko via Tarantool-patches 2021-04-16 14:03 ` Serge Petrenko via Tarantool-patches 2021-04-14 14:17 ` [Tarantool-patches] [PATCH v3 05/10] box: write PROMOTE even for empty limbo Serge Petrenko via Tarantool-patches 2021-04-15 23:21 ` Vladislav Shpilevoy via Tarantool-patches 2021-04-16 9:33 ` Serge Petrenko via Tarantool-patches 2021-04-14 14:17 ` [Tarantool-patches] [PATCH v3 06/10] raft: keep track of greatest known term and filter replication sources based on that Serge Petrenko via Tarantool-patches 2021-04-15 23:27 ` Vladislav Shpilevoy via Tarantool-patches 2021-04-16 14:16 ` Serge Petrenko via Tarantool-patches 2021-04-16 22:13 ` Vladislav Shpilevoy via Tarantool-patches 2021-04-14 14:17 ` [Tarantool-patches] [PATCH v3 07/10] replication: introduce a new election mode: "manual" Serge Petrenko via Tarantool-patches 2021-04-15 23:27 ` Vladislav Shpilevoy via Tarantool-patches 2021-04-16 14:18 ` Serge Petrenko via Tarantool-patches 2021-04-14 14:17 ` [Tarantool-patches] [PATCH v3 08/10] Support manual elections in `box.ctl.clear_synchro_queue()` Serge Petrenko via Tarantool-patches 2021-04-15 23:30 ` Vladislav Shpilevoy via Tarantool-patches 2021-04-16 15:38 ` Serge Petrenko via Tarantool-patches 2021-04-16 15:40 ` Serge Petrenko via Tarantool-patches 2021-04-16 15:50 ` Serge Petrenko via Tarantool-patches 2021-04-14 14:17 ` [Tarantool-patches] [PATCH v3 09/10] box: remove parameter from clear_synchro_queue Serge Petrenko via Tarantool-patches 2021-04-14 14:18 ` [Tarantool-patches] [PATCH v3 10/10] box.ctl: rename clear_synchro_queue to promote Serge Petrenko via Tarantool-patches 2021-04-15 23:31 ` Vladislav Shpilevoy via Tarantool-patches 2021-04-16 16:13 ` Serge Petrenko via Tarantool-patches 2021-04-14 18:21 ` [Tarantool-patches] [PATCH v3 00/10] raft: introduce manual elections and fix a bug with re-applying rolled back transactions Cyrill Gorcunov via Tarantool-patches 2021-04-15 23:16 ` Vladislav Shpilevoy via Tarantool-patches 2021-04-16 16:35 ` Serge Petrenko via Tarantool-patches
Reply instructions: You may reply publicly to this message via plain-text email using any one of the following methods: * Save the following mbox file, import it into your mail client, and reply-to-all from there: mbox Avoid top-posting and favor interleaved quoting: https://en.wikipedia.org/wiki/Posting_style#Interleaved_style * Reply using the --to, --cc, and --in-reply-to switches of git-send-email(1): git send-email \ --in-reply-to=704d7361-d27e-9fb5-0957-487af57b4628@tarantool.org \ --to=tarantool-patches@dev.tarantool.org \ --cc=gorcunov@gmail.com \ --cc=sergepetrenko@tarantool.org \ --cc=v.shpilevoy@tarantool.org \ --subject='Re: [Tarantool-patches] [PATCH v3 02/10] xrow: introduce a PROMOTE entry' \ /path/to/YOUR_REPLY https://kernel.org/pub/software/scm/git/docs/git-send-email.html * If your mail client supports setting the In-Reply-To header via mailto: links, try the mailto: link
This is a public inbox, see mirroring instructions for how to clone and mirror all data and code used for this inbox