Tarantool development patches archive
 help / color / mirror / Atom feed
From: Serge Petrenko <sergepetrenko@tarantool.org>
To: Cyrill Gorcunov <gorcunov@gmail.com>,
	tml <tarantool-patches@dev.tarantool.org>
Cc: Vladislav Shpilevoy <v.shpilevoy@tarantool.org>
Subject: Re: [Tarantool-patches] [PATCH 09/11] qsync: drop redundant type convention
Date: Fri, 13 Nov 2020 13:11:05 +0300	[thread overview]
Message-ID: <11e6dccd-feba-e55c-4f0b-0d73e50d8b6d@tarantool.org> (raw)
In-Reply-To: <20201112195121.191366-10-gorcunov@gmail.com>


12.11.2020 22:51, Cyrill Gorcunov пишет:
> Void pointer can be cast implicitly.

We usually use explicit casts. Check `applier.cc`, `alter.cc` and some 
other places.
This isn't in our style guide though, so I'm fine with the change.

Let's see what Vlad has to say.

>
> Signed-off-by: Cyrill Gorcunov <gorcunov@gmail.com>
> ---
>   src/box/txn_limbo.c | 6 ++----
>   1 file changed, 2 insertions(+), 4 deletions(-)
>
> diff --git a/src/box/txn_limbo.c b/src/box/txn_limbo.c
> index cf6122360..ffcda389c 100644
> --- a/src/box/txn_limbo.c
> +++ b/src/box/txn_limbo.c
> @@ -549,8 +549,7 @@ static int
>   txn_commit_cb(struct trigger *trigger, void *event)
>   {
>   	(void)event;
> -	struct confirm_waitpoint *cwp =
> -		(struct confirm_waitpoint *)trigger->data;
> +	struct confirm_waitpoint *cwp = trigger->data;
>   	cwp->is_confirm = true;
>   	fiber_wakeup(cwp->caller);
>   	return 0;
> @@ -560,8 +559,7 @@ static int
>   txn_rollback_cb(struct trigger *trigger, void *event)
>   {
>   	(void)event;
> -	struct confirm_waitpoint *cwp =
> -		(struct confirm_waitpoint *)trigger->data;
> +	struct confirm_waitpoint *cwp = trigger->data;
>   	cwp->is_rollback = true;
>   	fiber_wakeup(cwp->caller);
>   	return 0;

-- 
Serge Petrenko

  reply	other threads:[~2020-11-13 10:11 UTC|newest]

Thread overview: 43+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2020-11-12 19:51 [Tarantool-patches] [PATCH 00/11] qsync: code refactoring Cyrill Gorcunov
2020-11-12 19:51 ` [Tarantool-patches] [PATCH 01/11] build: add more ignore paths for tags target Cyrill Gorcunov
2020-11-16 13:09   ` Cyrill Gorcunov
2020-11-20 23:55   ` Vladislav Shpilevoy
2020-11-21 12:09     ` Cyrill Gorcunov
2020-11-12 19:51 ` [Tarantool-patches] [PATCH 02/11] vclock: vclock_get - drop misleading masking Cyrill Gorcunov
2020-11-12 19:51 ` [Tarantool-patches] [PATCH 03/11] vclock: vclock_inc -- add assert() to catch overflow Cyrill Gorcunov
2020-11-13  9:30   ` Serge Petrenko
2020-11-12 19:51 ` [Tarantool-patches] [PATCH 04/11] txn: txn_commit_async -- drop redundant variable Cyrill Gorcunov
2020-11-13  9:31   ` Serge Petrenko
2020-11-20 23:55   ` Vladislav Shpilevoy
2020-11-21 12:30     ` Cyrill Gorcunov
2020-11-21 13:29       ` Vladislav Shpilevoy
2020-11-21 16:14         ` Cyrill Gorcunov
2020-11-12 19:51 ` [Tarantool-patches] [PATCH 05/11] qsync: rename txn_limbo::instance_id to owner_id Cyrill Gorcunov
2020-11-13  9:37   ` Serge Petrenko
2020-11-12 19:51 ` [Tarantool-patches] [PATCH 06/11] qsync: txn_limbo_append -- use owner_id in argument name Cyrill Gorcunov
2020-11-13  9:43   ` Serge Petrenko
2020-11-13 10:11     ` Cyrill Gorcunov
2020-11-20 23:55   ` Vladislav Shpilevoy
2020-11-12 19:51 ` [Tarantool-patches] [PATCH 07/11] qsync: move limbo owner transition into separate helper Cyrill Gorcunov
2020-11-13  9:47   ` Serge Petrenko
2020-11-13 10:12     ` Cyrill Gorcunov
2020-11-20 23:55   ` Vladislav Shpilevoy
2020-11-12 19:51 ` [Tarantool-patches] [PATCH 08/11] qsync: txn_limbo_wait_confirm -- refactor code a bit Cyrill Gorcunov
2020-11-13  9:56   ` Serge Petrenko
2020-11-20 23:55   ` Vladislav Shpilevoy
2020-11-12 19:51 ` [Tarantool-patches] [PATCH 09/11] qsync: drop redundant type convention Cyrill Gorcunov
2020-11-13 10:11   ` Serge Petrenko [this message]
2020-11-13 10:13     ` Cyrill Gorcunov
2020-11-13 10:19       ` Serge Petrenko
2020-11-20 23:55   ` Vladislav Shpilevoy
2020-11-12 19:51 ` [Tarantool-patches] [PATCH 10/11] relay: use verbose names for fibers Cyrill Gorcunov
2020-11-13 10:17   ` Serge Petrenko
2020-11-13 10:28     ` Cyrill Gorcunov
2020-11-20 23:55   ` Vladislav Shpilevoy
2020-11-12 19:51 ` [Tarantool-patches] [PATCH 11/11] raft: drop redundant argument Cyrill Gorcunov
2020-11-13 10:18   ` Serge Petrenko
2020-11-20 23:54 ` [Tarantool-patches] [PATCH 00/11] qsync: code refactoring Vladislav Shpilevoy
2020-11-24 23:24   ` Vladislav Shpilevoy
2020-11-23 23:26 ` Vladislav Shpilevoy
2020-11-24  6:52   ` Cyrill Gorcunov
2020-11-24 21:41     ` Alexander V. Tikhonov

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=11e6dccd-feba-e55c-4f0b-0d73e50d8b6d@tarantool.org \
    --to=sergepetrenko@tarantool.org \
    --cc=gorcunov@gmail.com \
    --cc=tarantool-patches@dev.tarantool.org \
    --cc=v.shpilevoy@tarantool.org \
    --subject='Re: [Tarantool-patches] [PATCH 09/11] qsync: drop redundant type convention' \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox