Tarantool development patches archive
 help / color / mirror / Atom feed
From: Cyrill Gorcunov <gorcunov@gmail.com>
To: tml <tarantool-patches@dev.tarantool.org>
Cc: Vladislav Shpilevoy <v.shpilevoy@tarantool.org>
Subject: [Tarantool-patches] [PATCH 00/11] qsync: code refactoring
Date: Thu, 12 Nov 2020 22:51:10 +0300	[thread overview]
Message-ID: <20201112195121.191366-1-gorcunov@gmail.com> (raw)

Guys, while I'm working on #5435 and trying to figure out
how to implement it I need to read a lot of code so here
are some patches which I guess make code more readable.

Please take a look and say what you think. We can easily
ignore the whole set.

branch gorcunov/gh-5435-clear_synchro_queue

Cyrill Gorcunov (11):
  build: add more ignore paths for tags target
  vclock: vclock_get - drop misleading masking
  vclock: vclock_inc -- add assert() to catch overflow
  txn: txn_commit_async -- drop redundant variable
  qsync: rename txn_limbo::instance_id to owner_id
  qsync: txn_limbo_append -- use owner_id in argument name
  qsync: move limbo owner transition into separate helper
  qsync: txn_limbo_wait_confirm -- refactor code a bit
  qsync: drop redundant type convention
  relay: use verbose names for fibers
  raft: drop redundant argument

 CMakeLists.txt                 |   6 ++
 src/box/box.cc                 |   2 +-
 src/box/raft.c                 |   2 +-
 src/box/relay.cc               |  17 ++---
 src/box/txn.c                  |  13 ++--
 src/box/txn_limbo.c            | 126 ++++++++++++++++++---------------
 src/box/txn_limbo.h            |   4 +-
 src/lib/vclock/vclock.h        |   7 +-
 test/unit/snap_quorum_delay.cc |   2 +-
 9 files changed, 98 insertions(+), 81 deletions(-)


base-commit: 5d2962244247707c7298a59de0bd4628091dda96
-- 
2.26.2

             reply	other threads:[~2020-11-12 19:51 UTC|newest]

Thread overview: 43+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2020-11-12 19:51 Cyrill Gorcunov [this message]
2020-11-12 19:51 ` [Tarantool-patches] [PATCH 01/11] build: add more ignore paths for tags target Cyrill Gorcunov
2020-11-16 13:09   ` Cyrill Gorcunov
2020-11-20 23:55   ` Vladislav Shpilevoy
2020-11-21 12:09     ` Cyrill Gorcunov
2020-11-12 19:51 ` [Tarantool-patches] [PATCH 02/11] vclock: vclock_get - drop misleading masking Cyrill Gorcunov
2020-11-12 19:51 ` [Tarantool-patches] [PATCH 03/11] vclock: vclock_inc -- add assert() to catch overflow Cyrill Gorcunov
2020-11-13  9:30   ` Serge Petrenko
2020-11-12 19:51 ` [Tarantool-patches] [PATCH 04/11] txn: txn_commit_async -- drop redundant variable Cyrill Gorcunov
2020-11-13  9:31   ` Serge Petrenko
2020-11-20 23:55   ` Vladislav Shpilevoy
2020-11-21 12:30     ` Cyrill Gorcunov
2020-11-21 13:29       ` Vladislav Shpilevoy
2020-11-21 16:14         ` Cyrill Gorcunov
2020-11-12 19:51 ` [Tarantool-patches] [PATCH 05/11] qsync: rename txn_limbo::instance_id to owner_id Cyrill Gorcunov
2020-11-13  9:37   ` Serge Petrenko
2020-11-12 19:51 ` [Tarantool-patches] [PATCH 06/11] qsync: txn_limbo_append -- use owner_id in argument name Cyrill Gorcunov
2020-11-13  9:43   ` Serge Petrenko
2020-11-13 10:11     ` Cyrill Gorcunov
2020-11-20 23:55   ` Vladislav Shpilevoy
2020-11-12 19:51 ` [Tarantool-patches] [PATCH 07/11] qsync: move limbo owner transition into separate helper Cyrill Gorcunov
2020-11-13  9:47   ` Serge Petrenko
2020-11-13 10:12     ` Cyrill Gorcunov
2020-11-20 23:55   ` Vladislav Shpilevoy
2020-11-12 19:51 ` [Tarantool-patches] [PATCH 08/11] qsync: txn_limbo_wait_confirm -- refactor code a bit Cyrill Gorcunov
2020-11-13  9:56   ` Serge Petrenko
2020-11-20 23:55   ` Vladislav Shpilevoy
2020-11-12 19:51 ` [Tarantool-patches] [PATCH 09/11] qsync: drop redundant type convention Cyrill Gorcunov
2020-11-13 10:11   ` Serge Petrenko
2020-11-13 10:13     ` Cyrill Gorcunov
2020-11-13 10:19       ` Serge Petrenko
2020-11-20 23:55   ` Vladislav Shpilevoy
2020-11-12 19:51 ` [Tarantool-patches] [PATCH 10/11] relay: use verbose names for fibers Cyrill Gorcunov
2020-11-13 10:17   ` Serge Petrenko
2020-11-13 10:28     ` Cyrill Gorcunov
2020-11-20 23:55   ` Vladislav Shpilevoy
2020-11-12 19:51 ` [Tarantool-patches] [PATCH 11/11] raft: drop redundant argument Cyrill Gorcunov
2020-11-13 10:18   ` Serge Petrenko
2020-11-20 23:54 ` [Tarantool-patches] [PATCH 00/11] qsync: code refactoring Vladislav Shpilevoy
2020-11-24 23:24   ` Vladislav Shpilevoy
2020-11-23 23:26 ` Vladislav Shpilevoy
2020-11-24  6:52   ` Cyrill Gorcunov
2020-11-24 21:41     ` Alexander V. Tikhonov

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20201112195121.191366-1-gorcunov@gmail.com \
    --to=gorcunov@gmail.com \
    --cc=tarantool-patches@dev.tarantool.org \
    --cc=v.shpilevoy@tarantool.org \
    --subject='Re: [Tarantool-patches] [PATCH 00/11] qsync: code refactoring' \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox