Tarantool development patches archive
 help / color / mirror / Atom feed
From: Vladislav Shpilevoy <v.shpilevoy@tarantool.org>
To: Cyrill Gorcunov <gorcunov@gmail.com>
Cc: tarantool-patches@dev.tarantool.org
Subject: Re: [Tarantool-patches] [PATCH 1/4] fiber: introduce fiber.arg
Date: Tue, 10 Nov 2020 00:59:05 +0100	[thread overview]
Message-ID: <4d57db9b-37c5-923d-12d4-8949437e75c2@tarantool.org> (raw)
In-Reply-To: <20201109142717.GJ2339@grain>

Hi! Thanks for the review!

On 09.11.2020 15:27, Cyrill Gorcunov wrote:
> On Sun, Nov 08, 2020 at 07:03:54PM +0100, Vladislav Shpilevoy wrote:
>> @@ -565,7 +565,19 @@ struct fiber {
>>  	 * See http://gcc.gnu.org/bugzilla/show_bug.cgi?id=31488
>>  	 */
>>  	fiber_func f;
>> -	va_list f_data;
>> +	union {
>> +		/**
>> +		 * Argument list passed when the fiber is invoked in a blocking
>> +		 * way, so the caller may pass arguments from its own stack.
>> +		 */
>> +		va_list f_data;
>> +		/**
>> +		 * Fiber function argument which passed asynchronously. Can be
>> +		 * used not to call fiber_start to avoid yields, but still pass
>> +		 * something into the fiber.
>> +		 */
>> +		void *arg;
> 
> Won't be better to call it "f_arg" instead? To match f_ prefix used in f_data.
> This gonna be more suitable for grepping. Since such rename would cause you
> to update other patches up to you, if you prefer plain "arg" I'm ok.

Ok, sounds reasonable. Renamed.

  reply	other threads:[~2020-11-09 23:59 UTC|newest]

Thread overview: 16+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2020-11-08 18:03 [Tarantool-patches] [PATCH 0/4] Raft module, part 1 - explicit argument Vladislav Shpilevoy
2020-11-08 18:03 ` [Tarantool-patches] [PATCH 1/4] fiber: introduce fiber.arg Vladislav Shpilevoy
2020-11-09 12:49   ` Serge Petrenko
2020-11-09 14:27   ` Cyrill Gorcunov
2020-11-09 23:59     ` Vladislav Shpilevoy [this message]
2020-11-08 18:03 ` [Tarantool-patches] [PATCH 2/4] raft: initialize raft completely at runtime Vladislav Shpilevoy
2020-11-09 12:50   ` Serge Petrenko
2020-11-09 14:59   ` Cyrill Gorcunov
2020-11-09 23:59     ` Vladislav Shpilevoy
2020-11-08 18:03 ` [Tarantool-patches] [PATCH 3/4] raft: add explicit raft argument to all functions Vladislav Shpilevoy
2020-11-09 13:46   ` Serge Petrenko
2020-11-10  0:00     ` Vladislav Shpilevoy
2020-11-08 18:03 ` [Tarantool-patches] [PATCH 4/4] vclock: move to src/lib Vladislav Shpilevoy
2020-11-09 14:12   ` Serge Petrenko
2020-11-09 15:01   ` Cyrill Gorcunov
2020-11-10 21:06 ` [Tarantool-patches] [PATCH 0/4] Raft module, part 1 - explicit argument Alexander V. Tikhonov

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=4d57db9b-37c5-923d-12d4-8949437e75c2@tarantool.org \
    --to=v.shpilevoy@tarantool.org \
    --cc=gorcunov@gmail.com \
    --cc=tarantool-patches@dev.tarantool.org \
    --subject='Re: [Tarantool-patches] [PATCH 1/4] fiber: introduce fiber.arg' \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox