Tarantool development patches archive
 help / color / mirror / Atom feed
From: Cyrill Gorcunov <gorcunov@gmail.com>
To: Vladimir Davydov <vdavydov.dev@gmail.com>
Cc: tml <tarantool-patches@freelists.org>
Subject: Re: [PATCH 1/2] lib/core/fiber: Rename stack_direction to stack_growsdown
Date: Wed, 27 Mar 2019 12:48:49 +0300	[thread overview]
Message-ID: <20190327094849.GI20626@uranus.lan> (raw)
In-Reply-To: <20190327093510.f6jtxo35kwsv7ywg@esperanza>

On Wed, Mar 27, 2019 at 12:35:10PM +0300, Vladimir Davydov wrote:
> >  enum {
> >  	/* The minimum allowable fiber stack size in bytes */
> > @@ -808,7 +808,7 @@ fiber_stack_recycle(struct fiber *fiber)
> >  	 * it anyway.
> >  	 */
> >  	void *start, *end;
> > -	if (stack_direction < 0) {
> > +	if (stack_growsdown) {
> 
> TBO I like stack_direction more as it's looks symmetrical, so to say.

Symmetrical with what? :)

> I'd refrain from changing this if there's no other reason rather than
> personal taste.

It is not personal taste but rather a common naming (mman syscall).
Though I don't insist.

  reply	other threads:[~2019-03-27  9:48 UTC|newest]

Thread overview: 18+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2019-03-19 19:38 [RFC 0/2] lib/core/fiber: Allow to extend stack size via env variable Cyrill Gorcunov
2019-03-19 19:38 ` [PATCH 1/2] lib/core/fiber: Rename stack_direction to stack_growsdown Cyrill Gorcunov
2019-03-27  9:35   ` Vladimir Davydov
2019-03-27  9:48     ` Cyrill Gorcunov [this message]
2019-03-27 10:20       ` Vladimir Davydov
2019-03-27 10:30         ` Cyrill Gorcunov
2019-03-19 19:38 ` [PATCH 2/2] lib/core/fiber: Allow to extend default stack size Cyrill Gorcunov
2019-03-27  9:35   ` Vladimir Davydov
2019-03-27  9:46     ` Cyrill Gorcunov
2019-03-27 10:15       ` Vladimir Davydov
2019-03-27 10:23         ` Cyrill Gorcunov
2019-04-01 17:41           ` Cyrill Gorcunov
2019-04-01 18:58             ` Konstantin Osipov
2019-04-01 19:19               ` Cyrill Gorcunov
2019-04-01 20:51                 ` Konstantin Osipov
2019-04-01 22:05                   ` Cyrill Gorcunov
2019-04-02  7:14                     ` Konstantin Osipov
2019-04-02  8:09                       ` Cyrill Gorcunov

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20190327094849.GI20626@uranus.lan \
    --to=gorcunov@gmail.com \
    --cc=tarantool-patches@freelists.org \
    --cc=vdavydov.dev@gmail.com \
    --subject='Re: [PATCH 1/2] lib/core/fiber: Rename stack_direction to stack_growsdown' \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox