Tarantool development patches archive
 help / color / mirror / Atom feed
* [tarantool-patches] [PATCH 0/2] sql: add better coll. determination & position func.
@ 2019-03-20 11:11 Ivan Koptelov
  2019-03-20 11:11 ` [tarantool-patches] [PATCH 1/2] sql: add better collation determination in functions Ivan Koptelov
                   ` (2 more replies)
  0 siblings, 3 replies; 13+ messages in thread
From: Ivan Koptelov @ 2019-03-20 11:11 UTC (permalink / raw)
  To: tarantool-patches; +Cc: korablev, Ivan Koptelov

There are two patches in this series. First one enhances
collation determination for function arguments (e.g. for cases,
when function arguments have different collations). Second one
renames instr() to position() and swaps arguments order. Also
after the second patch both arguments must have the same type,
which should be either TEXT or BLOB.

Branch https://github.com/tarantool/tarantool/tree/sudobobo/gh-3933-add-position-func
Issue https://github.com/tarantool/tarantool/issues/3933

Ivan Koptelov (2):
  sql: add better collation determination in functions
  sql: rename instr to position & add collation usage

 src/box/sql/expr.c             |  65 ++-
 src/box/sql/func.c             | 157 ++++--
 src/box/sql/sqlInt.h           |   8 +-
 src/box/sql/vdbeInt.h          |   9 +
 test/sql-tap/func.test.lua     |  10 +-
 test/sql-tap/func5.test.lua    |   4 +-
 test/sql-tap/instr.test.lua    | 706 -------------------------
 test/sql-tap/position.test.lua | 905 +++++++++++++++++++++++++++++++++
 test/sql-tap/with1.test.lua    |   4 +-
 9 files changed, 1106 insertions(+), 762 deletions(-)
 delete mode 100755 test/sql-tap/instr.test.lua
 create mode 100755 test/sql-tap/position.test.lua

-- 
2.20.1

^ permalink raw reply	[flat|nested] 13+ messages in thread

end of thread, other threads:[~2019-04-01 14:15 UTC | newest]

Thread overview: 13+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2019-03-20 11:11 [tarantool-patches] [PATCH 0/2] sql: add better coll. determination & position func Ivan Koptelov
2019-03-20 11:11 ` [tarantool-patches] [PATCH 1/2] sql: add better collation determination in functions Ivan Koptelov
2019-03-25 19:26   ` [tarantool-patches] " n.pettik
2019-03-27 13:38     ` i.koptelov
2019-03-28 12:50       ` n.pettik
2019-03-28 14:08         ` i.koptelov
2019-03-29  9:57           ` n.pettik
2019-03-20 11:11 ` [tarantool-patches] [PATCH 2/2] sql: rename instr to position & add collation usage Ivan Koptelov
2019-03-20 12:59   ` [tarantool-patches] Re: [PATCH 1/2] " i.koptelov
2019-03-26 12:32   ` [tarantool-patches] Re: [PATCH 2/2] " n.pettik
2019-03-27 13:39     ` i.koptelov
2019-03-28 12:57       ` n.pettik
2019-04-01 14:15 ` [tarantool-patches] Re: [PATCH 0/2] sql: add better coll. determination & position func Kirill Yukhin

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox