[tarantool-patches] Re: [PATCH v2 3/8] vinyl: rename lsm->range_heap to max_compaction_priority

Konstantin Osipov kostja at tarantool.org
Fri Feb 8 20:19:46 MSK 2019

* Vladimir Davydov <vdavydov.dev at gmail.com> [19/01/24 20:16]:
> The name 'range_heap' is ambiguous, because it's unclear what range
> should be on top of the heap. We need to introduce another heap of
> ranges ordered differently, so let's rename to max_compaction_priority
> to avoid confusion.

I think the old name was better. And I think we could avoid
introducing another heap ;)

Konstantin Osipov, Moscow, Russia, +7 903 626 22 32
http://tarantool.io - www.twitter.com/kostja_osipov

More information about the Tarantool-patches mailing list