[tarantool-patches] Re: [PATCH v2 3/8] vinyl: rename lsm->range_heap to max_compaction_priority

Vladimir Davydov vdavydov.dev at gmail.com
Fri Feb 8 20:26:26 MSK 2019

On Fri, Feb 08, 2019 at 08:19:46PM +0300, Konstantin Osipov wrote:
> * Vladimir Davydov <vdavydov.dev at gmail.com> [19/01/24 20:16]:
> > The name 'range_heap' is ambiguous, because it's unclear what range
> > should be on top of the heap. We need to introduce another heap of
> > ranges ordered differently, so let's rename to max_compaction_priority
> > to avoid confusion.
> I think the old name was better. And I think we could avoid
> introducing another heap ;)

Yep, I removed the heap in the new version and left the old name.
See the branch pls.

More information about the Tarantool-patches mailing list