From: Vladislav Shpilevoy <v.shpilevoy@tarantool.org> To: tarantool-patches@freelists.org Cc: kostja@tarantool.org Subject: [tarantool-patches] [PATCH 0/6] swim payload Date: Fri, 12 Apr 2019 01:22:24 +0300 [thread overview] Message-ID: <cover.1555021137.git.v.shpilevoy@tarantool.org> (raw) The patchset introduces SWIM payload feature with a long tail of preliminary patches. First 3 of them are just refactoring. Next two patches strongly reworks SWIM tests' fake file descriptors filtering in order to make payload tests much simpler and faster than they could be without new filtering system. The last patch is a key one, and introduces the payload. Although it is worth noting, that I consider the patchset as rather raw. So it should not be pushed, in any part. Only reviewed. Branch: http://github.com/tarantool/tarantool/tree/gerold103/gh-3234-swim-payload Issue: https://github.com/tarantool/tarantool/issues/3234 Vladislav Shpilevoy (6): swim: factor out MP_BIN decoding from swim_decode_uuid swim: replace event_bin and member_bin with the passport swim: factor out 'update' part of swim_member_upsert() test: generalize SWIM fake descriptor filters test: introduce new SWIM packet filter by component names swim: introduce payload src/lib/swim/swim.c | 225 ++++++++++++++++++++++++++------ src/lib/swim/swim.h | 8 ++ src/lib/swim/swim_proto.c | 94 +++++++------ src/lib/swim/swim_proto.h | 87 ++++++------ test/unit/swim.c | 216 +++++++++++++++++++++++++++--- test/unit/swim.result | 32 ++++- test/unit/swim_test_transport.c | 133 +++++++++++++++---- test/unit/swim_test_transport.h | 41 +++++- test/unit/swim_test_utils.c | 184 +++++++++++++++++++++++++- test/unit/swim_test_utils.h | 45 +++++++ 10 files changed, 897 insertions(+), 168 deletions(-) -- 2.17.2 (Apple Git-113)
next reply other threads:[~2019-04-11 22:22 UTC|newest] Thread overview: 27+ messages / expand[flat|nested] mbox.gz Atom feed top 2019-04-11 22:22 Vladislav Shpilevoy [this message] 2019-04-11 22:22 ` [tarantool-patches] [PATCH 1/6] swim: factor out MP_BIN decoding from swim_decode_uuid Vladislav Shpilevoy 2019-04-11 23:09 ` [tarantool-patches] " Konstantin Osipov 2019-04-12 19:23 ` Vladislav Shpilevoy 2019-04-11 22:22 ` [tarantool-patches] [PATCH 2/6] swim: replace event_bin and member_bin with the passport Vladislav Shpilevoy 2019-04-11 23:10 ` [tarantool-patches] " Konstantin Osipov 2019-04-12 19:23 ` Vladislav Shpilevoy 2019-04-11 22:22 ` [tarantool-patches] [PATCH 3/6] swim: factor out 'update' part of swim_member_upsert() Vladislav Shpilevoy 2019-04-11 23:11 ` [tarantool-patches] " Konstantin Osipov 2019-04-12 19:23 ` Vladislav Shpilevoy 2019-04-11 22:22 ` [tarantool-patches] [PATCH 4/6] test: generalize SWIM fake descriptor filters Vladislav Shpilevoy 2019-04-11 23:11 ` [tarantool-patches] " Konstantin Osipov 2019-04-12 19:23 ` Vladislav Shpilevoy 2019-04-11 22:22 ` [tarantool-patches] [PATCH 5/6] test: introduce new SWIM packet filter by component names Vladislav Shpilevoy 2019-04-11 23:11 ` [tarantool-patches] " Konstantin Osipov 2019-04-12 19:23 ` Vladislav Shpilevoy 2019-04-11 22:22 ` [tarantool-patches] [PATCH 6/6] swim: introduce payload Vladislav Shpilevoy 2019-04-18 15:12 ` [tarantool-patches] " Konstantin Osipov 2019-04-18 17:43 ` Vladislav Shpilevoy 2019-04-18 18:03 ` Konstantin Osipov 2019-04-18 20:40 ` Vladislav Shpilevoy 2019-04-18 17:43 ` [tarantool-patches] [PATCH 5.5/6] swim: rename TTL to TTD Vladislav Shpilevoy 2019-04-18 17:48 ` [tarantool-patches] " Konstantin Osipov 2019-04-18 20:40 ` Vladislav Shpilevoy 2019-04-18 18:16 ` [tarantool-patches] [PATCH 7/6] swim: drop incarnation_inc parameter from update() routines Vladislav Shpilevoy 2019-04-18 18:20 ` [tarantool-patches] " Konstantin Osipov 2019-04-18 20:40 ` Vladislav Shpilevoy
Reply instructions: You may reply publicly to this message via plain-text email using any one of the following methods: * Save the following mbox file, import it into your mail client, and reply-to-all from there: mbox Avoid top-posting and favor interleaved quoting: https://en.wikipedia.org/wiki/Posting_style#Interleaved_style * Reply using the --to, --cc, and --in-reply-to switches of git-send-email(1): git send-email \ --in-reply-to=cover.1555021137.git.v.shpilevoy@tarantool.org \ --to=v.shpilevoy@tarantool.org \ --cc=kostja@tarantool.org \ --cc=tarantool-patches@freelists.org \ --subject='Re: [tarantool-patches] [PATCH 0/6] swim payload' \ /path/to/YOUR_REPLY https://kernel.org/pub/software/scm/git/docs/git-send-email.html * If your mail client supports setting the In-Reply-To header via mailto: links, try the mailto: link
This is a public inbox, see mirroring instructions for how to clone and mirror all data and code used for this inbox