Tarantool development patches archive
 help / color / mirror / Atom feed
From: Alexander Turenko <alexander.turenko@tarantool.org>
To: Vladimir Davydov <vdavydov.dev@gmail.com>
Cc: Alexander Turenko <alexander.turenko@tarantool.org>,
	tarantool-patches@freelists.org
Subject: [PATCH v2 0/6] Merger
Date: Wed,  9 Jan 2019 23:20:08 +0300	[thread overview]
Message-ID: <cover.1547064388.git.alexander.turenko@tarantool.org> (raw)

There was made many changes since the previous iteration. Consider the
email in the mailing thread re the first version, where I answer to the
review comments. In short (non-exhaustive list of changes):

* move to box/;
* renames structures;
* change API: merger.pairs(ctx, ...);
* remove decode/encode, added net.box/msgpack helpers;
* removed say_debug() debug prints;
* replaced switched around different sources with virtual functions;
* deduplicated the code was copied from lbox_tuple_new();
* moved key_def creation to box/lua/key_def.[ch];

https://github.com/tarantool/tarantool/issues/3276
https://github.com/tarantool/tarantool/tree/Totktonada/gh-3276-on-board-merger

Alexander Turenko (6):
  Add luaL_iscallable with support of cdata metatype
  Add functions to ease using Lua iterators from C
  lua: add luaT_newtuple()
  lua: add luaT_new_key_def()
  net.box: add helpers to decode msgpack headers
  Add merger for tuple streams

 extra/exports                    |    2 +
 src/CMakeLists.txt               |    1 +
 src/box/CMakeLists.txt           |    2 +
 src/box/lua/init.c               |    3 +
 src/box/lua/key_def.c            |  217 +++++
 src/box/lua/key_def.h            |   61 ++
 src/box/lua/merger.c             | 1402 ++++++++++++++++++++++++++++++
 src/box/lua/merger.h             |   47 +
 src/box/lua/net_box.c            |   49 ++
 src/box/lua/net_box.lua          |    1 +
 src/box/lua/tuple.c              |   91 +-
 src/box/lua/tuple.h              |   15 +
 src/lua/msgpack.c                |   66 ++
 src/lua/utils.c                  |  109 +++
 src/lua/utils.h                  |   38 +
 test/app-tap/module_api.c        |   23 +
 test/app-tap/module_api.test.lua |  172 +++-
 test/app-tap/msgpack.test.lua    |  157 +++-
 test/box-tap/merger.test.lua     |  558 ++++++++++++
 test/box-tap/suite.ini           |    1 +
 test/box/net.box.result          |   58 ++
 test/box/net.box.test.lua        |   26 +
 22 files changed, 3072 insertions(+), 27 deletions(-)
 create mode 100644 src/box/lua/key_def.c
 create mode 100644 src/box/lua/key_def.h
 create mode 100644 src/box/lua/merger.c
 create mode 100644 src/box/lua/merger.h
 create mode 100755 test/box-tap/merger.test.lua

-- 
2.20.1

             reply	other threads:[~2019-01-09 20:20 UTC|newest]

Thread overview: 28+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2019-01-09 20:20 Alexander Turenko [this message]
2019-01-09 20:20 ` [PATCH v2 1/6] Add luaL_iscallable with support of cdata metatype Alexander Turenko
2019-01-10 12:21   ` Vladimir Davydov
2019-01-09 20:20 ` [PATCH v2 2/6] Add functions to ease using Lua iterators from C Alexander Turenko
2019-01-10 12:29   ` Vladimir Davydov
2019-01-15 23:26     ` Alexander Turenko
2019-01-16  8:18       ` Vladimir Davydov
2019-01-16 11:40         ` Alexander Turenko
2019-01-16 12:20           ` Vladimir Davydov
2019-01-17  1:20             ` Alexander Turenko
2019-01-28 18:17         ` Alexander Turenko
2019-03-01  4:04           ` Alexander Turenko
2019-01-09 20:20 ` [PATCH v2 3/6] lua: add luaT_newtuple() Alexander Turenko
2019-01-10 12:44   ` Vladimir Davydov
2019-01-18 21:58     ` Alexander Turenko
2019-01-23 16:12       ` Vladimir Davydov
2019-01-28 16:51         ` Alexander Turenko
2019-03-01  4:08           ` Alexander Turenko
2019-01-09 20:20 ` [PATCH v2 4/6] lua: add luaT_new_key_def() Alexander Turenko
2019-01-10 13:07   ` Vladimir Davydov
2019-01-29 18:52     ` Alexander Turenko
2019-01-30 10:58       ` Alexander Turenko
2019-03-01  4:10         ` Alexander Turenko
2019-01-09 20:20 ` [PATCH v2 5/6] net.box: add helpers to decode msgpack headers Alexander Turenko
2019-01-10 17:29   ` Vladimir Davydov
2019-02-01 15:11     ` Alexander Turenko
2019-03-05 12:00       ` Alexander Turenko
2019-01-09 20:20 ` [PATCH v2 6/6] Add merger for tuple streams Alexander Turenko

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=cover.1547064388.git.alexander.turenko@tarantool.org \
    --to=alexander.turenko@tarantool.org \
    --cc=tarantool-patches@freelists.org \
    --cc=vdavydov.dev@gmail.com \
    --subject='Re: [PATCH v2 0/6] Merger' \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox