From: Sergey Kaplun via Tarantool-patches <tarantool-patches@dev.tarantool.org> To: Maxim Kokryashkin <m.kokryashkin@tarantool.org> Cc: tarantool-patches@dev.tarantool.org Subject: Re: [Tarantool-patches] [PATCH luajit 4/5] Fix pow() optimization inconsistencies. Date: Mon, 21 Aug 2023 12:31:06 +0300 [thread overview] Message-ID: <ZOMu2lwM1yB9Ip4T@root> (raw) In-Reply-To: <jjk7cqsky7vklhm6blgiohjku6flgrmwkbkjhgnttsof6lmrzv@74kafaooikyu> Hi, Maxim! Thanks for the answers! Fixed your comment and updated the branch. On 21.08.23, Maxim Kokryashkin wrote: > Hi, Sergey! > Thanks for the fixes! > LGTM now, see my answers below. > On Mon, Aug 21, 2023 at 11:06:32AM +0300, Sergey Kaplun wrote: <snipped> > > > > > > + > > > > +-- 2921 ^ 0.5 = 0x1.b05ec632536fap+5. > > > We certainly need to add some explanation here about the precision, because > > > it is not obvious why these magic numbers should cause any issues. > > > > I suppose any really intererested in this reader may compare the > > behaviour of the glibc implementation of `sqrt()` and `pow()`. Also, the > > comment should mention this implementation, so it becomes too huge and > > distracts the reader from the test case itself. > Something like the comment below is sufficient: > | This number has no special meaning and is used as one that gives different > | results when its square root is obtained with glibc's `sqrt` and `power` > | operations, thanks to their implementation nuances. > > I strongly suggest adding it to make the test case more understandable. Added. See the iterative patch below: =================================================================== diff --git a/test/tarantool-tests/lj-684-pow-inconsistencies.test.lua b/test/tarantool-tests/lj-684-pow-inconsistencies.test.lua index 418a1557..cfd4860d 100644 --- a/test/tarantool-tests/lj-684-pow-inconsistencies.test.lua +++ b/test/tarantool-tests/lj-684-pow-inconsistencies.test.lua @@ -50,6 +50,9 @@ test:samevalues(res, ('consistent results for folding (-inf) ^ 0.5')) -- 2921 ^ 0.5 = 0x1.b05ec632536fap+5. res = {} +-- This number has no special meaning and is used as one that +-- gives different results when its square root is obtained with +-- glibc's `sqrt()` and `pow()` operations. -- XXX: use local variable to prevent folding via parser. -- XXX: use stack slot out of trace to prevent constant folding. local corner_case_pow_05 = 2921 =================================================================== > > > > Ignoring for now. > > > > > > +res = {} > > > > <snipped> > > > > > > +test:samevalues(res, ('consistent results for folding 2921 ^ 0.5')) > > > > > > I believe it is possible to make a single function with different > > > parameters for all three cases above. > > > Something like `test_power(value, power, extra_map)`, so you can do > > > | res[i] = extra_map(value ^ power) > > > > I afraid that this function doesn't give any improvement in readability, > > also, it may change the trace semantics, so I prefer to leave it as is. > > > > Ignoring for now. > I've expressed my suggestion incomprehensively, sorry. Here is what I've meant > someting like this: > > | local function pow_test_case(value, power, extra_map) > | jit.on() > | res = {} > | jit.on() > | for i = 1, 4 do > | res[i] = extra_map(value ^ power) > | end > | > | -- XXX: Prevent hotcount side effects. > | jit.off() > | jit.flush() > | > | test:samevalues(res, ('consistent results for <...>')) > | end > > Anyway, I've checked the jit.dump by myself, and even for the simple > cases traces are entirely different. With that in mind, I believe, this > comment should be ignored, even though this is very sad. Yes, also it changes the semantic of trace, since power isn't a constant, fold optimization isn't taken. > > > > > > > > > > + > > > > <snipped> > > > > > > +-- Need some value near 1, to avoid infinite result. > > > Typo: s/Need/We need/ > > > Typo: s/avoid/avoid an/ > > > > Fixed. > > > > See the iterative patch below. > > > > =================================================================== > > diff --git a/test/tarantool-tests/lj-684-pow-inconsistencies.test.lua b/test/tarantool-tests/lj-684-pow-inconsistencies.test.lua > > index 5129fc45..003fe957 100644 > > --- a/test/tarantool-tests/lj-684-pow-inconsistencies.test.lua > > +++ b/test/tarantool-tests/lj-684-pow-inconsistencies.test.lua > > @@ -18,7 +18,7 @@ jit.off() > > jit.flush() > > > > local res = {} > > --- -0 ^ 0.5 = 0. Test sign with `tostring()`. > > +-- -0 ^ 0.5 = 0. Test the sign with `tostring()`. > > -- XXX: use local variable to prevent folding via parser. > > -- XXX: use stack slot out of trace to prevent constant folding. > > local minus_zero = -0 > > @@ -75,7 +75,7 @@ jit.on() > > pow(1, 2) > > pow(1, 2) > > > > --- Need some value near 1, to avoid infinite result. > > +-- We need some value near 1, to avoid an infinite result. > > local base = 1.0000000001 > > local power = 65536 * 3 > > local resulting_value = pow(base, power) > > =================================================================== > > > > > > +local base = 1.0000000001 > > > > <snipped> > > > > > > -- > > > > 2.41.0 > > > > > > > > -- > > Best regards, > > Sergey Kaplun -- Best regards, Sergey Kaplun
next prev parent reply other threads:[~2023-08-21 9:35 UTC|newest] Thread overview: 34+ messages / expand[flat|nested] mbox.gz Atom feed top 2023-08-15 9:36 [Tarantool-patches] [PATCH luajit 0/5] Fix pow inconsistencies and improve asserts Sergey Kaplun via Tarantool-patches 2023-08-15 9:36 ` [Tarantool-patches] [PATCH luajit 1/5] test: introduce `samevalues()` TAP checker Sergey Kaplun via Tarantool-patches 2023-08-17 14:03 ` Maxim Kokryashkin via Tarantool-patches 2023-08-17 15:03 ` Sergey Kaplun via Tarantool-patches 2023-08-18 10:43 ` Sergey Bronnikov via Tarantool-patches 2023-08-18 10:58 ` Sergey Kaplun via Tarantool-patches 2023-08-18 11:12 ` Sergey Bronnikov via Tarantool-patches 2023-08-21 10:47 ` Igor Munkin via Tarantool-patches 2023-08-24 7:44 ` Sergey Bronnikov via Tarantool-patches 2023-08-15 9:36 ` [Tarantool-patches] [PATCH luajit 2/5] Remove pow() splitting and cleanup backends Sergey Kaplun via Tarantool-patches 2023-08-17 14:52 ` Maxim Kokryashkin via Tarantool-patches 2023-08-17 15:33 ` Sergey Kaplun via Tarantool-patches 2023-08-20 9:48 ` Maxim Kokryashkin via Tarantool-patches 2023-08-18 11:08 ` Sergey Bronnikov via Tarantool-patches 2023-08-15 9:36 ` [Tarantool-patches] [PATCH luajit 3/5] Improve assertions Sergey Kaplun via Tarantool-patches 2023-08-17 14:58 ` Maxim Kokryashkin via Tarantool-patches 2023-08-18 7:56 ` Sergey Kaplun via Tarantool-patches 2023-08-18 11:20 ` Sergey Bronnikov via Tarantool-patches 2023-08-15 9:36 ` [Tarantool-patches] [PATCH luajit 4/5] Fix pow() optimization inconsistencies Sergey Kaplun via Tarantool-patches 2023-08-18 12:45 ` Sergey Bronnikov via Tarantool-patches 2023-08-21 8:07 ` Sergey Kaplun via Tarantool-patches 2023-08-20 9:26 ` Maxim Kokryashkin via Tarantool-patches 2023-08-21 8:06 ` Sergey Kaplun via Tarantool-patches 2023-08-21 9:00 ` Maxim Kokryashkin via Tarantool-patches 2023-08-21 9:31 ` Sergey Kaplun via Tarantool-patches [this message] 2023-08-15 9:36 ` [Tarantool-patches] [PATCH luajit 5/5] Revert to trival pow() optimizations to prevent inaccuracies Sergey Kaplun via Tarantool-patches 2023-08-18 12:49 ` Sergey Bronnikov via Tarantool-patches 2023-08-21 8:16 ` Sergey Kaplun via Tarantool-patches 2023-08-20 9:37 ` Maxim Kokryashkin via Tarantool-patches 2023-08-21 8:15 ` Sergey Kaplun via Tarantool-patches 2023-08-21 9:06 ` Maxim Kokryashkin via Tarantool-patches 2023-08-21 9:36 ` Sergey Kaplun via Tarantool-patches 2023-08-24 7:47 ` [Tarantool-patches] [PATCH luajit 0/5] Fix pow inconsistencies and improve asserts Sergey Bronnikov via Tarantool-patches 2023-08-31 15:18 ` Igor Munkin via Tarantool-patches
Reply instructions: You may reply publicly to this message via plain-text email using any one of the following methods: * Save the following mbox file, import it into your mail client, and reply-to-all from there: mbox Avoid top-posting and favor interleaved quoting: https://en.wikipedia.org/wiki/Posting_style#Interleaved_style * Reply using the --to, --cc, and --in-reply-to switches of git-send-email(1): git send-email \ --in-reply-to=ZOMu2lwM1yB9Ip4T@root \ --to=tarantool-patches@dev.tarantool.org \ --cc=m.kokryashkin@tarantool.org \ --cc=skaplun@tarantool.org \ --subject='Re: [Tarantool-patches] [PATCH luajit 4/5] Fix pow() optimization inconsistencies.' \ /path/to/YOUR_REPLY https://kernel.org/pub/software/scm/git/docs/git-send-email.html * If your mail client supports setting the In-Reply-To header via mailto: links, try the mailto: link
This is a public inbox, see mirroring instructions for how to clone and mirror all data and code used for this inbox