Tarantool development patches archive
 help / color / mirror / Atom feed
From: Cyrill Gorcunov via Tarantool-patches <tarantool-patches@dev.tarantool.org>
To: Serge Petrenko <sergepetrenko@tarantool.org>
Cc: tml <tarantool-patches@dev.tarantool.org>,
	Vladislav Shpilevoy <v.shpilevoy@tarantool.org>
Subject: Re: [Tarantool-patches] [RFC v5 3/5] limbo: gather promote tracking into a separate structure
Date: Thu, 15 Jul 2021 14:46:06 +0300	[thread overview]
Message-ID: <YPAf/tD+0/g4AWXI@grain> (raw)
In-Reply-To: <76124bb2-95fa-5312-e9ae-8c25c527bca2@tarantool.org>

On Thu, Jul 15, 2021 at 02:28:46PM +0300, Serge Petrenko wrote:
> > +static void
> > +txn_limbo_promote_create(struct txn_limbo_promote *pmt)
> > +{
> > +	vclock_create(&pmt->terms_map);
> > +	pmt->terms_max = 0;
> > +}
> > +
> 
> I don't like the name (limbo->promote, struct txn_limbo_promote),
> but can't come up with a better one.
> 
> The structure doesn't hold a specific promote. It's more like "promote
> history", or "terms seen".
> 
> Maybe something like "term history" ? "term tracker" ?
> "remote term set", "term set" ?
> 
> Just a suggestion, my names are not too good.

Sure! How about

struct txn_terms {
	latch		lock;
	vclock_t	map;
	uint64_t	map_max;
};

struct txn_limbo {
	...
	struct txn_terms terms;
	...
};

I don't mind for any name (except "set" because
set can't contain duplicated elements and our
vclock can have same term installed for different
replicas)

	Cyrill

  reply	other threads:[~2021-07-15 11:46 UTC|newest]

Thread overview: 14+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2021-07-14 21:23 [Tarantool-patches] [RFC v5 0/5] limbo: implement packets filtering Cyrill Gorcunov via Tarantool-patches
2021-07-14 21:23 ` [Tarantool-patches] [RFC v5 1/5] latch: add latch_is_locked helper Cyrill Gorcunov via Tarantool-patches
2021-07-15 11:15   ` Serge Petrenko via Tarantool-patches
2021-07-14 21:23 ` [Tarantool-patches] [RFC v5 2/5] say: introduce panic_on helper Cyrill Gorcunov via Tarantool-patches
2021-07-14 21:23 ` [Tarantool-patches] [RFC v5 3/5] limbo: gather promote tracking into a separate structure Cyrill Gorcunov via Tarantool-patches
2021-07-15 11:28   ` Serge Petrenko via Tarantool-patches
2021-07-15 11:46     ` Cyrill Gorcunov via Tarantool-patches [this message]
2021-07-15 12:00       ` Serge Petrenko via Tarantool-patches
2021-07-15 12:20         ` Cyrill Gorcunov via Tarantool-patches
2021-07-14 21:23 ` [Tarantool-patches] [RFC v5 4/5] limbo: order access to the promote terms Cyrill Gorcunov via Tarantool-patches
2021-07-15 11:48   ` Serge Petrenko via Tarantool-patches
2021-07-15 12:20     ` Cyrill Gorcunov via Tarantool-patches
2021-07-14 21:23 ` [Tarantool-patches] [RFC v5 5/5] limbo: filter incoming requests Cyrill Gorcunov via Tarantool-patches
2021-07-15 11:59   ` Serge Petrenko via Tarantool-patches

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=YPAf/tD+0/g4AWXI@grain \
    --to=tarantool-patches@dev.tarantool.org \
    --cc=gorcunov@gmail.com \
    --cc=sergepetrenko@tarantool.org \
    --cc=v.shpilevoy@tarantool.org \
    --subject='Re: [Tarantool-patches] [RFC v5 3/5] limbo: gather promote tracking into a separate structure' \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox