From: Cyrill Gorcunov via Tarantool-patches <tarantool-patches@dev.tarantool.org>
To: Serge Petrenko <sergepetrenko@tarantool.org>
Cc: v.shpilevoy@tarantool.org, tarantool-patches@dev.tarantool.org
Subject: Re: [Tarantool-patches] [PATCH v2 4/9] box: make clear_synchro_queue() write a PROMOTE entry instead of CONFIRM + ROLLBACK
Date: Tue, 13 Apr 2021 17:33:14 +0300 [thread overview]
Message-ID: <YHWrqtwExW4ToM5A@grain> (raw)
In-Reply-To: <150875bcbaaa0b7c270c1d53dc623892312fe16d.1618256019.git.sergepetrenko@tarantool.org>
On Mon, Apr 12, 2021 at 10:40:17PM +0300, Serge Petrenko wrote:
> } else {
> - txn_limbo_force_empty(&txn_limbo, wait_lsn);
> + /*
> + * Term parameter is unused now, We'll pass
> + * box_raft()->term there later.
> + */
> + txn_limbo_write_promote(&txn_limbo, wait_lsn, 0);
> + struct synchro_request req = {
> + .type = 0, /* unused */
> + .replica_id = 0, /* unused */
> + .origin_id = instance_id,
> + .lsn = wait_lsn,
> + .term = 0, /* unused */
> + };
Is there some particular meaning of zeroifying designated assignments?
I mean why not simply
struct synchro_request req = {
.origin_id = instance_id,
.lsn = wait_lsn,
};
or you wanted to pay attention that the left of the fields are
unused? Just curious, I'm fine with current code.
next prev parent reply other threads:[~2021-04-13 14:33 UTC|newest]
Thread overview: 23+ messages / expand[flat|nested] mbox.gz Atom feed top
2021-04-12 19:40 [Tarantool-patches] [PATCH v2 0/9] raft: introduce manual elections and fix a bug with re-applying rolled back transactions Serge Petrenko via Tarantool-patches
2021-04-12 19:40 ` [Tarantool-patches] [PATCH v2 1/9] wal: enrich row's meta information with sync replication flags Serge Petrenko via Tarantool-patches
2021-04-13 11:50 ` Cyrill Gorcunov via Tarantool-patches
2021-04-13 13:51 ` Serge Petrenko via Tarantool-patches
2021-04-13 14:16 ` Cyrill Gorcunov via Tarantool-patches
2021-04-13 13:09 ` Cyrill Gorcunov via Tarantool-patches
2021-04-13 13:29 ` Serge Petrenko via Tarantool-patches
2021-04-12 19:40 ` [Tarantool-patches] [PATCH v2 2/9] xrow: introduce a PROMOTE entry Serge Petrenko via Tarantool-patches
2021-04-13 14:15 ` Cyrill Gorcunov via Tarantool-patches
2021-04-14 9:12 ` Serge Petrenko via Tarantool-patches
2021-04-14 10:00 ` Cyrill Gorcunov via Tarantool-patches
2021-04-12 19:40 ` [Tarantool-patches] [PATCH v2 3/9] box: actualise iproto_key_type array Serge Petrenko via Tarantool-patches
2021-04-12 19:40 ` [Tarantool-patches] [PATCH v2 4/9] box: make clear_synchro_queue() write a PROMOTE entry instead of CONFIRM + ROLLBACK Serge Petrenko via Tarantool-patches
2021-04-13 14:33 ` Cyrill Gorcunov via Tarantool-patches [this message]
2021-04-14 8:23 ` Serge Petrenko via Tarantool-patches
2021-04-14 8:34 ` Cyrill Gorcunov via Tarantool-patches
2021-04-14 9:12 ` Serge Petrenko via Tarantool-patches
2021-04-12 19:40 ` [Tarantool-patches] [PATCH v2 5/9] box: write PROMOTE even for empty limbo Serge Petrenko via Tarantool-patches
2021-04-12 19:40 ` [Tarantool-patches] [PATCH v2 6/9] raft: keep track of greatest known term and filter replication sources based on that Serge Petrenko via Tarantool-patches
2021-04-12 19:40 ` [Tarantool-patches] [PATCH v2 7/9] replication: introduce a new election mode: "manual" Serge Petrenko via Tarantool-patches
2021-04-12 19:40 ` [Tarantool-patches] [PATCH v2 8/9] Support manual elections in `box.ctl.clear_synchro_queue()` Serge Petrenko via Tarantool-patches
2021-04-12 19:40 ` [Tarantool-patches] [PATCH v2 9/9] box.ctl: rename clear_synchro_queue to promote Serge Petrenko via Tarantool-patches
2021-04-13 14:42 ` [Tarantool-patches] [PATCH v2 0/9] raft: introduce manual elections and fix a bug with re-applying rolled back transactions Cyrill Gorcunov via Tarantool-patches
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=YHWrqtwExW4ToM5A@grain \
--to=tarantool-patches@dev.tarantool.org \
--cc=gorcunov@gmail.com \
--cc=sergepetrenko@tarantool.org \
--cc=v.shpilevoy@tarantool.org \
--subject='Re: [Tarantool-patches] [PATCH v2 4/9] box: make clear_synchro_queue() write a PROMOTE entry instead of CONFIRM + ROLLBACK' \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox