From: Cyrill Gorcunov via Tarantool-patches <tarantool-patches@dev.tarantool.org> To: Serge Petrenko <sergepetrenko@tarantool.org> Cc: v.shpilevoy@tarantool.org, tarantool-patches@dev.tarantool.org Subject: Re: [Tarantool-patches] [PATCH v2 2/9] xrow: introduce a PROMOTE entry Date: Tue, 13 Apr 2021 17:15:55 +0300 [thread overview] Message-ID: <YHWnmx3AVRE1EaoY@grain> (raw) In-Reply-To: <6641b0b1f98ff233ccb3a121833cb6363c45edcb.1618256019.git.sergepetrenko@tarantool.org> On Mon, Apr 12, 2021 at 10:40:15PM +0300, Serge Petrenko wrote: > diff --git a/src/box/xrow.c b/src/box/xrow.c > index cc8e43ed4..70ba075f8 100644 > --- a/src/box/xrow.c > +++ b/src/box/xrow.c > @@ -890,11 +890,11 @@ xrow_encode_synchro(struct xrow_header *row, > const struct synchro_request *req) > { > /* > - * A map with two elements. We don't compress > + * A map with two or three elements. We don't compress > * numbers to have this structure constant in size, > * which allows us to preallocate it on stack. > */ > - body->m_body = 0x80 | 2; > + body->m_body = 0x80 | (req->type == IPROTO_PROMOTE ? 3 : 2); > body->k_replica_id = IPROTO_REPLICA_ID; > body->m_replica_id = 0xce; > body->v_replica_id = mp_bswap_u32(req->replica_id); > @@ -903,10 +903,24 @@ xrow_encode_synchro(struct xrow_header *row, > body->v_lsn = mp_bswap_u64(req->lsn); > > memset(row, 0, sizeof(*row)); > - > row->type = req->type; > - row->body[0].iov_base = (void *)body; > - row->body[0].iov_len = sizeof(*body); > + > + /* Promote body is longer. It has an additional IPROTO_TERM field. */ > + if (req->type == IPROTO_PROMOTE) { > + struct promote_body_bin *promote_body = > + (struct promote_body_bin *)body; > + > + promote_body->k_term = IPROTO_TERM; > + promote_body->m_term = 0xcf; > + promote_body->v_term = mp_bswap_u64(req->term); > + > + row->body[0].iov_base = (void *)promote_body; > + row->body[0].iov_len = sizeof(*promote_body); > + } else { > + row->body[0].iov_base = (void *)body; > + row->body[0].iov_len = sizeof(*body); > + } > + > row->bodycnt = 1; > } You know, while I understand that we're trying to reuse code flow here but I really don't like that this function unaware of type passed. IOW the function may easily overwire caller's stack if you occasionally pass synchro_body_bin instead of promote request. Actually I've sevaral options: 1) make the caller to provide a size and use assert() inside this encoder to make sure the caller passer proper amount of data from stack; 2) provide own helper for promote packet encoding (see below). Still both approaches somehow *ugly* I think. Since there only a few use of this encodings it is easy to remember where and what and don't make a mistake. So lets leave it as it now. --- diff --git a/src/box/txn_limbo.c b/src/box/txn_limbo.c index f119c35b6..87fa220ea 100644 --- a/src/box/txn_limbo.c +++ b/src/box/txn_limbo.c @@ -333,8 +333,7 @@ txn_limbo_write_synchro(struct txn_limbo *limbo, uint32_t type, int64_t lsn, * This is a synchronous commit so we can allocate everything on a * stack. Promote body includes synchro body. */ - struct promote_body_bin body; - struct synchro_body_bin *base = &body.base; + struct promote_body_bin body_bin; struct xrow_header row; char buf[sizeof(struct journal_entry) + @@ -343,7 +342,7 @@ txn_limbo_write_synchro(struct txn_limbo *limbo, uint32_t type, int64_t lsn, struct journal_entry *entry = (struct journal_entry *)buf; entry->rows[0] = &row; - xrow_encode_synchro(&row, base, &req); + xrow_encode_promote(&row, &body_bin, &req); journal_entry_create(entry, 1, xrow_approx_len(&row), txn_limbo_write_cb, fiber()); diff --git a/src/box/xrow.c b/src/box/xrow.c index 70ba075f8..df76b104b 100644 --- a/src/box/xrow.c +++ b/src/box/xrow.c @@ -884,16 +884,11 @@ xrow_encode_dml(const struct request *request, struct region *region, return iovcnt; } -void -xrow_encode_synchro(struct xrow_header *row, - struct synchro_body_bin *body, - const struct synchro_request *req) +static void +xrow_encode_synchro_common(struct xrow_header *row, + struct synchro_body_bin *body, + const struct synchro_request *req) { - /* - * A map with two or three elements. We don't compress - * numbers to have this structure constant in size, - * which allows us to preallocate it on stack. - */ body->m_body = 0x80 | (req->type == IPROTO_PROMOTE ? 3 : 2); body->k_replica_id = IPROTO_REPLICA_ID; body->m_replica_id = 0xce; @@ -904,24 +899,32 @@ xrow_encode_synchro(struct xrow_header *row, memset(row, 0, sizeof(*row)); row->type = req->type; + row->bodycnt = 1; +} - /* Promote body is longer. It has an additional IPROTO_TERM field. */ - if (req->type == IPROTO_PROMOTE) { - struct promote_body_bin *promote_body = - (struct promote_body_bin *)body; +void +xrow_encode_promote(struct xrow_header *row, struct promote_body_bin *body, + const struct synchro_request *req) +{ + xrow_encode_synchro_common(row, body, req); - promote_body->k_term = IPROTO_TERM; - promote_body->m_term = 0xcf; - promote_body->v_term = mp_bswap_u64(req->term); + promote_body->k_term = IPROTO_TERM; + promote_body->m_term = 0xcf; + promote_body->v_term = mp_bswap_u64(req->term); - row->body[0].iov_base = (void *)promote_body; - row->body[0].iov_len = sizeof(*promote_body); - } else { - row->body[0].iov_base = (void *)body; - row->body[0].iov_len = sizeof(*body); - } + row->body[0].iov_base = body; + row->body[0].iov_len = sizeof(*body); +} + +void +xrow_encode_synchro(struct xrow_header *row, struct synchro_body_bin *body, + const struct synchro_request *req) +{ + xrow_encode_synchro_common(row, body, req); + + row->body[0].iov_base = body; + row->body[0].iov_len = sizeof(*body); - row->bodycnt = 1; } int
next prev parent reply other threads:[~2021-04-13 14:16 UTC|newest] Thread overview: 23+ messages / expand[flat|nested] mbox.gz Atom feed top 2021-04-12 19:40 [Tarantool-patches] [PATCH v2 0/9] raft: introduce manual elections and fix a bug with re-applying rolled back transactions Serge Petrenko via Tarantool-patches 2021-04-12 19:40 ` [Tarantool-patches] [PATCH v2 1/9] wal: enrich row's meta information with sync replication flags Serge Petrenko via Tarantool-patches 2021-04-13 11:50 ` Cyrill Gorcunov via Tarantool-patches 2021-04-13 13:51 ` Serge Petrenko via Tarantool-patches 2021-04-13 14:16 ` Cyrill Gorcunov via Tarantool-patches 2021-04-13 13:09 ` Cyrill Gorcunov via Tarantool-patches 2021-04-13 13:29 ` Serge Petrenko via Tarantool-patches 2021-04-12 19:40 ` [Tarantool-patches] [PATCH v2 2/9] xrow: introduce a PROMOTE entry Serge Petrenko via Tarantool-patches 2021-04-13 14:15 ` Cyrill Gorcunov via Tarantool-patches [this message] 2021-04-14 9:12 ` Serge Petrenko via Tarantool-patches 2021-04-14 10:00 ` Cyrill Gorcunov via Tarantool-patches 2021-04-12 19:40 ` [Tarantool-patches] [PATCH v2 3/9] box: actualise iproto_key_type array Serge Petrenko via Tarantool-patches 2021-04-12 19:40 ` [Tarantool-patches] [PATCH v2 4/9] box: make clear_synchro_queue() write a PROMOTE entry instead of CONFIRM + ROLLBACK Serge Petrenko via Tarantool-patches 2021-04-13 14:33 ` Cyrill Gorcunov via Tarantool-patches 2021-04-14 8:23 ` Serge Petrenko via Tarantool-patches 2021-04-14 8:34 ` Cyrill Gorcunov via Tarantool-patches 2021-04-14 9:12 ` Serge Petrenko via Tarantool-patches 2021-04-12 19:40 ` [Tarantool-patches] [PATCH v2 5/9] box: write PROMOTE even for empty limbo Serge Petrenko via Tarantool-patches 2021-04-12 19:40 ` [Tarantool-patches] [PATCH v2 6/9] raft: keep track of greatest known term and filter replication sources based on that Serge Petrenko via Tarantool-patches 2021-04-12 19:40 ` [Tarantool-patches] [PATCH v2 7/9] replication: introduce a new election mode: "manual" Serge Petrenko via Tarantool-patches 2021-04-12 19:40 ` [Tarantool-patches] [PATCH v2 8/9] Support manual elections in `box.ctl.clear_synchro_queue()` Serge Petrenko via Tarantool-patches 2021-04-12 19:40 ` [Tarantool-patches] [PATCH v2 9/9] box.ctl: rename clear_synchro_queue to promote Serge Petrenko via Tarantool-patches 2021-04-13 14:42 ` [Tarantool-patches] [PATCH v2 0/9] raft: introduce manual elections and fix a bug with re-applying rolled back transactions Cyrill Gorcunov via Tarantool-patches
Reply instructions: You may reply publicly to this message via plain-text email using any one of the following methods: * Save the following mbox file, import it into your mail client, and reply-to-all from there: mbox Avoid top-posting and favor interleaved quoting: https://en.wikipedia.org/wiki/Posting_style#Interleaved_style * Reply using the --to, --cc, and --in-reply-to switches of git-send-email(1): git send-email \ --in-reply-to=YHWnmx3AVRE1EaoY@grain \ --to=tarantool-patches@dev.tarantool.org \ --cc=gorcunov@gmail.com \ --cc=sergepetrenko@tarantool.org \ --cc=v.shpilevoy@tarantool.org \ --subject='Re: [Tarantool-patches] [PATCH v2 2/9] xrow: introduce a PROMOTE entry' \ /path/to/YOUR_REPLY https://kernel.org/pub/software/scm/git/docs/git-send-email.html * If your mail client supports setting the In-Reply-To header via mailto: links, try the mailto: link
This is a public inbox, see mirroring instructions for how to clone and mirror all data and code used for this inbox