From: Roman Khabibov <roman.habibov@tarantool.org> To: Vladislav Shpilevoy <v.shpilevoy@tarantool.org> Cc: tarantool-patches@dev.tarantool.org Subject: Re: [Tarantool-patches] [PATCH v3 1/4] sql: rename TK_COLUMN to TK_COLUMN_NAME Date: Sat, 12 Sep 2020 00:51:53 +0300 [thread overview] Message-ID: <A3C44C64-F988-4138-B7B4-A11D22557CA5@tarantool.org> (raw) In-Reply-To: <f0956d2d-e61a-9019-d4c1-b44f5cf9d60a@tarantool.org> Hi! Thanks for the review. > On Aug 20, 2020, at 01:20, Vladislav Shpilevoy <v.shpilevoy@tarantool.org> wrote: > > Thanks for the patch! > >> diff --git a/src/box/sql/sqlInt.h b/src/box/sql/sqlInt.h >> index adf90d824..beb83ce95 100644 >> --- a/src/box/sql/sqlInt.h >> +++ b/src/box/sql/sqlInt.h >> @@ -1587,20 +1587,20 @@ struct Expr { >> #if SQL_MAX_EXPR_DEPTH>0 >> int nHeight; /* Height of the tree headed by this node */ >> #endif >> - int iTable; /* TK_COLUMN: cursor number of table holding column >> + int iTable; /* TK_COLUMN_NAME: cursor number of table holding column >> * TK_REGISTER: register number >> * TK_TRIGGER: 1 -> new, 0 -> old >> * EP_Unlikely: 134217728 times likelihood >> * TK_SELECT: 1st register of result vector >> */ >> - ynVar iColumn; /* TK_COLUMN: column index. >> + ynVar iColumn; /* TK_COLUMN_NAME: column index. > > Does not this look wrong to you? - 'COLUMN_NAME: column index'. In > some other places TK_COLUMN_NAME also designates presense of a column > index, not name. Probably a better name would be TK_COLUMN_REF. > Ok. Done. >> * TK_VARIABLE: variable number (always >= 1). >> * TK_SELECT_COLUMN: column of the result vector >> */ >> i16 iAgg; /* Which entry in pAggInfo->aCol[] or ->aFunc[] */ >> i16 iRightJoinTable; /* If EP_FromJoin, the right table of the join */ >> u8 op2; /* TK_REGISTER: original value of Expr.op >> - * TK_COLUMN: the value of p5 for OP_Column >> + * TK_COLUMN_NAME: the value of p5 for OP_Column >> * TK_AGG_FUNCTION: nesting depth >> */ >> AggInfo *pAggInfo; /* Used by TK_AGG_COLUMN and TK_AGG_FUNCTION */
next prev parent reply other threads:[~2020-09-11 21:51 UTC|newest] Thread overview: 9+ messages / expand[flat|nested] mbox.gz Atom feed top 2020-08-11 0:33 [Tarantool-patches] [PATCH v3 0/4] Support ALTER TABLE ADD COLUMN Roman Khabibov 2020-08-11 0:33 ` [Tarantool-patches] [PATCH v3 1/4] sql: rename TK_COLUMN to TK_COLUMN_NAME Roman Khabibov 2020-08-19 22:20 ` Vladislav Shpilevoy 2020-09-11 21:51 ` Roman Khabibov [this message] 2020-08-11 0:33 ` [Tarantool-patches] [PATCH v3 2/4] sql: refactor create_table_def and parse Roman Khabibov 2020-08-11 0:33 ` [Tarantool-patches] [PATCH v3 3/4] schema: add box_space_field_MAX Roman Khabibov 2020-08-11 0:33 ` [Tarantool-patches] [PATCH v3 4/4] sql: support column addition Roman Khabibov 2020-08-19 22:20 ` Vladislav Shpilevoy 2020-09-11 21:51 ` Roman Khabibov
Reply instructions: You may reply publicly to this message via plain-text email using any one of the following methods: * Save the following mbox file, import it into your mail client, and reply-to-all from there: mbox Avoid top-posting and favor interleaved quoting: https://en.wikipedia.org/wiki/Posting_style#Interleaved_style * Reply using the --to, --cc, and --in-reply-to switches of git-send-email(1): git send-email \ --in-reply-to=A3C44C64-F988-4138-B7B4-A11D22557CA5@tarantool.org \ --to=roman.habibov@tarantool.org \ --cc=tarantool-patches@dev.tarantool.org \ --cc=v.shpilevoy@tarantool.org \ --subject='Re: [Tarantool-patches] [PATCH v3 1/4] sql: rename TK_COLUMN to TK_COLUMN_NAME' \ /path/to/YOUR_REPLY https://kernel.org/pub/software/scm/git/docs/git-send-email.html * If your mail client supports setting the In-Reply-To header via mailto: links, try the mailto: link
This is a public inbox, see mirroring instructions for how to clone and mirror all data and code used for this inbox