Tarantool development patches archive
 help / color / mirror / Atom feed
[Tarantool-patches] [PATCH 0/2] reduce performance degradation introduced by JSON path indices
 2020-11-20 23:26 UTC  (7+ messages)
` [Tarantool-patches] [PATCH 1/2] box: speed up tuple_field_map_create
` [Tarantool-patches] [PATCH 2/2] box: use tuple_field_raw_by_part where possible

[Tarantool-patches] [PATCH 1/1] swim: don't call swim_quit via FFI
 2020-11-20 22:42 UTC 

[Tarantool-patches] [PATCH v2 00/16] Raft module, part 2 - relocation to src/lib/raft
 2020-11-20 19:42 UTC  (24+ messages)
` [Tarantool-patches] [PATCH v2 01/16] raft: move sources to raftlib.h/.c
` [Tarantool-patches] [PATCH v2 10/16] raft: make worker non-cancellable during WAL write
` [Tarantool-patches] [PATCH v2 11/16] raft: move worker fiber from Raft library to box
` [Tarantool-patches] [PATCH v2 12/16] raft: move synchro queue clear to the worker fiber
` [Tarantool-patches] [PATCH v2 13/16] raft: invoke update triggers within state machine
` [Tarantool-patches] [PATCH v2 14/16] raft: move RO summary update to box-Raft
` [Tarantool-patches] [PATCH v2 15/16] raft: introduce RaftError
` [Tarantool-patches] [PATCH v2 16/16] raft: move algorithm code to src/lib/raft
` [Tarantool-patches] [PATCH v2 02/16] raft: move box_raft_* to src/box/raft.h and .c
` [Tarantool-patches] [PATCH v2 03/16] raft: stop using replication_disconnect_timeout()
` [Tarantool-patches] [PATCH v2 04/16] raft: stop using replication_synchro_quorum
` [Tarantool-patches] [PATCH v2 05/16] raft: stop using instance_id
` [Tarantool-patches] [PATCH v2 06/16] raft: make raft_request.vclock constant
` [Tarantool-patches] [PATCH v2 07/16] raft: stop using replicaset.vclock
` [Tarantool-patches] [PATCH v2 08/16] raft: introduce vtab for disk and network
` [Tarantool-patches] [PATCH v2 09/16] raft: introduce raft_msg, drop xrow dependency

[Tarantool-patches] [PATCH 00/12] Raft module, part 2 - relocation to src/lib/raft
 2020-11-20 19:40 UTC  (36+ messages)
` [Tarantool-patches] [PATCH 01/12] raft: move sources to raftlib.h/.c
` [Tarantool-patches] [PATCH 10/12] raft: move box_update_ro_summary to update trigger
` [Tarantool-patches] [PATCH 11/12] raft: introduce RaftError
` [Tarantool-patches] [PATCH 12/12] raft: move algorithm code to src/lib/raft
` [Tarantool-patches] [PATCH 02/12] raft: move box_raft_* to src/box/raft.h and .c
` [Tarantool-patches] [PATCH 03/12] raft: stop using replication_disconnect_timeout()
` [Tarantool-patches] [PATCH 04/12] raft: stop using replication_synchro_quorum
` [Tarantool-patches] [PATCH 05/12] raft: stop using instance_id
` [Tarantool-patches] [PATCH 06/12] raft: make raft_request.vclock constant
` [Tarantool-patches] [PATCH 07/12] raft: stop using replicaset.vclock
` [Tarantool-patches] [PATCH 08/12] raft: introduce vtab for disk and network
` [Tarantool-patches] [PATCH 09/12] raft: introduce raft_msg, drop xrow dependency

[Tarantool-patches] [test-run] Add options for upgrade testing
 2020-11-20 19:27 UTC  (14+ messages)
            ` [Tarantool-patches] [PATCH] "

[Tarantool-patches] [PATCH 1/1] test: fix flaky unit/swim test
 2020-11-20 18:10 UTC  (3+ messages)

[Tarantool-patches] [PATCH v2] luacheck: change global vars to local in sql-tap
 2020-11-20 16:34 UTC 

[Tarantool-patches] [RFC 0/4] qsync: evaluate replication_synchro_quorum dynamically
 2020-11-20 15:00 UTC  (18+ messages)
` [Tarantool-patches] [RFC 1/4] cfg: add cfg_isnumber helper
` [Tarantool-patches] [RFC 2/4] qsync: move synchro quorum update to separate routine
` [Tarantool-patches] [RFC 3/4] cfg: prepare symbolic evaluation of replication_synchro_quorum
` [Tarantool-patches] [RFC 4/4] qsync: allow to specify replication_synchro_quorum as a formula

[Tarantool-patches] [PATCH] sql: forbid data changes in read-only mode
 2020-11-20 13:47 UTC  (7+ messages)

[Tarantool-patches] [PATCH v1] test: add flaky tests results files checksums
 2020-11-20 13:45 UTC 

[Tarantool-patches] [PATCH 0/2] GCC 10 warnings
 2020-11-20  2:23 UTC  (3+ messages)
` [Tarantool-patches] [PATCH 1/2] sql: fix build with GCC 10
` [Tarantool-patches] [PATCH 2/2] bitset: fix GCC 10 build

[Tarantool-patches] [PATCH] console: drop unused serpent module
 2020-11-19 20:52 UTC  (4+ messages)

[Tarantool-patches] [PATCH] lua/merger: fix NULL dereferences on error paths
 2020-11-19  8:15 UTC  (8+ messages)

[Tarantool-patches] [PATCH v2 0/2] Support column addition with <ALTER TABLE>
 2020-11-18 23:07 UTC  (3+ messages)

[Tarantool-patches] [PATCH v2] core: handle fiber cancellation for fiber.cond
 2020-11-18 22:05 UTC  (10+ messages)

[Tarantool-patches] [PATCH] func: clean the module cache on first load error
 2020-11-18 21:30 UTC  (3+ messages)

[Tarantool-patches] [PATCH v4 0/5] Support column addition
 2020-11-18 16:15 UTC  (14+ messages)
` [Tarantool-patches] [PATCH v4 2/5] sql: refactor create_table_def and parse
` [Tarantool-patches] [PATCH v4 4/5] sql: use parser's region of "index" array
  ` [Tarantool-patches] [PATCH v4 5/5] sql: support column addition

[Tarantool-patches] [PATCH v2 0/2] Make uuid values comparable
 2020-11-18  8:02 UTC  (4+ messages)
` [Tarantool-patches] [PATCH v2 1/2] uuid: support comparison of uuid values in Lua
` [Tarantool-patches] [PATCH v2 2/2] uuid: support uuid comparison with strings

[Tarantool-patches] [PATCH] lua: introduce function for uuid comparison
 2020-11-18  8:02 UTC  (8+ messages)

[Tarantool-patches] [PATCH] vinyl: update gh-4957-too-many-upserts test
 2020-11-17 20:26 UTC  (6+ messages)

[Tarantool-patches] [PATCH] serializer: check for recursive serialization
 2020-11-17 16:40 UTC 

[Tarantool-patches] [PATCH 0/4 v3] Additional qsync tests
 2020-11-17 16:13 UTC  (5+ messages)
` [Tarantool-patches] [PATCH 1/4] replication: run clear_synchro_queue() with unconfigured box
` [Tarantool-patches] [PATCH 2/4] replication: test clear_synchro_queue() function
` [Tarantool-patches] [PATCH 3/4] replication: add test with random leaders promotion and demotion
` [Tarantool-patches] [PATCH 4/4] replication: add test with change space sync mode in a loop

[Tarantool-patches] [PATCH v1] test: flaky hang vinyl/ddl.test.lua test
 2020-11-17 15:34 UTC 

[Tarantool-patches] [PATCH] raft: execute triggers exactly on state change
 2020-11-17 15:16 UTC 

[Tarantool-patches] [PATCH v1] test: fix hang of vinyl/select_consistency.* test
 2020-11-16 21:06 UTC  (2+ messages)

[Tarantool-patches] [PATCH v10 0/4] box/cbox: implement cfunc Lua module
 2020-11-16 20:26 UTC  (13+ messages)
` [Tarantool-patches] [PATCH v10 1/4] box/func: factor out c function entry structure
` [Tarantool-patches] [PATCH v10 2/4] module_cache: move module handling into own subsystem
` [Tarantool-patches] [PATCH v10 3/4] box/cbox: implement cbox Lua module

[Tarantool-patches] [PATCH 0/3 v2] Additional qsync tests
 2020-11-16 16:04 UTC  (14+ messages)
` [Tarantool-patches] [PATCH 1/3 v2] replication: test clear_synchro_queue() function
` [Tarantool-patches] [PATCH 2/3 v2] replication: add test with random leaders promotion and demotion
` [Tarantool-patches] [PATCH 3/3 v2] replication: add test with change space sync mode in a loop

[Tarantool-patches] [PATCH 00/11] qsync: code refactoring
 2020-11-16 13:09 UTC  (26+ messages)
` [Tarantool-patches] [PATCH 01/11] build: add more ignore paths for tags target
` [Tarantool-patches] [PATCH 03/11] vclock: vclock_inc -- add assert() to catch overflow
` [Tarantool-patches] [PATCH 04/11] txn: txn_commit_async -- drop redundant variable
` [Tarantool-patches] [PATCH 05/11] qsync: rename txn_limbo::instance_id to owner_id
` [Tarantool-patches] [PATCH 06/11] qsync: txn_limbo_append -- use owner_id in argument name
` [Tarantool-patches] [PATCH 07/11] qsync: move limbo owner transition into separate helper
` [Tarantool-patches] [PATCH 08/11] qsync: txn_limbo_wait_confirm -- refactor code a bit
` [Tarantool-patches] [PATCH 09/11] qsync: drop redundant type convention
` [Tarantool-patches] [PATCH 10/11] relay: use verbose names for fibers
` [Tarantool-patches] [PATCH 11/11] raft: drop redundant argument

[Tarantool-patches] [PATCH v1] test: flaky hang vinyl/ddl.test.lua test
 2020-11-16 10:31 UTC 

[Tarantool-patches] [PATCH v1 1/1] lua: replace tonumber64() with misc.tonumber64()
 2020-11-16  9:34 UTC 

[Tarantool-patches] [PATCH v1 1/1] misc: introduce misc.tonumber64()
 2020-11-16  9:34 UTC 

[Tarantool-patches] [PATCH] box: check schema version after tarantool update
 2020-11-15 23:54 UTC 

[Tarantool-patches] [PATCH] raft: use vclock_map_t for voting tracking
 2020-11-13 22:42 UTC  (2+ messages)

[Tarantool-patches] [PATCH v5] core: introduce evenly distributed int64 random in range
 2020-11-13 22:30 UTC  (2+ messages)

[Tarantool-patches] [PATCH v8 0/4] box/cbox: implement cfunc Lua module
 2020-11-13 18:30 UTC  (5+ messages)
` [Tarantool-patches] [PATCH v8 3/4] box/cbox: implement cbox "

[Tarantool-patches] [PATCH v4] core: introduce evenly distributed int64 random in range
 2020-11-13 11:54 UTC  (3+ messages)

[Tarantool-patches] [PATCH v1] test: fix flaky election_qsync_stress test
 2020-11-13  9:18 UTC  (2+ messages)

page:  |  | latest

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox