Tarantool development patches archive
 help / color / mirror / Atom feed
From: "n.pettik" <korablev@tarantool.org>
To: Vladislav Shpilevoy <v.shpilevoy@tarantool.org>
Cc: tarantool-patches@freelists.org
Subject: [tarantool-patches] Re: [PATCH 1/2] sql: remove obsolete SQLite routine
Date: Thu, 5 Apr 2018 15:13:19 +0300	[thread overview]
Message-ID: <92A16559-3B03-4971-A095-841AE57BD4E0@tarantool.org> (raw)
In-Reply-To: <8234232f-13ed-cc02-b54a-0feb6b2ef4f5@tarantool.org>


> On 5 Apr 2018, at 14:16, Vladislav Shpilevoy <v.shpilevoy@tarantool.org> wrote:
> 
> 
>>> Same about checking sqlite3HashFind results. And if it is
>>> possible with not huge diff, can you please rename sqlite3HashFind to sql_hash_find ?
>> 
>> Is it worth doing? It is going to disappear soon.
> Ok, then lets leave as is.
>> @@ -1146,7 +1147,7 @@ analyzeTable(Parse * pParse, Table * pTab, Index * pOnlyIdx)
>> int iStatCur;
>> assert(pTab != 0);
>> -sql_set_multi_write(pParse, 0);
>> +sql_set_multi_write(pParse, true);
> 1. Typo? 0 != true.

Typo. Fixed on branch:

 -       sql_set_multi_write(pParse, true);
+       sql_set_multi_write(pParse, false);

>> @@ -1769,9 +1769,8 @@ xferOptimization(Parse * pParse,/* Parser context */
>> int regData, regTupleid;/* Registers holding data and tupleid */
>> struct session *user_session = current_session();
>> -if (pSelect == 0) {
>> +if (pSelect == 0)
> 2. == NULL.

Typo. Fixed on branch:

-       if (pSelect == 0)
+       if (pSelect == NULL)

  reply	other threads:[~2018-04-05 12:13 UTC|newest]

Thread overview: 12+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2018-04-03 16:14 [tarantool-patches] [PATCH 0/2] rework SQL 'DROP' routine Nikita Pettik
2018-04-03 16:14 ` [tarantool-patches] [PATCH 1/2] sql: remove obsolete SQLite routine Nikita Pettik
2018-04-03 17:54   ` [tarantool-patches] " Vladislav Shpilevoy
2018-04-04 18:09     ` n.pettik
2018-04-05 11:16       ` Vladislav Shpilevoy
2018-04-05 12:13         ` n.pettik [this message]
2018-04-05 13:28           ` Vladislav Shpilevoy
2018-04-03 16:14 ` [tarantool-patches] [PATCH 2/2] sql: rework 'DROP INDEX' and 'DROP TABLE' handling Nikita Pettik
2018-04-03 18:27   ` [tarantool-patches] " Vladislav Shpilevoy
2018-04-04 18:11     ` n.pettik
2018-04-05 11:20       ` Vladislav Shpilevoy
2018-04-05 14:12 ` [tarantool-patches] Re: [PATCH 0/2] rework SQL 'DROP' routine Kirill Yukhin

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=92A16559-3B03-4971-A095-841AE57BD4E0@tarantool.org \
    --to=korablev@tarantool.org \
    --cc=tarantool-patches@freelists.org \
    --cc=v.shpilevoy@tarantool.org \
    --subject='[tarantool-patches] Re: [PATCH 1/2] sql: remove obsolete SQLite routine' \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox