Tarantool development patches archive
 help / color / mirror / Atom feed
From: Vladislav Shpilevoy <v.shpilevoy@tarantool.org>
To: tarantool-patches@freelists.org
Subject: [tarantool-patches] Re: [PATCH 3/5] sql: use 'varbinary' as a name of type instead of 'blob'
Date: Fri, 26 Jul 2019 00:11:14 +0200	[thread overview]
Message-ID: <8d445bae-53ae-5a62-f0c8-84a655789c3e@tarantool.org> (raw)
In-Reply-To: <dfb06eacfd92a9f76ab6c638f1549b6beb37d794.1563967510.git.korablev@tarantool.org>





On 24/07/2019 13:42, Nikita Pettik wrote:
> We are going to introduce new column type 'VARBINARY', which allows to
> store values with MP_BIN msgpack format. On the other hand, now it is also
> possible to meet this type: all literals in form of x'...' are
> supposed to be inserted into SCALAR column type exactly with MP_BIN
> encoding. Prior to this moment type of such values (encoded as MP_BIN)
> was called 'blob'. Thus, let's fix all visible to user messages using
> 'varbinary' name of type instead of 'blob'.
> ---
>  src/box/lua/lua_sql.c          |  2 +-
>  src/box/sql/func.c             |  4 ++--
>  src/box/sql/vdbe.c             |  4 ++--
>  src/box/sql/vdbeapi.c          |  4 ++--
>  test/sql-tap/cast.test.lua     |  4 ++--
>  test/sql-tap/func.test.lua     |  2 +-
>  test/sql-tap/lua_sql.test.lua  |  4 ++--
>  test/sql-tap/position.test.lua | 16 ++++++++--------
>  test/sql/types.result          | 24 ++++++++++++------------
>  9 files changed, 32 insertions(+), 32 deletions(-)

More mentionings of blob in messages visible to user.

func.c   :540, :1185, :1254, :1753
vdbeapi.c:283, :382,  :1061
vdbemem.c:996, :1022
vdbeaux.c:1192

  reply	other threads:[~2019-07-25 22:09 UTC|newest]

Thread overview: 22+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2019-07-24 11:42 [tarantool-patches] [PATCH 0/5] Introduce VARBINARY in SQL Nikita Pettik
2019-07-24 11:42 ` [tarantool-patches] [PATCH 1/5] sql: always erase numeric flag after stringifying Nikita Pettik
2019-07-24 11:42 ` [tarantool-patches] [PATCH 2/5] sql: fix resulting type calculation for CASE-WHEN stmt Nikita Pettik
2019-07-25 22:12   ` [tarantool-patches] " Vladislav Shpilevoy
     [not found]   ` <a061e845-eeb1-00d1-9141-3b9bb87768f5@tarantool.org>
2019-07-28 23:56     ` n.pettik
2019-07-24 11:42 ` [tarantool-patches] [PATCH 3/5] sql: use 'varbinary' as a name of type instead of 'blob' Nikita Pettik
2019-07-25 22:11   ` Vladislav Shpilevoy [this message]
     [not found]   ` <2e655514-0fec-8baf-20a8-d49e5586b047@tarantool.org>
2019-07-28 23:56     ` [tarantool-patches] " n.pettik
2019-07-29 21:03       ` Vladislav Shpilevoy
2019-07-30 13:43         ` n.pettik
2019-07-24 11:42 ` [tarantool-patches] [PATCH 4/5] sql: make built-ins raise errors for varbin args Nikita Pettik
2019-07-25 22:11   ` [tarantool-patches] " Vladislav Shpilevoy
     [not found]   ` <05d15035-2552-1f05-b7ce-facfbbc3a520@tarantool.org>
2019-07-28 23:59     ` n.pettik
2019-07-24 11:42 ` [tarantool-patches] [PATCH 5/5] sql: introduce VARBINARY column type Nikita Pettik
2019-07-25 22:12   ` [tarantool-patches] " Vladislav Shpilevoy
     [not found]   ` <49a188eb-dafe-44e7-a0fd-e9244b68e721@tarantool.org>
2019-07-29  0:03     ` n.pettik
2019-07-29 20:55       ` Vladislav Shpilevoy
2019-07-30 13:44         ` n.pettik
2019-07-30 19:41           ` Vladislav Shpilevoy
2019-07-30 19:52             ` Vladislav Shpilevoy
2019-07-31 14:51               ` n.pettik
2019-08-01  8:42 ` [tarantool-patches] Re: [PATCH 0/5] Introduce VARBINARY in SQL Kirill Yukhin

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=8d445bae-53ae-5a62-f0c8-84a655789c3e@tarantool.org \
    --to=v.shpilevoy@tarantool.org \
    --cc=tarantool-patches@freelists.org \
    --subject='[tarantool-patches] Re: [PATCH 3/5] sql: use '\''varbinary'\'' as a name of type instead of '\''blob'\''' \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox