Tarantool development patches archive
 help / color / mirror / Atom feed
From: Oleg Babin <olegrok@tarantool.org>
To: Cyrill Gorcunov <gorcunov@gmail.com>,
	tml <tarantool-patches@dev.tarantool.org>
Subject: Re: [Tarantool-patches] [PATCH 0/7] box/console: add support for internal types
Date: Fri, 8 May 2020 19:04:26 +0300	[thread overview]
Message-ID: <7d39ce8a-3c12-a814-9bb3-8d43bfc6f782@tarantool.org> (raw)
In-Reply-To: <20200508114714.426908-1-gorcunov@gmail.com>

Hi! Thanks for patchset! I have a few comments.

I'm not sure that we should return errors in such way:
```
tarantool> x
{error = "[string \"return x\"]:1: variable \'x\' is not declared"};
```

Or is it expected behaviour?

Also `nil` value is ignored in some cases.
```
tarantool> nil
;
tarantool> nil, 2, 3
;
tarantool> 1, nil, 3
1, nil, 3;
```

And I've met strange output:
```
tarantool> box.space.test.index
{[0] = {unique = true, parts = {{type = "integer", is_nullable = 
"false", fieldno = "3"}, {type = "unsigned", is_nullable = "false", 
fieldno = "5"}}, type = "TREE", id = "0", space_id = "520", name = 
"id"}, [1] = {unique = false, parts = {{type = "unsigned", is_nullable = 
"false", fieldno = "1"}}, id = 1, space_id = 520, type = "TREE", name = 
"bucket_id"}, [bucket_id]1
  = !!!*anchor[id]0
  = !!!*anchor};
```

"!!!*anchor" looks strange. Seems it occurs when you mix map and array.

On 08/05/2020 14:47, Cyrill Gorcunov wrote:
> In the series we implement support for internal taranool types
> such as ULL. To be able to do so we implement own serializer
> thus the output is simiar to encodings in yaml mode.
> 
> Once things settle down we will drop serpent module. I guess
> I need to explain why serpent didn't fit: there is no interface
> inside serpent to fetch internal tarantool types and adding it
> means more work to do than implement an own serializer.
> 
> issue https://github.com/tarantool/tarantool/issues/4682
> branch gorcunov/gh-4682-console-numbers
> 
> Cyrill Gorcunov (7):
>    box/console: console_session_vtab -- use designated initialization
>    box/console: use tabs instead of spaces in consolelib
>    box/console: rename format to format_yaml
>    box/console: rename luaL_yaml_default to serializer_yaml
>    box/console: implement lua serializer
>    box/console: switch to new lua serializer
>    test: extend console lua test
> 
>   src/box/CMakeLists.txt            |    1 +
>   src/box/lua/console.c             |  111 +++-
>   src/box/lua/console.lua           |   75 +--
>   src/box/lua/serialize_lua.c       | 1021 +++++++++++++++++++++++++++++
>   src/box/lua/serialize_lua.h       |   67 ++
>   test/app-tap/console_lua.test.lua |   28 +-
>   6 files changed, 1238 insertions(+), 65 deletions(-)
>   create mode 100644 src/box/lua/serialize_lua.c
>   create mode 100644 src/box/lua/serialize_lua.h
> 

  parent reply	other threads:[~2020-05-08 16:04 UTC|newest]

Thread overview: 15+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2020-05-08 11:47 Cyrill Gorcunov
2020-05-08 11:47 ` [Tarantool-patches] [PATCH 1/7] box/console: console_session_vtab -- use designated initialization Cyrill Gorcunov
2020-05-08 11:47 ` [Tarantool-patches] [PATCH 2/7] box/console: use tabs instead of spaces in consolelib Cyrill Gorcunov
2020-05-08 11:47 ` [Tarantool-patches] [PATCH 3/7] box/console: rename format to format_yaml Cyrill Gorcunov
2020-05-08 11:47 ` [Tarantool-patches] [PATCH 4/7] box/console: rename luaL_yaml_default to serializer_yaml Cyrill Gorcunov
2020-05-08 11:47 ` [Tarantool-patches] [PATCH 5/7] box/console: implement lua serializer Cyrill Gorcunov
2020-05-08 11:47 ` [Tarantool-patches] [PATCH 6/7] box/console: switch to new " Cyrill Gorcunov
2020-05-08 11:47 ` [Tarantool-patches] [PATCH 7/7] test: extend console lua test Cyrill Gorcunov
2020-05-08 16:04 ` Oleg Babin [this message]
2020-05-08 16:19   ` [Tarantool-patches] [PATCH 0/7] box/console: add support for internal types Cyrill Gorcunov
2020-05-12 17:06     ` Mons Anderson
2020-05-12 17:31       ` Cyrill Gorcunov
2020-05-12 13:53 ` Cyrill Gorcunov
2020-05-12 13:50 Cyrill Gorcunov
2020-05-18 12:46 ` Kirill Yukhin

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=7d39ce8a-3c12-a814-9bb3-8d43bfc6f782@tarantool.org \
    --to=olegrok@tarantool.org \
    --cc=gorcunov@gmail.com \
    --cc=tarantool-patches@dev.tarantool.org \
    --subject='Re: [Tarantool-patches] [PATCH 0/7] box/console: add support for internal types' \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox