Tarantool development patches archive
 help / color / mirror / Atom feed
* [tarantool-patches] [PATCH v2 0/4] Introduce row_count() function
@ 2018-11-13 16:11 Nikita Pettik
  2018-11-13 16:11 ` [tarantool-patches] [PATCH v2 1/4] sql: don't increment row count on FK creation within CREATE TABLE Nikita Pettik
                   ` (4 more replies)
  0 siblings, 5 replies; 13+ messages in thread
From: Nikita Pettik @ 2018-11-13 16:11 UTC (permalink / raw)
  To: tarantool-patches; +Cc: v.shpilevoy, Nikita Pettik

Branch: https://github.com/tarantool/tarantool/commits/np/gh-2181-rework-change-counter-v2
Issue: https://github.com/tarantool/tarantool/issues/2181

This patch-set slightly fixes behaviour of changes() function (in
order to be closer to ROW_COUNT analogue from ANSI SQL), renames
it row_count() and removes total_changes() function.

All these changes take place according to comments in @dev
mailing list.

Changes in v2:

Actually, it is kind of completely independent approach and it has
nothing in common with first iteration (which was aimed at dealing
with behaviour of total_changes() during transaction).

Nikita Pettik (4):
  sql: don't increment row count on FK creation within CREATE TABLE
  sql: account REPLACE as two row changes
  sql: remove total_changes() function
  sql: rename changes() to row_count()

 src/box/execute.c           |   2 +-
 src/box/sql/build.c         |   3 +-
 src/box/sql/func.c          |  34 +---------
 src/box/sql/insert.c        |   2 +-
 src/box/sql/main.c          |  32 ++-------
 src/box/sql/sqliteInt.h     |  15 +++--
 src/box/sql/vdbeaux.c       |  16 ++---
 test/sql/row-count.result   | 157 ++++++++++++++++++++++++++++++++++++++++++++
 test/sql/row-count.test.lua |  54 +++++++++++++++
 9 files changed, 237 insertions(+), 78 deletions(-)
 create mode 100644 test/sql/row-count.result
 create mode 100644 test/sql/row-count.test.lua

-- 
2.15.1

^ permalink raw reply	[flat|nested] 13+ messages in thread

end of thread, other threads:[~2018-11-15  5:06 UTC | newest]

Thread overview: 13+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2018-11-13 16:11 [tarantool-patches] [PATCH v2 0/4] Introduce row_count() function Nikita Pettik
2018-11-13 16:11 ` [tarantool-patches] [PATCH v2 1/4] sql: don't increment row count on FK creation within CREATE TABLE Nikita Pettik
2018-11-14 12:32   ` [tarantool-patches] " Vladislav Shpilevoy
2018-11-14 16:20     ` n.pettik
2018-11-13 16:11 ` [tarantool-patches] [PATCH v2 2/4] sql: account REPLACE as two row changes Nikita Pettik
2018-11-14 12:32   ` [tarantool-patches] " Vladislav Shpilevoy
2018-11-14 16:20     ` n.pettik
2018-11-13 16:11 ` [tarantool-patches] [PATCH v2 3/4] sql: remove total_changes() function Nikita Pettik
2018-11-13 16:11 ` [tarantool-patches] [PATCH v2 4/4] sql: rename changes() to row_count() Nikita Pettik
2018-11-14 12:32   ` [tarantool-patches] " Vladislav Shpilevoy
2018-11-14 16:20     ` n.pettik
2018-11-14 16:43       ` Vladislav Shpilevoy
2018-11-15  5:06 ` [tarantool-patches] Re: [PATCH v2 0/4] Introduce row_count() function Kirill Yukhin

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox