From: Oleg Babin <olegrok@tarantool.org>
To: Cyrill Gorcunov <gorcunov@gmail.com>,
tml <tarantool-patches@dev.tarantool.org>
Subject: Re: [Tarantool-patches] [PATCH 3/7] box/console: rename format to format_yaml
Date: Mon, 18 May 2020 15:04:49 +0300 [thread overview]
Message-ID: <3474ae26-0362-02d9-dc9f-81a7d265fc06@tarantool.org> (raw)
In-Reply-To: <20200512135052.221379-4-gorcunov@gmail.com>
LGTM
On 12/05/2020 16:50, Cyrill Gorcunov wrote:
> This will allow us to implement own formatter for
> Lua output mode, so to be precise which exactly formatter
> is caller lets rename general "format" to "format_yaml".
>
> Part-of #4682
>
> Signed-off-by: Cyrill Gorcunov <gorcunov@gmail.com>
> ---
> src/box/lua/console.c | 2 +-
> src/box/lua/console.lua | 4 ++--
> 2 files changed, 3 insertions(+), 3 deletions(-)
>
> diff --git a/src/box/lua/console.c b/src/box/lua/console.c
> index d437ff3fe..734c0ee47 100644
> --- a/src/box/lua/console.c
> +++ b/src/box/lua/console.c
> @@ -352,7 +352,7 @@ lbox_console_add_history(struct lua_State *L)
> * parameter.
> */
> static int
> -lbox_console_format(struct lua_State *L)
> +lbox_console_format_yaml(struct lua_State *L)
> {
> int arg_count = lua_gettop(L);
> if (arg_count == 0) {
> diff --git a/src/box/lua/console.lua b/src/box/lua/console.lua
> index 2add9a79d..5642ca956 100644
> --- a/src/box/lua/console.lua
> +++ b/src/box/lua/console.lua
> @@ -53,7 +53,7 @@ output_handlers["yaml"] = function(status, opts, ...)
> local err
> if status then
> -- serializer can raise an exception
> - status, err = pcall(internal.format, ...)
> + status, err = pcall(internal.format_yaml, ...)
> if status then
> return err
> else
> @@ -66,7 +66,7 @@ output_handlers["yaml"] = function(status, opts, ...)
> err = box.NULL
> end
> end
> - return internal.format({ error = err })
> + return internal.format_yaml({ error = err })
> end
>
> -- A map for internal symbols in case if they
>
next prev parent reply other threads:[~2020-05-18 12:04 UTC|newest]
Thread overview: 20+ messages / expand[flat|nested] mbox.gz Atom feed top
2020-05-12 13:50 [Tarantool-patches] [PATCH 0/7] box/console: add support for internal types Cyrill Gorcunov
2020-05-12 13:50 ` [Tarantool-patches] [PATCH 1/7] box/console: console_session_vtab -- use designated initialization Cyrill Gorcunov
2020-05-18 12:03 ` Oleg Babin
2020-05-12 13:50 ` [Tarantool-patches] [PATCH 2/7] box/console: use tabs instead of spaces in consolelib Cyrill Gorcunov
2020-05-18 12:04 ` Oleg Babin
2020-05-12 13:50 ` [Tarantool-patches] [PATCH 3/7] box/console: rename format to format_yaml Cyrill Gorcunov
2020-05-18 12:04 ` Oleg Babin [this message]
2020-05-12 13:50 ` [Tarantool-patches] [PATCH 4/7] box/console: rename luaL_yaml_default to serializer_yaml Cyrill Gorcunov
2020-05-18 12:11 ` Oleg Babin
2020-05-18 21:17 ` Igor Munkin
2020-05-19 6:47 ` Oleg Babin
2020-05-12 13:50 ` [Tarantool-patches] [PATCH 5/7] box/console: implement lua serializer Cyrill Gorcunov
2020-05-18 12:18 ` Oleg Babin
2020-05-12 13:50 ` [Tarantool-patches] [PATCH 6/7] box/console: switch to new " Cyrill Gorcunov
2020-05-18 12:21 ` Oleg Babin
2020-05-12 13:50 ` [Tarantool-patches] [PATCH 7/7] test: extend console lua test Cyrill Gorcunov
2020-05-18 12:22 ` Oleg Babin
2020-05-18 12:25 ` Cyrill Gorcunov
2020-05-18 12:46 ` [Tarantool-patches] [PATCH 0/7] box/console: add support for internal types Kirill Yukhin
-- strict thread matches above, loose matches on Subject: below --
2020-05-08 11:47 Cyrill Gorcunov
2020-05-08 11:47 ` [Tarantool-patches] [PATCH 3/7] box/console: rename format to format_yaml Cyrill Gorcunov
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=3474ae26-0362-02d9-dc9f-81a7d265fc06@tarantool.org \
--to=olegrok@tarantool.org \
--cc=gorcunov@gmail.com \
--cc=tarantool-patches@dev.tarantool.org \
--subject='Re: [Tarantool-patches] [PATCH 3/7] box/console: rename format to format_yaml' \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox