Tarantool development patches archive
 help / color / mirror / Atom feed
From: Vladislav Shpilevoy <v.shpilevoy@tarantool.org>
To: Nikita Pettik <korablev@tarantool.org>
Cc: tarantool-patches@dev.tarantool.org
Subject: Re: [Tarantool-patches] [PATCH 3/7] box/error: don't set error created via box.error.new to diag
Date: Thu, 26 Mar 2020 01:22:52 +0100	[thread overview]
Message-ID: <32acd313-8d54-5496-55e2-0613fe4bd883@tarantool.org> (raw)
In-Reply-To: <20200325010231.GA30598@tarantool.org>

On 25/03/2020 02:02, Nikita Pettik wrote:
> On 22 Feb 18:18, Vladislav Shpilevoy wrote:
>> Thanks for the patch!
>>
>>> diff --git a/src/box/error.cc b/src/box/error.cc
>>> index 7dfe1b3ee..824a4617c 100644
>>> --- a/src/box/error.cc
>>> +++ b/src/box/error.cc
>>> @@ -86,6 +86,22 @@ box_error_set(const char *file, unsigned line, uint32_t code,
>>>  	return -1;
>>>  }
>>>  
>>> +struct error *
>>> +box_error_construct(const char *file, unsigned line, uint32_t code,
>>> +		    const char *fmt, ...)
>>> +{
>>> +	struct error *e = BuildClientError(file, line, ER_UNKNOWN);
>>> +	ClientError *client_error = type_cast(ClientError, e);
>>> +	if (client_error != NULL) {
>>> +		client_error->m_errcode = code;
>>
>> 4. You can now make box_error_set() call box_error_construct() +
>> diag_set(), to avoid code duplication.
> 
> I don't think it is worth it since I have to introduce one more
> 'proxy' function which accepts va_list arguments. Skipped.

Yeah, I forgot that it is not as as trivial to forward ... as
in Lua.

>>> +		va_list ap;
>>> +		va_start(ap, fmt);
>>> +		error_vformat_msg(e, fmt, ap);
>>> +		va_end(ap);
>>> +	}
>>> +	return e;
>>> +}
>>> +
>>>  /* }}} */
>>>  
>>>  struct rmean *rmean_error = NULL;
>>> diff --git a/src/box/error.h b/src/box/error.h
>>> index b8c7cf73d..42043ef80 100644
>>> --- a/src/box/error.h
>>> +++ b/src/box/error.h
>>> @@ -129,6 +129,14 @@ int
>>>  box_error_set(const char *file, unsigned line, uint32_t code,
>>>  	      const char *format, ...);
>>>  
>>> +/**
>>> + * Construct error object without setting it in the diagnostics
>>> + * area. On the memory allocation fail returns NULL.
>>> + */
>>> +struct error *
>>> +box_error_construct(const char *file, unsigned line, uint32_t code,
>>> +		    const char *fmt, ...);
>>
>> 5. You added the method to the public C API (it is inside 'cond public'
>> comments). I don't think we should do that. At least until someone
>> asked so.
>>
>> Also why not box_error_new()? 'Construct' seems to be a very strange name.
> 
> IMHO _new 'suffix' implies allocating new object, meanwhile _construct - 
> filling in already allocated object. It was my understanding.
Exactly. And box_error_construct() allocates a new object. You even said
that in the comment. So where am I wrong?

Btw, for initialization of an object in-place we use '_create'.
'_init' is used for initialization of a module. But '_construct' - never.

  reply	other threads:[~2020-03-26  0:22 UTC|newest]

Thread overview: 27+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2020-02-19 14:16 [Tarantool-patches] [PATCH 0/7] Stacked diagnostics area Nikita Pettik
2020-02-19 14:16 ` [Tarantool-patches] [PATCH 1/7] box: rename diag_add_error to diag_set_error Nikita Pettik
2020-02-19 14:16 ` [Tarantool-patches] [PATCH 2/7] box/error: introduce box.error.set() method Nikita Pettik
2020-02-19 14:26   ` Cyrill Gorcunov
2020-02-19 14:30     ` Nikita Pettik
2020-02-19 14:53       ` Cyrill Gorcunov
2020-02-19 14:16 ` [Tarantool-patches] [PATCH 3/7] box/error: don't set error created via box.error.new to diag Nikita Pettik
2020-02-22 17:18   ` Vladislav Shpilevoy
2020-03-25  1:02     ` Nikita Pettik
2020-03-26  0:22       ` Vladislav Shpilevoy [this message]
2020-03-26  1:03         ` Nikita Pettik
2020-02-19 14:16 ` [Tarantool-patches] [PATCH 4/7] box: introduce stacked diagnostic area Nikita Pettik
2020-02-19 21:10   ` Vladislav Shpilevoy
2020-02-20 11:53     ` Nikita Pettik
2020-02-20 18:29       ` Nikita Pettik
2020-02-23 17:43   ` Vladislav Shpilevoy
2020-03-25  1:34     ` Nikita Pettik
2020-02-19 14:16 ` [Tarantool-patches] [PATCH 5/7] box/error: clarify purpose of reference counting in struct error Nikita Pettik
2020-02-23 17:43   ` Vladislav Shpilevoy
2020-03-25  1:40     ` Nikita Pettik
2020-02-19 14:16 ` [Tarantool-patches] [PATCH 6/7] iproto: refactor error encoding with mpstream Nikita Pettik
2020-02-23 17:44   ` Vladislav Shpilevoy
2020-03-25  1:42     ` Nikita Pettik
2020-02-19 14:16 ` [Tarantool-patches] [PATCH 7/7] iproto: support error stacked diagnostic area Nikita Pettik
2020-02-23 17:43   ` Vladislav Shpilevoy
2020-03-25  1:38     ` Nikita Pettik
2020-02-22 17:18 ` [Tarantool-patches] [PATCH 0/7] Stacked diagnostics area Vladislav Shpilevoy

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=32acd313-8d54-5496-55e2-0613fe4bd883@tarantool.org \
    --to=v.shpilevoy@tarantool.org \
    --cc=korablev@tarantool.org \
    --cc=tarantool-patches@dev.tarantool.org \
    --subject='Re: [Tarantool-patches] [PATCH 3/7] box/error: don'\''t set error created via box.error.new to diag' \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox