From: Cyrill Gorcunov via Tarantool-patches <tarantool-patches@dev.tarantool.org> To: Vladislav Shpilevoy <v.shpilevoy@tarantool.org> Cc: tml <tarantool-patches@dev.tarantool.org> Subject: Re: [Tarantool-patches] [PATCH v12 2/8] module_cache: move module handling into own subsystem Date: Mon, 25 Jan 2021 11:52:18 +0300 [thread overview] Message-ID: <20210125085218.GE2174@grain> (raw) In-Reply-To: <136716fc-7e19-6515-d18c-c0d3d0576a96@tarantool.org> On Sun, Jan 24, 2021 at 05:26:48PM +0100, Vladislav Shpilevoy wrote: > Thanks for the patch! > > See 4 comments below. > > On 18.01.2021 21:35, Cyrill Gorcunov wrote: > > The module handling should not be bound to particular > > function implementation (we will have two users: already > > existing functions for "_func" space, and a new upcoming > > one which will be serving cbox submodule in next patch). > > 1. It is now cmod, not cbox. Thanks! > > + > > +#include "box/error.h" > > 2. #include "error.h" and #include "box/error.h" are the same > files. Because you are in box/ folder. OK > > + > > + mod_sym->addr = module_sym(module, name.sym); > > + if (mod_sym->addr == NULL) > > + return -1; > > 3. Is it correct, that you second time has deleted the bugfix > which you did about module not being unloaded when first > symbol load fails? Sigh... This sneaky issue triggers for n'th time :( Thanks for catching, Vlad! > > +#pragma once > > + > > +#include <small/rlist.h> > > 4. Please, use "" instead of <> for non-system headers. OK, an update on top of the patch. I'll squash it later --- src/box/module_cache.c | 30 ++++++++++++++++++++++++++---- src/box/module_cache.h | 2 +- 2 files changed, 27 insertions(+), 5 deletions(-) diff --git a/src/box/module_cache.c b/src/box/module_cache.c index 9fe316807..a66b84efb 100644 --- a/src/box/module_cache.c +++ b/src/box/module_cache.c @@ -16,7 +16,7 @@ #include "fiber.h" #include "port.h" -#include "box/error.h" +#include "error.h" #include "lua/utils.h" #include "libeio/eio.h" @@ -338,8 +338,14 @@ module_sym_load(struct module_sym *mod_sym) struct func_name name; func_split_name(mod_sym->name, &name); - struct module *module = module_cache_find(name.package, name.package_end); - if (module == NULL) { + /* + * In case if module has been loaded already by + * some previous call we can eliminate redundant + * loading and take it from the cache. + */ + struct module *cached, *module; + cached = module_cache_find(name.package, name.package_end); + if (cached == NULL) { module = module_load(name.package, name.package_end); if (module == NULL) return -1; @@ -347,11 +353,27 @@ module_sym_load(struct module_sym *mod_sym) module_delete(module); return -1; } + } else { + module = cached; } mod_sym->addr = module_sym(module, name.sym); - if (mod_sym->addr == NULL) + if (mod_sym->addr == NULL) { + if (cached == NULL) { + /* + * In case if it was a first load we should + * clean the cache immediately otherwise + * the module continue being referenced even + * if there will be no use of it. + * + * Note the module_sym set an error thus be + * careful to not wipe it. + */ + module_cache_del(name.package, name.package_end); + module_delete(module); + } return -1; + } mod_sym->module = module; rlist_add(&module->funcs_list, &mod_sym->item); diff --git a/src/box/module_cache.h b/src/box/module_cache.h index fd789f603..0f5d2b64a 100644 --- a/src/box/module_cache.h +++ b/src/box/module_cache.h @@ -6,7 +6,7 @@ #pragma once -#include <small/rlist.h> +#include "small/rlist.h" #if defined(__cplusplus) extern "C" { -- 2.29.2
next prev parent reply other threads:[~2021-01-25 8:52 UTC|newest] Thread overview: 26+ messages / expand[flat|nested] mbox.gz Atom feed top 2021-01-18 20:35 [Tarantool-patches] [PATCH v12 0/8] box: implement cmod Lua module Cyrill Gorcunov via Tarantool-patches 2021-01-18 20:35 ` [Tarantool-patches] [PATCH v12 1/8] box/func: factor out c function entry structure Cyrill Gorcunov via Tarantool-patches 2021-01-18 20:35 ` [Tarantool-patches] [PATCH v12 2/8] module_cache: move module handling into own subsystem Cyrill Gorcunov via Tarantool-patches 2021-01-24 16:26 ` Vladislav Shpilevoy via Tarantool-patches 2021-01-25 8:52 ` Cyrill Gorcunov via Tarantool-patches [this message] 2021-01-18 20:35 ` [Tarantool-patches] [PATCH v12 3/8] module_cache: improve naming Cyrill Gorcunov via Tarantool-patches 2021-01-24 16:27 ` Vladislav Shpilevoy via Tarantool-patches 2021-01-24 22:32 ` Cyrill Gorcunov via Tarantool-patches 2021-01-30 18:53 ` Vladislav Shpilevoy via Tarantool-patches 2021-02-01 11:41 ` Cyrill Gorcunov via Tarantool-patches 2021-01-18 20:35 ` [Tarantool-patches] [PATCH v12 4/8] module_cache: direct update a cache value on reload Cyrill Gorcunov via Tarantool-patches 2021-01-19 12:46 ` Cyrill Gorcunov via Tarantool-patches 2021-01-24 16:27 ` Vladislav Shpilevoy via Tarantool-patches 2021-01-24 22:26 ` Cyrill Gorcunov via Tarantool-patches 2021-01-18 20:35 ` [Tarantool-patches] [PATCH v12 5/8] module_cache: rename calls to ref in module structure Cyrill Gorcunov via Tarantool-patches 2021-01-24 16:27 ` Vladislav Shpilevoy via Tarantool-patches 2021-01-25 10:29 ` Cyrill Gorcunov via Tarantool-patches 2021-01-18 20:35 ` [Tarantool-patches] [PATCH v12 6/8] module_cache: provide helpers to load and unload modules Cyrill Gorcunov via Tarantool-patches 2021-01-24 16:28 ` Vladislav Shpilevoy via Tarantool-patches 2021-01-18 20:35 ` [Tarantool-patches] [PATCH v12 7/8] box/cmod: implement cmod Lua module Cyrill Gorcunov via Tarantool-patches 2021-01-24 16:28 ` Vladislav Shpilevoy via Tarantool-patches 2021-01-25 16:50 ` Cyrill Gorcunov via Tarantool-patches 2021-01-30 18:53 ` Vladislav Shpilevoy via Tarantool-patches 2021-01-18 20:35 ` [Tarantool-patches] [PATCH v12 8/8] test: box/cfunc -- add cmod test Cyrill Gorcunov via Tarantool-patches 2021-01-24 16:28 ` Vladislav Shpilevoy via Tarantool-patches 2021-01-24 16:26 ` [Tarantool-patches] [PATCH v12 0/8] box: implement cmod Lua module Vladislav Shpilevoy via Tarantool-patches
Reply instructions: You may reply publicly to this message via plain-text email using any one of the following methods: * Save the following mbox file, import it into your mail client, and reply-to-all from there: mbox Avoid top-posting and favor interleaved quoting: https://en.wikipedia.org/wiki/Posting_style#Interleaved_style * Reply using the --to, --cc, and --in-reply-to switches of git-send-email(1): git send-email \ --in-reply-to=20210125085218.GE2174@grain \ --to=tarantool-patches@dev.tarantool.org \ --cc=gorcunov@gmail.com \ --cc=v.shpilevoy@tarantool.org \ --subject='Re: [Tarantool-patches] [PATCH v12 2/8] module_cache: move module handling into own subsystem' \ /path/to/YOUR_REPLY https://kernel.org/pub/software/scm/git/docs/git-send-email.html * If your mail client supports setting the In-Reply-To header via mailto: links, try the mailto: link
This is a public inbox, see mirroring instructions for how to clone and mirror all data and code used for this inbox