Tarantool development patches archive
 help / color / mirror / Atom feed
From: Sergey Kaplun <skaplun@tarantool.org>
To: Cyrill Gorcunov <gorcunov@gmail.com>
Cc: tarantool-patches@dev.tarantool.org,
	Vladislav Shpilevoy <v.shpilevoy@tarantool.org>
Subject: Re: [Tarantool-patches] [DRAFT v1] replication: track information about replica
Date: Thu, 2 Jul 2020 22:40:48 +0300	[thread overview]
Message-ID: <20200702194048.GA32264@root> (raw)
In-Reply-To: <20200702155347.GJ2256@grain>

Hi! Thanks for the review!

On 02.07.20, Cyrill Gorcunov wrote:
> On Mon, Jun 29, 2020 at 11:31:34PM +0300, Sergey Kaplun wrote:
> ...
> >  
> > +static int
> > +relay_on_state_f(struct trigger *trigger, void *event)
> > +{
> 
> Sergey, I'll review the patch with more attention tomorrow, still
> here are some notes which I can point early.
> 
>  - please don't name the trigger function with _f postfix, we usually
>    do this for cord thread runners (I know here are a few exceptions
>    but they are simply misnamed)
> 

Yup, thanks!

> > +	struct relay *relay = (struct relay *)event;
> > +	(void)trigger;
> 
> You can easily exit early
> 
> 	if (relay_get_state(relay) == RELAY_OFF)
> 		return 0;
> 
> shifting the rest of the code left. Still up to you I do not insist.
> 

Nice point! Early return looks much better!

> 
> Do we really need to call diag_raise() here?
> 
> > +		int rc;
> > +		switch (relay_get_state(relay)) {
> ...
> > +		}
> > +		if (rc != 0)
> > +			diag_raise();
> 
> And here. IIRC usually triggers simply return -1 on error.
> The left of the patch is trimmed for now.

I think we should not raise an error inside relay. Is say_error enough
if something goes wrong?

I will send new version with separate letter.

-- 
Best regards,
Sergey Kaplun

      reply	other threads:[~2020-07-02 19:41 UTC|newest]

Thread overview: 3+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2020-06-29 20:31 Sergey Kaplun
2020-07-02 15:53 ` Cyrill Gorcunov
2020-07-02 19:40   ` Sergey Kaplun [this message]

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20200702194048.GA32264@root \
    --to=skaplun@tarantool.org \
    --cc=gorcunov@gmail.com \
    --cc=tarantool-patches@dev.tarantool.org \
    --cc=v.shpilevoy@tarantool.org \
    --subject='Re: [Tarantool-patches] [DRAFT v1] replication: track information about replica' \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox