Tarantool development patches archive
 help / color / mirror / Atom feed
From: Cyrill Gorcunov <gorcunov@gmail.com>
To: lvasiliev <lvasiliev@tarantool.org>
Cc: tml <tarantool-patches@dev.tarantool.org>
Subject: Re: [Tarantool-patches] [PATCH v4 6/8] lua/log: use log module settings inside box.cfg
Date: Thu, 28 May 2020 20:34:23 +0300	[thread overview]
Message-ID: <20200528173423.GG215590@grain> (raw)
In-Reply-To: <6ec85e2f-93a6-250d-63a9-a18c4caddb7d@tarantool.org>

On Thu, May 28, 2020 at 08:07:02PM +0300, lvasiliev wrote:
> > +local function apply_default_modules_cfg(cfg)
> 
> Looks like apply_default_cfg(cfg, log.box_api.cfg).
> Can we avoid code duplication?

The problem is keys naming. The module may have own mapping.
For example in my latest version we use variables without
log_ prefix but for box module sake we provide a map

log.lua
=======

-- Name mapping from box to log module.
-- Make sure all required fields are covered!
local log2box_keys = {
    ['log']         = 'log',
    ['nonblock']    = 'log_nonblock',
    ['level']       = 'log_level',
    ['format']      = 'log_format',
}

-- Apply defaut config to the box module
local function box_cfg_apply_default(box_cfg)
    for k, v in pairs(log_cfg) do
        if box_cfg[log2box_keys[k]] == nil then
            box_cfg[log2box_keys[k]] = v
        end
    end
end

load_cfg.lua
============

-- Fetch default settings from modules.
local function apply_default_modules_cfg(cfg)
    log.box_api.cfg_apply_default(cfg)
end

This isolate module specifics from box variables as
it should be I believe.

> 
> > +    --
> > +    -- logging
> > +    for k,v in pairs(log.box_api.cfg) do
> 
> Add a space before v.

already reworked, thanks!

> > @@ -146,7 +162,8 @@ local function log_rotate()
> >   end
> >   local function log_level(level)
> > -    return ffi.C.say_set_log_level(level)
> > +    ffi.C.say_set_log_level(level)
> > +    rawset(log_cfg, 'log_level', level)
> 
> Maybe I'm wrong, but seems like after that change the ffi.C.log_level
> is deprecated (log_cfg.log_level can be used instead). But now you
> keep 'level' in two places (ffi.C.log_level and log_cfg.log_level).

Not sure I follow here. You mean to drop their usage in Lua's
"function say()" in this module?

> >   setmetatable(log, {
> > +    __serialize = function(self)
> 
> Can you add a test on __serizlize?

Good point, will do.

  reply	other threads:[~2020-05-28 17:34 UTC|newest]

Thread overview: 44+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2020-05-28 10:07 [Tarantool-patches] [PATCH v4 0/8] lua/log: add an ability to setup logger without box.cfg{} Cyrill Gorcunov
2020-05-28 10:07 ` [Tarantool-patches] [PATCH v4 1/8] core/say: do not reconfig early set up logger Cyrill Gorcunov
2020-05-28 10:36   ` Oleg Babin
2020-05-28 10:42   ` lvasiliev
2020-05-28 10:47     ` Cyrill Gorcunov
2020-05-28 10:07 ` [Tarantool-patches] [PATCH v4 2/8] lua/log: declare say_logger_init and say_logger_initialized Cyrill Gorcunov
2020-05-28 10:37   ` Oleg Babin
2020-05-28 11:12   ` lvasiliev
2020-05-28 11:16     ` Cyrill Gorcunov
2020-05-28 10:07 ` [Tarantool-patches] [PATCH v4 3/8] lua/log: put string constants to map Cyrill Gorcunov
2020-05-28 10:37   ` Oleg Babin
2020-05-28 12:46   ` lvasiliev
2020-05-28 10:07 ` [Tarantool-patches] [PATCH v4 4/8] lua/log: do not allow to set json for boot logger Cyrill Gorcunov
2020-05-28 10:40   ` Oleg Babin
2020-05-28 10:48     ` Cyrill Gorcunov
2020-05-28 11:49   ` lvasiliev
2020-05-28 11:59     ` Cyrill Gorcunov
2020-05-28 10:07 ` [Tarantool-patches] [PATCH v4 5/8] lua/log: declare log as separate variable Cyrill Gorcunov
2020-05-28 10:40   ` Oleg Babin
2020-05-28 12:57   ` lvasiliev
2020-05-28 10:07 ` [Tarantool-patches] [PATCH v4 6/8] lua/log: use log module settings inside box.cfg Cyrill Gorcunov
2020-05-28 10:41   ` Oleg Babin
2020-05-28 10:49     ` Cyrill Gorcunov
2020-05-28 17:07   ` lvasiliev
2020-05-28 17:34     ` Cyrill Gorcunov [this message]
2020-05-29  8:43       ` Leonid Vasiliev
2020-05-28 10:07 ` [Tarantool-patches] [PATCH v4 7/8] lua/log: allow to configure logging without a box Cyrill Gorcunov
2020-05-28 10:42   ` Oleg Babin
2020-05-29  8:41   ` Leonid Vasiliev
2020-05-29  8:53     ` Oleg Babin
2020-05-29  9:16       ` Leonid Vasiliev
2020-05-29  9:49         ` Cyrill Gorcunov
2020-05-29 10:00           ` Oleg Babin
2020-05-29 10:22           ` Leonid Vasiliev
2020-05-29 10:38             ` Cyrill Gorcunov
2020-05-29 11:08               ` Leonid Vasiliev
2020-05-29 11:32                 ` Cyrill Gorcunov
2020-05-29 11:39                   ` Leonid Vasiliev
2020-05-29 10:07     ` Cyrill Gorcunov
2020-05-28 10:07 ` [Tarantool-patches] [PATCH v4 8/8] test: use direct log module Cyrill Gorcunov
2020-05-28 10:42   ` Oleg Babin
2020-05-28 10:50     ` Cyrill Gorcunov
2020-05-29  9:02   ` Leonid Vasiliev
2020-05-29 11:31 ` [Tarantool-patches] [PATCH v4 0/8] lua/log: add an ability to setup logger without box.cfg{} Leonid Vasiliev

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20200528173423.GG215590@grain \
    --to=gorcunov@gmail.com \
    --cc=lvasiliev@tarantool.org \
    --cc=tarantool-patches@dev.tarantool.org \
    --subject='Re: [Tarantool-patches] [PATCH v4 6/8] lua/log: use log module settings inside box.cfg' \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox