Tarantool development patches archive
 help / color / mirror / Atom feed
From: Cyrill Gorcunov <gorcunov@gmail.com>
To: Oleg Babin <olegrok@tarantool.org>
Cc: tml <tarantool-patches@dev.tarantool.org>
Subject: Re: [Tarantool-patches] [PATCH 0/7] box/console: add support for internal types
Date: Fri, 8 May 2020 19:19:10 +0300	[thread overview]
Message-ID: <20200508161910.GC51428@grain> (raw)
In-Reply-To: <7d39ce8a-3c12-a814-9bb3-8d43bfc6f782@tarantool.org>

On Fri, May 08, 2020 at 07:04:26PM +0300, Oleg Babin wrote:
> Hi! Thanks for patchset! I have a few comments.
> 
> I'm not sure that we should return errors in such way:
> ```
> tarantool> x
> {error = "[string \"return x\"]:1: variable \'x\' is not declared"};
> ```

Yes. This allows to paste the result back to the console.
This is change in behaviour but while we're not claiming
that th lua mode is stable I think we can do so.

> 
> Or is it expected behaviour?
> 
> Also `nil` value is ignored in some cases.
> ```
> tarantool> nil
> ;
> tarantool> nil, 2, 3
> ;
> tarantool> 1, nil, 3
> 1, nil, 3;
> ```

Thanks! I'll take a look.

> 
> And I've met strange output:
> ```
> tarantool> box.space.test.index
> {[0] = {unique = true, parts = {{type = "integer", is_nullable = "false",
> fieldno = "3"}, {type = "unsigned", is_nullable = "false", fieldno = "5"}},
> type = "TREE", id = "0", space_id = "520", name = "id"}, [1] = {unique =
> false, parts = {{type = "unsigned", is_nullable = "false", fieldno = "1"}},
> id = 1, space_id = 520, type = "TREE", name = "bucket_id"}, [bucket_id]1
>  = !!!*anchor[id]0
>  = !!!*anchor};
> ```
> 
> "!!!*anchor" looks strange. Seems it occurs when you mix map and array.

Yes, this is self reference. I need to revisit this moment. Thank you!

  reply	other threads:[~2020-05-08 16:19 UTC|newest]

Thread overview: 15+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2020-05-08 11:47 Cyrill Gorcunov
2020-05-08 11:47 ` [Tarantool-patches] [PATCH 1/7] box/console: console_session_vtab -- use designated initialization Cyrill Gorcunov
2020-05-08 11:47 ` [Tarantool-patches] [PATCH 2/7] box/console: use tabs instead of spaces in consolelib Cyrill Gorcunov
2020-05-08 11:47 ` [Tarantool-patches] [PATCH 3/7] box/console: rename format to format_yaml Cyrill Gorcunov
2020-05-08 11:47 ` [Tarantool-patches] [PATCH 4/7] box/console: rename luaL_yaml_default to serializer_yaml Cyrill Gorcunov
2020-05-08 11:47 ` [Tarantool-patches] [PATCH 5/7] box/console: implement lua serializer Cyrill Gorcunov
2020-05-08 11:47 ` [Tarantool-patches] [PATCH 6/7] box/console: switch to new " Cyrill Gorcunov
2020-05-08 11:47 ` [Tarantool-patches] [PATCH 7/7] test: extend console lua test Cyrill Gorcunov
2020-05-08 16:04 ` [Tarantool-patches] [PATCH 0/7] box/console: add support for internal types Oleg Babin
2020-05-08 16:19   ` Cyrill Gorcunov [this message]
2020-05-12 17:06     ` Mons Anderson
2020-05-12 17:31       ` Cyrill Gorcunov
2020-05-12 13:53 ` Cyrill Gorcunov
2020-05-12 13:50 Cyrill Gorcunov
2020-05-18 12:46 ` Kirill Yukhin

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20200508161910.GC51428@grain \
    --to=gorcunov@gmail.com \
    --cc=olegrok@tarantool.org \
    --cc=tarantool-patches@dev.tarantool.org \
    --subject='Re: [Tarantool-patches] [PATCH 0/7] box/console: add support for internal types' \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox