From: Nikita Pettik <korablev@tarantool.org> To: Konstantin Osipov <kostja.osipov@gmail.com>, tarantool-patches@dev.tarantool.org, v.shpilevoy@tarantool.org Subject: Re: [Tarantool-patches] [PATCH v2 05/10] box/error: don't set error created via box.error.new to diag Date: Thu, 26 Mar 2020 17:59:15 +0000 [thread overview] Message-ID: <20200326175915.GC5718@tarantool.org> (raw) In-Reply-To: <20200326165049.GC21134@atlas> On 26 Mar 19:50, Konstantin Osipov wrote: > * Nikita Pettik <korablev@tarantool.org> [20/03/25 09:32]: > > To achieve this let's refactor luaT_error_create() to return error > > object instead of setting it via box_error_set(). > > luaT_error_create() is used both to handle box.error() and > > box.error.new() invocations, and box.error() is still expected to set > > error to diagnostic area. So, luaT_error_call() which implements > > box.error() processing at the end calls diag_set_error(). > > It is worth mentioning that net.box module relied on the fact that > > box.error.new() set error to diagnostic area: otherwise request errors > > don't get to diagnostic area on client side. > > > > I know there was a discussion about construct vs create vs new. It was not really discussion, I accidentally didn't notice that box_error_construct() in fact allocated memory (meanwhile I thought it didn't). I've already renamed it to box_error_new(). > Let me remind about approved name pairs: > > obj_create/obj_destroy - constructor/destructor, without > allocation/deallocation. > > obj_new/obj_delete - constructor/destructor with > allocation/deallocation > > init/free - library initialization/destruction > > _construct is not in the vocabulary. I'd avoid it. Ok, Vlad already guided me (but it would be nice to see this manual in our dev docs). > I know this is bikeshed, pls feel free to ignore in scope of this > patch. And sorry for jumping in late. > > > +struct error * > > +box_error_construct(const char *file, unsigned line, uint32_t code, > > + const char *fmt, ...) > > +{ > > + struct error *e = BuildClientError(file, line, ER_UNKNOWN); > > + ClientError *client_error = type_cast(ClientError, e); > > + if (client_error != NULL) { > > + client_error->m_errcode = code; > > + va_list ap; > > + va_start(ap, fmt); > > + error_vformat_msg(e, fmt, ap); > > + va_end(ap); > > + } > > + return e; > > +} > > if box_error_new() is already taken by the public api, options are > box_client_error_new() or box_build_client_error()? No, box_error_new() name is still available. I've renamed box_error_construct() to box_error_new() and pushed branch containing this changes. > > -- > Konstantin Osipov, Moscow, Russia
next prev parent reply other threads:[~2020-03-26 17:59 UTC|newest] Thread overview: 57+ messages / expand[flat|nested] mbox.gz Atom feed top 2020-03-25 1:42 [Tarantool-patches] [PATCH v2 00/10] Stacked diagnostics Nikita Pettik 2020-03-25 1:42 ` [Tarantool-patches] [PATCH v2 01/10] box: rfc for stacked diagnostic area Nikita Pettik 2020-03-25 8:27 ` Konstantin Osipov 2020-03-25 14:08 ` Nikita Pettik 2020-03-25 1:42 ` [Tarantool-patches] [PATCH v2 02/10] box: rename diag_add_error to diag_set_error Nikita Pettik 2020-03-25 8:27 ` Konstantin Osipov 2020-03-26 0:22 ` Vladislav Shpilevoy 2020-03-26 12:31 ` Nikita Pettik 2020-03-25 1:42 ` [Tarantool-patches] [PATCH v2 03/10] test: move box.error tests to box/error.test.lua Nikita Pettik 2020-03-25 8:28 ` Konstantin Osipov 2020-03-26 0:22 ` Vladislav Shpilevoy 2020-03-26 12:31 ` Nikita Pettik 2020-03-25 1:43 ` [Tarantool-patches] [PATCH v2 04/10] box/error: introduce box.error.set() method Nikita Pettik 2020-03-25 8:33 ` Konstantin Osipov 2020-03-25 17:41 ` Nikita Pettik 2020-03-26 0:22 ` Vladislav Shpilevoy 2020-03-26 12:31 ` Nikita Pettik 2020-03-25 1:43 ` [Tarantool-patches] [PATCH v2 05/10] box/error: don't set error created via box.error.new to diag Nikita Pettik 2020-03-26 16:50 ` Konstantin Osipov 2020-03-26 17:59 ` Nikita Pettik [this message] 2020-03-26 18:06 ` Nikita Pettik 2020-03-26 18:07 ` Alexander Turenko 2020-03-27 0:19 ` Vladislav Shpilevoy 2020-03-27 13:09 ` Nikita Pettik 2020-03-25 1:43 ` [Tarantool-patches] [PATCH v2 06/10] box: introduce stacked diagnostic area Nikita Pettik 2020-03-26 16:54 ` Konstantin Osipov 2020-03-26 18:03 ` Nikita Pettik 2020-03-26 18:08 ` Konstantin Osipov 2020-03-28 18:40 ` Vladislav Shpilevoy 2020-04-01 16:09 ` Nikita Pettik 2020-04-02 0:29 ` Vladislav Shpilevoy 2020-04-02 17:42 ` Nikita Pettik 2020-04-02 22:20 ` Vladislav Shpilevoy 2020-04-03 1:54 ` Nikita Pettik 2020-04-03 23:17 ` Vladislav Shpilevoy 2020-03-28 18:59 ` Vladislav Shpilevoy 2020-03-31 17:44 ` Nikita Pettik 2020-04-02 0:29 ` Vladislav Shpilevoy 2020-04-02 14:16 ` Nikita Pettik 2020-03-25 1:43 ` [Tarantool-patches] [PATCH v2 07/10] box: use stacked diagnostic area for functional indexes Nikita Pettik 2020-03-30 23:24 ` Vladislav Shpilevoy 2020-04-01 15:53 ` Nikita Pettik 2020-03-25 1:43 ` [Tarantool-patches] [PATCH v2 08/10] box/error: clarify purpose of reference counting in struct error Nikita Pettik 2020-03-30 23:24 ` Vladislav Shpilevoy 2020-03-25 1:43 ` [Tarantool-patches] [PATCH v2 09/10] iproto: refactor error encoding with mpstream Nikita Pettik 2020-03-30 23:24 ` Vladislav Shpilevoy 2020-04-01 15:54 ` Nikita Pettik 2020-03-25 1:43 ` [Tarantool-patches] [PATCH v2 10/10] iproto: support error stacked diagnostic area Nikita Pettik 2020-03-30 23:24 ` Vladislav Shpilevoy 2020-04-01 16:26 ` Nikita Pettik 2020-04-01 22:24 ` Nikita Pettik 2020-04-02 0:29 ` Vladislav Shpilevoy 2020-04-02 14:01 ` Nikita Pettik 2020-04-02 22:20 ` Vladislav Shpilevoy 2020-04-03 2:16 ` Nikita Pettik 2020-04-03 23:17 ` Vladislav Shpilevoy 2020-04-06 11:07 ` Nikita Pettik
Reply instructions: You may reply publicly to this message via plain-text email using any one of the following methods: * Save the following mbox file, import it into your mail client, and reply-to-all from there: mbox Avoid top-posting and favor interleaved quoting: https://en.wikipedia.org/wiki/Posting_style#Interleaved_style * Reply using the --to, --cc, and --in-reply-to switches of git-send-email(1): git send-email \ --in-reply-to=20200326175915.GC5718@tarantool.org \ --to=korablev@tarantool.org \ --cc=kostja.osipov@gmail.com \ --cc=tarantool-patches@dev.tarantool.org \ --cc=v.shpilevoy@tarantool.org \ --subject='Re: [Tarantool-patches] [PATCH v2 05/10] box/error: don'\''t set error created via box.error.new to diag' \ /path/to/YOUR_REPLY https://kernel.org/pub/software/scm/git/docs/git-send-email.html * If your mail client supports setting the In-Reply-To header via mailto: links, try the mailto: link
This is a public inbox, see mirroring instructions for how to clone and mirror all data and code used for this inbox