Tarantool development patches archive
 help / color / mirror / Atom feed
From: Nikita Pettik <korablev@tarantool.org>
To: Vladislav Shpilevoy <v.shpilevoy@tarantool.org>
Cc: tarantool-patches@dev.tarantool.org
Subject: Re: [Tarantool-patches] [PATCH 7/7] iproto: support error stacked diagnostic area
Date: Wed, 25 Mar 2020 01:38:06 +0000	[thread overview]
Message-ID: <20200325013806.GC30598@tarantool.org> (raw)
In-Reply-To: <2a5f311b-54cd-9b82-af60-1b95397ed687@tarantool.org>

On 23 Feb 18:43, Vladislav Shpilevoy wrote:
> Thanks for the patch!
> 
> > diff --git a/src/box/lua/net_box.lua b/src/box/lua/net_box.lua
> > index b4811edfa..9a619e3d4 100644
> > --- a/src/box/lua/net_box.lua
> > +++ b/src/box/lua/net_box.lua
> > @@ -277,8 +280,24 @@ local function create_transport(host, port, user, password, callback,
> >      --
> >      function request_index:result()
> >          if self.errno then
> > -            return nil, box.error.new({code = self.errno,
> > -                                       reason = self.response})
> > +            if type(self.response) == 'table' then
> > +                -- Decode and fill in error stack.
> > +                local prev = nil
> > +                for i = #self.response, 1, -1 do
> 
> 4. Why do you start from the end? Seems like you could easily
> do the same with the direct iteration. Your way is not worse,
> but it raises unnecessary questions.

Hm, it's like stack restoration from top to bottom. On the contrary
it seems to be more rational to start iterating from the top (IMHO).
 
> > +                    local error = self.response[i]
> > +                    local code = error[IPROTO_ERROR_CODE]
> > +                    local msg = error[IPROTO_ERROR_MESSAGE]
> > +                    assert(type(code) == 'number')
> > +                    assert(type(msg) == 'string')
> > +                    local new_err = box.error.new({code = code, reason = msg})
> > +                    new_err:set_prev(prev)
> > +                    prev = new_err
> > +                end
> > +                return nil, prev
> > +            else
> > +                return nil, box.error.new({code = self.errno,
> > +                                           reason = self.response})
> > +            end
> >          elseif not self.id then
> >              return self.response
> >          elseif not worker_fiber then

  reply	other threads:[~2020-03-25  1:38 UTC|newest]

Thread overview: 27+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2020-02-19 14:16 [Tarantool-patches] [PATCH 0/7] Stacked diagnostics area Nikita Pettik
2020-02-19 14:16 ` [Tarantool-patches] [PATCH 1/7] box: rename diag_add_error to diag_set_error Nikita Pettik
2020-02-19 14:16 ` [Tarantool-patches] [PATCH 2/7] box/error: introduce box.error.set() method Nikita Pettik
2020-02-19 14:26   ` Cyrill Gorcunov
2020-02-19 14:30     ` Nikita Pettik
2020-02-19 14:53       ` Cyrill Gorcunov
2020-02-19 14:16 ` [Tarantool-patches] [PATCH 3/7] box/error: don't set error created via box.error.new to diag Nikita Pettik
2020-02-22 17:18   ` Vladislav Shpilevoy
2020-03-25  1:02     ` Nikita Pettik
2020-03-26  0:22       ` Vladislav Shpilevoy
2020-03-26  1:03         ` Nikita Pettik
2020-02-19 14:16 ` [Tarantool-patches] [PATCH 4/7] box: introduce stacked diagnostic area Nikita Pettik
2020-02-19 21:10   ` Vladislav Shpilevoy
2020-02-20 11:53     ` Nikita Pettik
2020-02-20 18:29       ` Nikita Pettik
2020-02-23 17:43   ` Vladislav Shpilevoy
2020-03-25  1:34     ` Nikita Pettik
2020-02-19 14:16 ` [Tarantool-patches] [PATCH 5/7] box/error: clarify purpose of reference counting in struct error Nikita Pettik
2020-02-23 17:43   ` Vladislav Shpilevoy
2020-03-25  1:40     ` Nikita Pettik
2020-02-19 14:16 ` [Tarantool-patches] [PATCH 6/7] iproto: refactor error encoding with mpstream Nikita Pettik
2020-02-23 17:44   ` Vladislav Shpilevoy
2020-03-25  1:42     ` Nikita Pettik
2020-02-19 14:16 ` [Tarantool-patches] [PATCH 7/7] iproto: support error stacked diagnostic area Nikita Pettik
2020-02-23 17:43   ` Vladislav Shpilevoy
2020-03-25  1:38     ` Nikita Pettik [this message]
2020-02-22 17:18 ` [Tarantool-patches] [PATCH 0/7] Stacked diagnostics area Vladislav Shpilevoy

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20200325013806.GC30598@tarantool.org \
    --to=korablev@tarantool.org \
    --cc=tarantool-patches@dev.tarantool.org \
    --cc=v.shpilevoy@tarantool.org \
    --subject='Re: [Tarantool-patches] [PATCH 7/7] iproto: support error stacked diagnostic area' \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox