Tarantool development patches archive
 help / color / mirror / Atom feed
* [Tarantool-patches] [PATCH 0/7] Stacked diagnostics area
@ 2020-02-19 14:16 Nikita Pettik
  2020-02-19 14:16 ` [Tarantool-patches] [PATCH 1/7] box: rename diag_add_error to diag_set_error Nikita Pettik
                   ` (7 more replies)
  0 siblings, 8 replies; 27+ messages in thread
From: Nikita Pettik @ 2020-02-19 14:16 UTC (permalink / raw)
  To: tarantool-patches; +Cc: v.shpilevoy

Branch: https://github.com/tarantool/tarantool/commits/np/gh-1148-stacked-diag
Issue:
https://github.com/tarantool/tarantool/issues/1148
https://github.com/tarantool/tarantool/issues/4778

Patch-set basically consists of two parts: first one fixes undocumented
behaviour of box.error.new() which sets created error to diagnostics
area. The reason why it is required is described in the corresponding
github ticked. Second part is about stacked diagnostics itself: patch
error structure extending it with double linked list, provide Lua and
C interfaces to interact with it, support stacked diagnostics in IProto
protocol and net.box module (all points according to the rfc: 
https://github.com/tarantool/tarantool/commit/1acd32d98f628431429b427df19caa9d269bb9c8).

Kirill Shcherbatov (2):
  box: rename diag_add_error to diag_set_error
  iproto: refactor error encoding with mpstream

Nikita Pettik (5):
  box/error: introduce box.error.set() method
  box/error: don't set error created via box.error.new to diag
  box: introduce stacked diagnostic area
  box/error: clarify purpose of reference counting in struct error
  iproto: support error stacked diagnostic area

 extra/exports                   |   2 +
 src/box/applier.cc              |   2 +-
 src/box/error.cc                |  33 +++++
 src/box/error.h                 |  24 ++++
 src/box/iproto_constants.h      |   6 +
 src/box/key_list.c              |  16 +--
 src/box/lua/call.c              |   6 +-
 src/box/lua/error.cc            |  71 ++++++----
 src/box/lua/net_box.lua         |  32 ++++-
 src/box/relay.cc                |   4 +-
 src/box/vy_scheduler.c          |   6 +-
 src/box/xrow.c                  | 150 ++++++++++++++++----
 src/lib/core/diag.c             |  51 +++++++
 src/lib/core/diag.h             | 110 ++++++++++++++-
 src/lib/core/exception.cc       |   2 +-
 src/lib/core/exception.h        |   2 +-
 src/lua/error.c                 |   2 +-
 src/lua/error.h                 |   3 +
 src/lua/error.lua               |  40 ++++++
 src/lua/utils.c                 |   2 +-
 test/box-py/iproto.result       |   6 +-
 test/box-py/iproto.test.py      |   6 +-
 test/box/iproto.result          | 166 ++++++++++++++++++++++
 test/box/iproto.test.lua        |  73 ++++++++++
 test/box/misc.result            | 295 ++++++++++++++++++++++++++++++++++++++++
 test/box/misc.test.lua          | 119 ++++++++++++++++
 test/box/net.box.result         |  65 +++++++++
 test/box/net.box.test.lua       |  25 ++++
 test/engine/func_index.result   |  50 +++++--
 test/engine/func_index.test.lua |   7 +
 30 files changed, 1282 insertions(+), 94 deletions(-)
 create mode 100644 test/box/iproto.result
 create mode 100644 test/box/iproto.test.lua

-- 
2.15.1

^ permalink raw reply	[flat|nested] 27+ messages in thread

end of thread, other threads:[~2020-03-26  1:03 UTC | newest]

Thread overview: 27+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2020-02-19 14:16 [Tarantool-patches] [PATCH 0/7] Stacked diagnostics area Nikita Pettik
2020-02-19 14:16 ` [Tarantool-patches] [PATCH 1/7] box: rename diag_add_error to diag_set_error Nikita Pettik
2020-02-19 14:16 ` [Tarantool-patches] [PATCH 2/7] box/error: introduce box.error.set() method Nikita Pettik
2020-02-19 14:26   ` Cyrill Gorcunov
2020-02-19 14:30     ` Nikita Pettik
2020-02-19 14:53       ` Cyrill Gorcunov
2020-02-19 14:16 ` [Tarantool-patches] [PATCH 3/7] box/error: don't set error created via box.error.new to diag Nikita Pettik
2020-02-22 17:18   ` Vladislav Shpilevoy
2020-03-25  1:02     ` Nikita Pettik
2020-03-26  0:22       ` Vladislav Shpilevoy
2020-03-26  1:03         ` Nikita Pettik
2020-02-19 14:16 ` [Tarantool-patches] [PATCH 4/7] box: introduce stacked diagnostic area Nikita Pettik
2020-02-19 21:10   ` Vladislav Shpilevoy
2020-02-20 11:53     ` Nikita Pettik
2020-02-20 18:29       ` Nikita Pettik
2020-02-23 17:43   ` Vladislav Shpilevoy
2020-03-25  1:34     ` Nikita Pettik
2020-02-19 14:16 ` [Tarantool-patches] [PATCH 5/7] box/error: clarify purpose of reference counting in struct error Nikita Pettik
2020-02-23 17:43   ` Vladislav Shpilevoy
2020-03-25  1:40     ` Nikita Pettik
2020-02-19 14:16 ` [Tarantool-patches] [PATCH 6/7] iproto: refactor error encoding with mpstream Nikita Pettik
2020-02-23 17:44   ` Vladislav Shpilevoy
2020-03-25  1:42     ` Nikita Pettik
2020-02-19 14:16 ` [Tarantool-patches] [PATCH 7/7] iproto: support error stacked diagnostic area Nikita Pettik
2020-02-23 17:43   ` Vladislav Shpilevoy
2020-03-25  1:38     ` Nikita Pettik
2020-02-22 17:18 ` [Tarantool-patches] [PATCH 0/7] Stacked diagnostics area Vladislav Shpilevoy

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox