From: Nikita Pettik <korablev@tarantool.org>
To: Cyrill Gorcunov <gorcunov@gmail.com>
Cc: tarantool-patches@dev.tarantool.org, v.shpilevoy@tarantool.org
Subject: Re: [Tarantool-patches] [PATCH 2/7] box/error: introduce box.error.set() method
Date: Wed, 19 Feb 2020 17:30:51 +0300 [thread overview]
Message-ID: <20200219143051.GA40100@tarantool.org> (raw)
In-Reply-To: <20200219142627.GA2788@uranus>
On 19 Feb 17:26, Cyrill Gorcunov wrote:
> On Wed, Feb 19, 2020 at 05:16:51PM +0300, Nikita Pettik wrote:
> > +static int
> > +luaT_error_set(lua_State *L)
> > +{
> > + if (lua_gettop(L) == 0)
> > + return luaL_error(L, "Usage: box.error.set(error)");
> > + struct error *e = luaL_checkerror(L, 1);
> > + assert(e != NULL);
> > + diag_set_error(&fiber()->diag, e);
> > + return 0;
> > +}
>
> diag_set_error already has assert(e != NULL), maybe we could omit this one?
Yep, you are right, this assertion is likely to be redundant. Thanks,
will drop it while preparing next patch-set version.
next prev parent reply other threads:[~2020-02-19 14:30 UTC|newest]
Thread overview: 27+ messages / expand[flat|nested] mbox.gz Atom feed top
2020-02-19 14:16 [Tarantool-patches] [PATCH 0/7] Stacked diagnostics area Nikita Pettik
2020-02-19 14:16 ` [Tarantool-patches] [PATCH 1/7] box: rename diag_add_error to diag_set_error Nikita Pettik
2020-02-19 14:16 ` [Tarantool-patches] [PATCH 2/7] box/error: introduce box.error.set() method Nikita Pettik
2020-02-19 14:26 ` Cyrill Gorcunov
2020-02-19 14:30 ` Nikita Pettik [this message]
2020-02-19 14:53 ` Cyrill Gorcunov
2020-02-19 14:16 ` [Tarantool-patches] [PATCH 3/7] box/error: don't set error created via box.error.new to diag Nikita Pettik
2020-02-22 17:18 ` Vladislav Shpilevoy
2020-03-25 1:02 ` Nikita Pettik
2020-03-26 0:22 ` Vladislav Shpilevoy
2020-03-26 1:03 ` Nikita Pettik
2020-02-19 14:16 ` [Tarantool-patches] [PATCH 4/7] box: introduce stacked diagnostic area Nikita Pettik
2020-02-19 21:10 ` Vladislav Shpilevoy
2020-02-20 11:53 ` Nikita Pettik
2020-02-20 18:29 ` Nikita Pettik
2020-02-23 17:43 ` Vladislav Shpilevoy
2020-03-25 1:34 ` Nikita Pettik
2020-02-19 14:16 ` [Tarantool-patches] [PATCH 5/7] box/error: clarify purpose of reference counting in struct error Nikita Pettik
2020-02-23 17:43 ` Vladislav Shpilevoy
2020-03-25 1:40 ` Nikita Pettik
2020-02-19 14:16 ` [Tarantool-patches] [PATCH 6/7] iproto: refactor error encoding with mpstream Nikita Pettik
2020-02-23 17:44 ` Vladislav Shpilevoy
2020-03-25 1:42 ` Nikita Pettik
2020-02-19 14:16 ` [Tarantool-patches] [PATCH 7/7] iproto: support error stacked diagnostic area Nikita Pettik
2020-02-23 17:43 ` Vladislav Shpilevoy
2020-03-25 1:38 ` Nikita Pettik
2020-02-22 17:18 ` [Tarantool-patches] [PATCH 0/7] Stacked diagnostics area Vladislav Shpilevoy
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20200219143051.GA40100@tarantool.org \
--to=korablev@tarantool.org \
--cc=gorcunov@gmail.com \
--cc=tarantool-patches@dev.tarantool.org \
--cc=v.shpilevoy@tarantool.org \
--subject='Re: [Tarantool-patches] [PATCH 2/7] box/error: introduce box.error.set() method' \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox