From: Nikita Pettik <korablev@tarantool.org> To: Vladislav Shpilevoy <v.shpilevoy@tarantool.org> Cc: tarantool-patches@dev.tarantool.org Subject: Re: [Tarantool-patches] [PATCH v2 11/16] sql: introduce sql_stmt_sizeof() function Date: Fri, 13 Dec 2019 16:56:26 +0300 [thread overview] Message-ID: <20191213135626.GA82116@tarantool.org> (raw) In-Reply-To: <8bd6cb33-4a55-8f4c-60cf-bc54928f220e@tarantool.org> On 03 Dec 23:51, Vladislav Shpilevoy wrote: > Thanks for the patch! > > See 4 comments below. > > On 20/11/2019 22:28, Nikita Pettik wrote: > > To implement memory quota of prepared statement cache, we have to > > estimate size of prepared statement. This function attempts at that. > > > > Part of #2592 > > --- > > src/box/execute.h | 8 ++++++++ > > src/box/sql/vdbeapi.c | 53 +++++++++++++++++++++++++++++++++++++++++++++++++++ > > 2 files changed, 61 insertions(+) > > > > diff --git a/src/box/execute.h b/src/box/execute.h > > index 6702a18cc..d5b4d8421 100644 > > --- a/src/box/execute.h > > +++ b/src/box/execute.h > > @@ -116,6 +116,14 @@ extern const struct port_vtab port_sql_vtab; > > int > > sql_finalize(struct sql_stmt *stmt); > > > > +/** > > + * Calculate estimated size of memory occupied by VM. > > + * See sqlVdbeMakeReady() for details concerning allocated > > + * memory. > > + */ > > +size_t > > +sql_stmt_sizeof(const struct sql_stmt *stmt); > > + > > 1. Lets call it 'sql_stmt_sizeof_estimated()'. To emphasize that > the size is not exact. TBO it seems to be too long. I'd better use Konstantin's version: sql_stmt_est_size(). > > /** > > * Prepare (compile into VDBE byte-code) statement. > > * > > diff --git a/src/box/sql/vdbeapi.c b/src/box/sql/vdbeapi.c > > index da528a4dc..10135bb68 100644 > > --- a/src/box/sql/vdbeapi.c > > +++ b/src/box/sql/vdbeapi.c > > @@ -805,6 +805,59 @@ sql_stmt_schema_version(sql_stmt *stmt) > > return v->schema_ver; > > } > > > > +size_t > > +sql_stmt_sizeof(const sql_stmt *stmt) > > 2. You have 'struct' in the declaration, but not > here. I think struct should be added there too. Fixed. > > +{ > > + struct Vdbe *v = (struct Vdbe *) stmt; > > + size_t size = sizeof(*v); > > + /* Resulting set */ > > + size += sizeof(struct Mem) * v->nResColumn * COLNAME_N; > > 3. Could we account column names too? aColName member. It is exactly what is accounted here. Fixed a bit comment: - /* Resulting set */ + /* Names and types of result set columns */ Memory cells containing values of result set are already accounted in v->nMem. > > + /* Opcodes */ > > + size += sizeof(struct VdbeOp) * v->nOp; > > + /* Memory cells */ > > + size += sizeof(struct Mem) * v->nMem; > > + /* Bindings */ > > + size += sizeof(struct Mem) * v->nVar; > > + /* Bindings included in the result set */ > > + size += sizeof(uint32_t) * v->res_var_count; > > + /* Cursors */ > > + size += sizeof(struct VdbeCursor *) * v->nCursor; > > + > > + for (int i = 0; i < v->nOp; ++i) { > > + /* Estimate size of p4 operand. */ > > + if (v->aOp[i].p4type != P4_NOTUSED) { > > 4. You can reduce the indentation: > > - Try to invert the check and do 'continue' when P4 is > unused; > > - 'Case' should be aligned under 'switch' according to > the code style. Thanks, refactord: @@ -825,33 +825,33 @@ sql_stmt_sizeof(const sql_stmt *stmt) for (int i = 0; i < v->nOp; ++i) { /* Estimate size of p4 operand. */ - if (v->aOp[i].p4type != P4_NOTUSED) { - switch (v->aOp[i].p4type) { - case P4_DYNAMIC: - case P4_STATIC: - if (v->aOp[i].opcode == OP_Blob || - v->aOp[i].opcode == OP_String) - size += v->aOp[i].p1; - else if (v->aOp[i].opcode == OP_String8) - size += strlen(v->aOp[i].p4.z); - break; - case P4_BOOL: - size += sizeof(v->aOp[i].p4.b); - break; - case P4_INT32: - size += sizeof(v->aOp[i].p4.i); - break; - case P4_UINT64: - case P4_INT64: - size += sizeof(*v->aOp[i].p4.pI64); - break; - case P4_REAL: - size += sizeof(*v->aOp[i].p4.pReal); - break; - default: - size += sizeof(v->aOp[i].p4.p); - break; - } + if (v->aOp[i].p4type == P4_NOTUSED) + continue; + switch (v->aOp[i].p4type) { + case P4_DYNAMIC: + case P4_STATIC: + if (v->aOp[i].opcode == OP_Blob || + v->aOp[i].opcode == OP_String) + size += v->aOp[i].p1; + else if (v->aOp[i].opcode == OP_String8) + size += strlen(v->aOp[i].p4.z); + break; + case P4_BOOL: + size += sizeof(v->aOp[i].p4.b); + break; + case P4_INT32: + size += sizeof(v->aOp[i].p4.i); + break; + case P4_UINT64: + case P4_INT64: + size += sizeof(*v->aOp[i].p4.pI64); + break; + case P4_REAL: + size += sizeof(*v->aOp[i].p4.pReal); + break; + default: + size += sizeof(v->aOp[i].p4.p); + break; } } size += strlen(v->zSql); > > + switch (v->aOp[i].p4type) { > > + case P4_DYNAMIC: > > + case P4_STATIC: > > + if (v->aOp[i].opcode == OP_Blob || > > + v->aOp[i].opcode == OP_String) > > + size += v->aOp[i].p1; > > + else if (v->aOp[i].opcode == OP_String8) > > + size += strlen(v->aOp[i].p4.z); > > + break; > > + case P4_BOOL: > > + size += sizeof(v->aOp[i].p4.b); > > + break; > > + case P4_INT32: > > + size += sizeof(v->aOp[i].p4.i); > > + break; > > + case P4_UINT64: > > + case P4_INT64: > > + size += sizeof(*v->aOp[i].p4.pI64); > > + break; > > + case P4_REAL: > > + size += sizeof(*v->aOp[i].p4.pReal); > > + break; > > + default: > > + size += sizeof(v->aOp[i].p4.p); > > + break; > > + } > > + }
next prev parent reply other threads:[~2019-12-13 13:56 UTC|newest] Thread overview: 58+ messages / expand[flat|nested] mbox.gz Atom feed top 2019-11-20 21:27 [Tarantool-patches] [PATCH v2 00/16] sql: prepared statements Nikita Pettik 2019-11-20 21:28 ` [Tarantool-patches] [PATCH v2 01/16] sql: remove sql_prepare_v2() Nikita Pettik 2019-12-04 11:36 ` Konstantin Osipov 2019-11-20 21:28 ` [Tarantool-patches] [PATCH v2 02/16] sql: refactor sql_prepare() and sqlPrepare() Nikita Pettik 2019-12-03 22:51 ` Vladislav Shpilevoy 2019-12-04 11:36 ` Konstantin Osipov 2019-11-20 21:28 ` [Tarantool-patches] [PATCH v2 03/16] sql: move sql_prepare() declaration to box/execute.h Nikita Pettik 2019-12-04 11:37 ` Konstantin Osipov 2019-12-05 13:32 ` Nikita Pettik 2019-11-20 21:28 ` [Tarantool-patches] [PATCH v2 04/16] sql: rename sqlPrepare() to sql_compile() Nikita Pettik 2019-12-03 22:51 ` Vladislav Shpilevoy 2019-12-13 13:49 ` Nikita Pettik 2019-12-04 11:39 ` Konstantin Osipov 2019-11-20 21:28 ` [Tarantool-patches] [PATCH v2 05/16] sql: move sql_finalize() to execute.h Nikita Pettik 2019-12-03 22:51 ` Vladislav Shpilevoy 2019-12-04 11:39 ` Konstantin Osipov 2019-12-13 13:49 ` Nikita Pettik 2019-12-04 11:40 ` Konstantin Osipov 2019-12-05 13:37 ` Nikita Pettik 2019-11-20 21:28 ` [Tarantool-patches] [PATCH v2 06/16] port: increase padding of struct port Nikita Pettik 2019-12-04 11:42 ` Konstantin Osipov 2019-12-13 13:54 ` Nikita Pettik 2019-11-20 21:28 ` [Tarantool-patches] [PATCH v2 07/16] port: add dump format and request type to port_sql Nikita Pettik 2019-12-03 22:51 ` Vladislav Shpilevoy 2019-12-13 13:55 ` Nikita Pettik 2019-12-04 11:52 ` Konstantin Osipov 2019-12-13 13:53 ` Nikita Pettik 2019-11-20 21:28 ` [Tarantool-patches] [PATCH v2 08/16] sql: resurrect sql_bind_parameter_count() function Nikita Pettik 2019-12-03 22:51 ` Vladislav Shpilevoy 2019-12-04 11:54 ` Konstantin Osipov 2019-11-20 21:28 ` [Tarantool-patches] [PATCH v2 09/16] sql: resurrect sql_bind_parameter_name() Nikita Pettik 2019-12-04 11:55 ` Konstantin Osipov 2019-12-04 11:55 ` Konstantin Osipov 2019-12-13 13:55 ` Nikita Pettik 2019-11-20 21:28 ` [Tarantool-patches] [PATCH v2 10/16] sql: add sql_stmt_schema_version() Nikita Pettik 2019-12-04 11:57 ` Konstantin Osipov 2019-11-20 21:28 ` [Tarantool-patches] [PATCH v2 11/16] sql: introduce sql_stmt_sizeof() function Nikita Pettik 2019-12-03 22:51 ` Vladislav Shpilevoy 2019-12-13 13:56 ` Nikita Pettik [this message] 2019-12-04 11:59 ` Konstantin Osipov 2019-12-13 13:56 ` Nikita Pettik 2019-12-13 14:15 ` Konstantin Osipov 2019-11-20 21:28 ` [Tarantool-patches] [PATCH v2 12/16] box: increment schema_version on ddl operations Nikita Pettik 2019-12-04 12:03 ` Konstantin Osipov 2019-11-20 21:28 ` [Tarantool-patches] [PATCH v2 13/16] sql: introduce sql_stmt_query_str() method Nikita Pettik 2019-12-03 22:51 ` Vladislav Shpilevoy 2019-12-04 12:04 ` Konstantin Osipov 2019-11-20 21:28 ` [Tarantool-patches] [PATCH v2 14/16] sql: introduce cache for prepared statemets Nikita Pettik 2019-12-03 22:51 ` Vladislav Shpilevoy 2019-12-04 12:11 ` Konstantin Osipov 2019-12-17 14:43 ` Kirill Yukhin 2019-11-20 21:28 ` [Tarantool-patches] [PATCH v2 15/16] box: introduce prepared statements Nikita Pettik 2019-12-04 12:13 ` Konstantin Osipov 2019-12-06 23:18 ` Vladislav Shpilevoy 2019-11-20 21:28 ` [Tarantool-patches] [PATCH v2 16/16] netbox: " Nikita Pettik 2019-12-06 23:18 ` Vladislav Shpilevoy 2019-12-03 22:51 ` [Tarantool-patches] [PATCH v2 00/16] sql: " Vladislav Shpilevoy 2019-12-17 15:58 ` Georgy Kirichenko
Reply instructions: You may reply publicly to this message via plain-text email using any one of the following methods: * Save the following mbox file, import it into your mail client, and reply-to-all from there: mbox Avoid top-posting and favor interleaved quoting: https://en.wikipedia.org/wiki/Posting_style#Interleaved_style * Reply using the --to, --cc, and --in-reply-to switches of git-send-email(1): git send-email \ --in-reply-to=20191213135626.GA82116@tarantool.org \ --to=korablev@tarantool.org \ --cc=tarantool-patches@dev.tarantool.org \ --cc=v.shpilevoy@tarantool.org \ --subject='Re: [Tarantool-patches] [PATCH v2 11/16] sql: introduce sql_stmt_sizeof() function' \ /path/to/YOUR_REPLY https://kernel.org/pub/software/scm/git/docs/git-send-email.html * If your mail client supports setting the In-Reply-To header via mailto: links, try the mailto: link
This is a public inbox, see mirroring instructions for how to clone and mirror all data and code used for this inbox