From: Nikita Pettik <korablev@tarantool.org> To: Konstantin Osipov <kostja.osipov@gmail.com>, tarantool-patches@dev.tarantool.org, v.shpilevoy@tarantool.org Subject: Re: [Tarantool-patches] [PATCH v2 07/16] port: add dump format and request type to port_sql Date: Fri, 13 Dec 2019 16:53:43 +0300 [thread overview] Message-ID: <20191213135343.GA75855@tarantool.org> (raw) In-Reply-To: <20191204115244.GI6592@atlas> On 04 Dec 14:52, Konstantin Osipov wrote: > * Nikita Pettik <korablev@tarantool.org> [19/11/21 10:00]: > > Dump formats of DQL and DML queries are different: the last one contains > > Ergh, this is not dump, but result set/serialization format. Dump > in SQL is usually used for logical or physical database > backup. Okay, let's rename to sql_serialization_format > > number of affected rows and optionally list of autoincremented ids; the > > first one comprises all meta-information including column names of > > resulting set and their types. What is more, dump format is going to be > > different for execute and prepare requests. So let's introduce separate > > member to struct port_sql responsible for dump format to be used. > > > > What is more, prepared statement finalization is required only for > > PREPARE-AND-EXECUTE requests. So let's keep request type in port as well. > > > > > Note that C standard specifies that enums are integers, but it does not > > specify the size. Hence, let's use simple uint8 - mentioned enums are > > small enough to fit into it. > > enum sizeof in C and older C++ is implementation dependent. > > what do you mean here? To store uint8 numbers instead of enums (due to their implementation dependent sizes). > > + struct port_sql *port_sql = (struct port_sql *) base; > > + if (port_sql->request == PREPARE_AND_EXECUTE) > > + sql_finalize(((struct port_sql *)base)->stmt); > > Does this work with the statement object only or with the cache as > well? Only with prepared statement objects. > I suggest we introduce a clear naming for API calls: > > sql_stmt_* - for statement object api > sql_stmt_cache_* - for prepared statement api > sql_finalize, sql_prepare, sql_execute - for SQL high level API > which manipulates both statements and the cache. > > What do you think? Ok, will move renaming sql_finalize -> sql_stmt_finalize etc to a separate patch. I'm okay with suggested naming and I'm going to use it in the next patches. > > -port_sql_create(struct port *port, struct sql_stmt *stmt) > > +port_sql_create(struct port *port, struct sql_stmt *stmt, > > + enum sql_dump_format dump_format, enum sql_request_type request) > > { > > port_tuple_create(port); > > - ((struct port_sql *)port)->stmt = stmt; > > port->vtab = &port_sql_vtab; > > + struct port_sql *port_sql = (struct port_sql *) port; > > + port_sql->stmt = stmt; > > + port_sql->dump_format = dump_format; > > Let's use sql_result_set_format? Do you have to introduce this > enum ? This information can be derived from sql_request_type, no + > statement type, no? If yes, I suggest to have a function, which > returns it, rather than store. To save 1 byte? :) Doesn't seem to be reasonable tho. Current implementation looks quite suitable in code. > > +/** > > + * One of possible formats used to dump msgpack/Lua. > > + * For details see port_sql_dump_msgpack() and port_sql_dump_lua(). > > > > + */ > > +enum sql_dump_format { > > + DQL_EXECUTE = 0, > > + DML_EXECUTE = 1, > > + DQL_PREPARE = 2, > > + DML_PREPARE = 3, > > +}; > > Neither the names of the members nor comments convey what is going > on here - looks like a simple matrix dml/dql * prepare/execute. That's it. > Having a couple of if statments is not such a big deal IMHO. With this enum code looks way much better. > > + /** > > + * Dump format depends on type of SQL query: DML or DQL; > > + * and on type of SQL request: execute or prepare. > > + */ > > + uint8_t dump_format; > > + /** enum sql_request_type */ > > + uint8_t request; > > If I had to add these constants, I would not use type-erasing > uint8 here, but use max value for enum in C/C++, which is 64 bits > and the original type. Now one is replaced with do_finalize as Vlad suggested.
next prev parent reply other threads:[~2019-12-13 13:53 UTC|newest] Thread overview: 58+ messages / expand[flat|nested] mbox.gz Atom feed top 2019-11-20 21:27 [Tarantool-patches] [PATCH v2 00/16] sql: prepared statements Nikita Pettik 2019-11-20 21:28 ` [Tarantool-patches] [PATCH v2 01/16] sql: remove sql_prepare_v2() Nikita Pettik 2019-12-04 11:36 ` Konstantin Osipov 2019-11-20 21:28 ` [Tarantool-patches] [PATCH v2 02/16] sql: refactor sql_prepare() and sqlPrepare() Nikita Pettik 2019-12-03 22:51 ` Vladislav Shpilevoy 2019-12-04 11:36 ` Konstantin Osipov 2019-11-20 21:28 ` [Tarantool-patches] [PATCH v2 03/16] sql: move sql_prepare() declaration to box/execute.h Nikita Pettik 2019-12-04 11:37 ` Konstantin Osipov 2019-12-05 13:32 ` Nikita Pettik 2019-11-20 21:28 ` [Tarantool-patches] [PATCH v2 04/16] sql: rename sqlPrepare() to sql_compile() Nikita Pettik 2019-12-03 22:51 ` Vladislav Shpilevoy 2019-12-13 13:49 ` Nikita Pettik 2019-12-04 11:39 ` Konstantin Osipov 2019-11-20 21:28 ` [Tarantool-patches] [PATCH v2 05/16] sql: move sql_finalize() to execute.h Nikita Pettik 2019-12-03 22:51 ` Vladislav Shpilevoy 2019-12-04 11:39 ` Konstantin Osipov 2019-12-13 13:49 ` Nikita Pettik 2019-12-04 11:40 ` Konstantin Osipov 2019-12-05 13:37 ` Nikita Pettik 2019-11-20 21:28 ` [Tarantool-patches] [PATCH v2 06/16] port: increase padding of struct port Nikita Pettik 2019-12-04 11:42 ` Konstantin Osipov 2019-12-13 13:54 ` Nikita Pettik 2019-11-20 21:28 ` [Tarantool-patches] [PATCH v2 07/16] port: add dump format and request type to port_sql Nikita Pettik 2019-12-03 22:51 ` Vladislav Shpilevoy 2019-12-13 13:55 ` Nikita Pettik 2019-12-04 11:52 ` Konstantin Osipov 2019-12-13 13:53 ` Nikita Pettik [this message] 2019-11-20 21:28 ` [Tarantool-patches] [PATCH v2 08/16] sql: resurrect sql_bind_parameter_count() function Nikita Pettik 2019-12-03 22:51 ` Vladislav Shpilevoy 2019-12-04 11:54 ` Konstantin Osipov 2019-11-20 21:28 ` [Tarantool-patches] [PATCH v2 09/16] sql: resurrect sql_bind_parameter_name() Nikita Pettik 2019-12-04 11:55 ` Konstantin Osipov 2019-12-04 11:55 ` Konstantin Osipov 2019-12-13 13:55 ` Nikita Pettik 2019-11-20 21:28 ` [Tarantool-patches] [PATCH v2 10/16] sql: add sql_stmt_schema_version() Nikita Pettik 2019-12-04 11:57 ` Konstantin Osipov 2019-11-20 21:28 ` [Tarantool-patches] [PATCH v2 11/16] sql: introduce sql_stmt_sizeof() function Nikita Pettik 2019-12-03 22:51 ` Vladislav Shpilevoy 2019-12-13 13:56 ` Nikita Pettik 2019-12-04 11:59 ` Konstantin Osipov 2019-12-13 13:56 ` Nikita Pettik 2019-12-13 14:15 ` Konstantin Osipov 2019-11-20 21:28 ` [Tarantool-patches] [PATCH v2 12/16] box: increment schema_version on ddl operations Nikita Pettik 2019-12-04 12:03 ` Konstantin Osipov 2019-11-20 21:28 ` [Tarantool-patches] [PATCH v2 13/16] sql: introduce sql_stmt_query_str() method Nikita Pettik 2019-12-03 22:51 ` Vladislav Shpilevoy 2019-12-04 12:04 ` Konstantin Osipov 2019-11-20 21:28 ` [Tarantool-patches] [PATCH v2 14/16] sql: introduce cache for prepared statemets Nikita Pettik 2019-12-03 22:51 ` Vladislav Shpilevoy 2019-12-04 12:11 ` Konstantin Osipov 2019-12-17 14:43 ` Kirill Yukhin 2019-11-20 21:28 ` [Tarantool-patches] [PATCH v2 15/16] box: introduce prepared statements Nikita Pettik 2019-12-04 12:13 ` Konstantin Osipov 2019-12-06 23:18 ` Vladislav Shpilevoy 2019-11-20 21:28 ` [Tarantool-patches] [PATCH v2 16/16] netbox: " Nikita Pettik 2019-12-06 23:18 ` Vladislav Shpilevoy 2019-12-03 22:51 ` [Tarantool-patches] [PATCH v2 00/16] sql: " Vladislav Shpilevoy 2019-12-17 15:58 ` Georgy Kirichenko
Reply instructions: You may reply publicly to this message via plain-text email using any one of the following methods: * Save the following mbox file, import it into your mail client, and reply-to-all from there: mbox Avoid top-posting and favor interleaved quoting: https://en.wikipedia.org/wiki/Posting_style#Interleaved_style * Reply using the --to, --cc, and --in-reply-to switches of git-send-email(1): git send-email \ --in-reply-to=20191213135343.GA75855@tarantool.org \ --to=korablev@tarantool.org \ --cc=kostja.osipov@gmail.com \ --cc=tarantool-patches@dev.tarantool.org \ --cc=v.shpilevoy@tarantool.org \ --subject='Re: [Tarantool-patches] [PATCH v2 07/16] port: add dump format and request type to port_sql' \ /path/to/YOUR_REPLY https://kernel.org/pub/software/scm/git/docs/git-send-email.html * If your mail client supports setting the In-Reply-To header via mailto: links, try the mailto: link
This is a public inbox, see mirroring instructions for how to clone and mirror all data and code used for this inbox