From: Konstantin Osipov <kostja@tarantool.org> To: Kirill Shcherbatov <kshcherbatov@tarantool.org> Cc: Tarantool MailList <tarantool-patches@freelists.org>, Nikita Pettik <korablev@tarantool.org> Subject: [tarantool-patches] Re: [PATCH v2 7/8] sql: get rid of FuncDef function hash Date: Tue, 13 Aug 2019 11:42:46 +0300 [thread overview] Message-ID: <20190813084246.GA5284@atlas> (raw) In-Reply-To: <28e7766a-0374-36ab-d848-a533106dedda@tarantool.org> * Kirill Shcherbatov <kshcherbatov@tarantool.org> [19/08/13 10:30]: > >> + REG_FUNC("ABS", ARGC_MASK(1), FIELD_TYPE_NUMBER, 0, > >> + absFunc, NULL, true), > > > > > > This looks like huge overengineering. > > > > A bunch of macros, a binary search, can you just open-code > > inserting all of these functions into the hash? It would be > > perhaps a bit more copy-paste, but it will be easy to maintain. > > > > Am I missing something? > > This constructor is called automatically during function recovery > by prototype defined in snapshot. Thus all functions are > initialized in a one place: in on_replace_dd_func trigger. > > I like this concept because it is uniform and all implementation-dependent > details (like the completion of the function definition initialization) are hidden > in the corresponding module (sql/func.c). What does this code do? Why do you need an anonymous structure, instead of initializing struct func_sql_builtn object right away? What do you need the binary search for? Pre-ordering the array for the binary search is very fragile. > Technically we may skip a function cache entry creation for SQL_BUILTIN > tuple type in on_replace_dd_func trigger, to perform the whole preparements > during Tarantool initialization. This require to distinguish SQL_BUILTIN entries > and other types in trigger and this is not cool, I believe. > > Finally, a current approach enforces keeping snapshot will all built in definitions > in actual state. Can this be coded in Lua, in upgrade.lua? -- Konstantin Osipov, Moscow, Russia
next prev parent reply other threads:[~2019-08-13 8:42 UTC|newest] Thread overview: 38+ messages / expand[flat|nested] mbox.gz Atom feed top 2019-08-08 14:50 [tarantool-patches] [PATCH v2 0/8] sql: uniform SQL and Lua functions subsystem Kirill Shcherbatov 2019-08-08 14:50 ` [tarantool-patches] [PATCH v2 1/8] sql: remove SQL_PreferBuiltin flag Kirill Shcherbatov 2019-08-09 16:07 ` [tarantool-patches] " n.pettik 2019-08-12 21:58 ` Konstantin Osipov 2019-08-08 14:50 ` [tarantool-patches] [PATCH v2 2/8] sql: GREATEST, LEAST instead of MIN/MAX overload Kirill Shcherbatov 2019-08-09 17:37 ` [tarantool-patches] " n.pettik 2019-08-13 8:26 ` Kirill Shcherbatov 2019-08-12 21:59 ` Konstantin Osipov 2019-08-08 14:50 ` [tarantool-patches] [PATCH v2 3/8] sql: wrap all trim functions in dispatcher Kirill Shcherbatov 2019-08-09 18:05 ` [tarantool-patches] " n.pettik 2019-08-13 8:28 ` Kirill Shcherbatov 2019-08-13 22:19 ` n.pettik 2019-08-12 22:00 ` Konstantin Osipov 2019-08-08 14:50 ` [tarantool-patches] [PATCH v2 4/8] sql: get rid of SQL_FUNC_COUNT flag Kirill Shcherbatov 2019-08-12 22:01 ` [tarantool-patches] " Konstantin Osipov 2019-08-13 20:35 ` n.pettik 2019-08-14 7:25 ` Kirill Shcherbatov 2019-08-08 14:50 ` [tarantool-patches] [PATCH v2 5/8] sql: introduce a signature_mask for functions Kirill Shcherbatov 2019-08-12 22:04 ` [tarantool-patches] " Konstantin Osipov 2019-08-13 8:32 ` Kirill Shcherbatov 2019-08-13 8:44 ` Konstantin Osipov 2019-08-13 20:38 ` n.pettik 2019-08-14 7:21 ` Kirill Shcherbatov 2019-08-08 14:50 ` [tarantool-patches] [PATCH v2 6/8] sql: rename OP_Function to OP_BuiltinFunction Kirill Shcherbatov 2019-08-12 22:04 ` [tarantool-patches] " Konstantin Osipov 2019-08-13 20:36 ` n.pettik 2019-08-08 14:50 ` [tarantool-patches] [PATCH v2 7/8] sql: get rid of FuncDef function hash Kirill Shcherbatov 2019-08-12 22:11 ` [tarantool-patches] " Konstantin Osipov 2019-08-13 7:29 ` Kirill Shcherbatov 2019-08-13 8:42 ` Konstantin Osipov [this message] 2019-08-13 9:45 ` Kirill Shcherbatov 2019-08-13 20:40 ` n.pettik 2019-08-16 12:57 ` Kirill Shcherbatov 2019-08-20 16:06 ` n.pettik 2019-08-08 14:50 ` [tarantool-patches] [PATCH v2 8/8] box: get rid of box.internal.sql_function_create Kirill Shcherbatov 2019-08-13 20:43 ` [tarantool-patches] " n.pettik 2019-08-16 12:57 ` Kirill Shcherbatov 2019-08-20 19:36 ` n.pettik
Reply instructions: You may reply publicly to this message via plain-text email using any one of the following methods: * Save the following mbox file, import it into your mail client, and reply-to-all from there: mbox Avoid top-posting and favor interleaved quoting: https://en.wikipedia.org/wiki/Posting_style#Interleaved_style * Reply using the --to, --cc, and --in-reply-to switches of git-send-email(1): git send-email \ --in-reply-to=20190813084246.GA5284@atlas \ --to=kostja@tarantool.org \ --cc=korablev@tarantool.org \ --cc=kshcherbatov@tarantool.org \ --cc=tarantool-patches@freelists.org \ --subject='[tarantool-patches] Re: [PATCH v2 7/8] sql: get rid of FuncDef function hash' \ /path/to/YOUR_REPLY https://kernel.org/pub/software/scm/git/docs/git-send-email.html * If your mail client supports setting the In-Reply-To header via mailto: links, try the mailto: link
This is a public inbox, see mirroring instructions for how to clone and mirror all data and code used for this inbox