Tarantool development patches archive
 help / color / mirror / Atom feed
From: Vladimir Davydov <vdavydov.dev@gmail.com>
To: Konstantin Osipov <kostja.osipov@gmail.com>
Cc: tarantool-patches@freelists.org
Subject: Re: [PATCH 03/13] vinyl: store tuple comparison hints in tx write set
Date: Thu, 4 Apr 2019 20:28:44 +0300	[thread overview]
Message-ID: <20190404172844.gllh3csaqghoumqt@esperanza> (raw)
In-Reply-To: <20190404124001.GL28969@chai>

On Thu, Apr 04, 2019 at 03:40:01PM +0300, Konstantin Osipov wrote:
> * Vladimir Davydov <vdavydov.dev@gmail.com> [19/04/04 15:24]:
> > On Thu, Apr 04, 2019 at 02:41:17PM +0300, Konstantin Osipov wrote:
> > > * Vladimir Davydov <vdavydov.dev@gmail.com> [19/04/02 20:35]:
> > > > This patch incorporates tuple comparison hints into the transaction
> > > > write set. Now, beside a statement, each txv also stores its hint,
> > > > which is used in all comparison operations.
> > > 
> > > Actually, the more I look at this patch set the more an object
> > > representing a pair <tuple, hint> (vy_key?) is called for.
> > > Please consider adding it, it could be passed around by value.
> > 
> > This could be reasonable, but I don't quite like the name vy_key,
> > because in vinyl we have a different concept of keys.
> > 
> > A few names that pop into mind:
> > 
> > 	vy_kv.{stmt,val}
> 
> vy_mem_key?

Nah, it's not exactly a key. It may be a tuple, actually.
Would still be confusing since we have vy_stmt_is_key() helper,
which checks whether a statement is in key format.

Besides, we already have vy_mem_tree_key, which is used for lookups in
vy_mem_tree. Having both vy_mem_key and vy_mem_tree_key would definitely
be confusing.

What about vy_item or vy_entry? That would emphasize that this thing
comes from some kind of a container (e.g. vy_mem_tree). We already have
vy_cache_entry so I'd rather call it vy_item - it's short and unique.

Other variants:

	vy_record
	vy_element (or even vy_elem)
	vy_entity
	vy_unit
	vy_thing :)
	vy_object
	vy_article

  reply	other threads:[~2019-04-04 17:28 UTC|newest]

Thread overview: 31+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2019-04-02 17:33 [PATCH 00/13] Incorporate tuple comparison hints into Vinyl Vladimir Davydov
2019-04-02 17:33 ` [PATCH 01/13] vinyl: store tuple comparison hints in memory tree Vladimir Davydov
2019-04-04  8:53   ` Konstantin Osipov
2019-04-04  9:09     ` Vladimir Davydov
2019-04-04  9:48       ` Konstantin Osipov
2019-04-02 17:33 ` [PATCH 02/13] vinyl: store tuple comparison hints in cache tree Vladimir Davydov
2019-04-04 11:39   ` Konstantin Osipov
2019-04-02 17:33 ` [PATCH 03/13] vinyl: store tuple comparison hints in tx write set Vladimir Davydov
2019-04-04 11:41   ` Konstantin Osipov
2019-04-04 12:21     ` Vladimir Davydov
2019-04-04 12:40       ` Konstantin Osipov
2019-04-04 17:28         ` Vladimir Davydov [this message]
2019-04-02 17:33 ` [PATCH 04/13] vinyl: store tuple comparison hints in tx read set Vladimir Davydov
2019-04-04 11:42   ` Konstantin Osipov
2019-04-04 12:08     ` Vladimir Davydov
2019-04-02 17:33 ` [PATCH 05/13] vinyl: store tuple comparison hints in range tree Vladimir Davydov
2019-04-02 17:33 ` [PATCH 06/13] vinyl: store tuple comparison hints in page index Vladimir Davydov
2019-04-02 17:33 ` [PATCH 07/13] vinyl: propagate tuple comparison hints to read iterator Vladimir Davydov
2019-04-04 11:43   ` Konstantin Osipov
2019-04-02 17:33 ` [PATCH 08/13] vinyl: propagate tuple comparison hints to write iterator Vladimir Davydov
2019-04-04 11:47   ` Konstantin Osipov
2019-04-02 17:33 ` [PATCH 09/13] vinyl: forward tuple comparison hints to memory tree Vladimir Davydov
2019-04-04 12:10   ` Konstantin Osipov
2019-04-02 17:33 ` [PATCH 10/13] vinyl: forward tuple comparison hints to cache tree Vladimir Davydov
2019-04-04 12:11   ` Konstantin Osipov
2019-04-02 17:33 ` [PATCH 11/13] vinyl: forward tuple comparison hints to read iterator Vladimir Davydov
2019-04-04 12:12   ` Konstantin Osipov
2019-04-02 17:33 ` [PATCH 12/13] vinyl: forward tuple comparison hints to tx read set Vladimir Davydov
2019-04-04 12:12   ` Konstantin Osipov
2019-04-02 17:33 ` [PATCH 13/13] Make tuple comparison hints mandatory Vladimir Davydov
2019-04-04 12:21   ` Konstantin Osipov

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20190404172844.gllh3csaqghoumqt@esperanza \
    --to=vdavydov.dev@gmail.com \
    --cc=kostja.osipov@gmail.com \
    --cc=tarantool-patches@freelists.org \
    --subject='Re: [PATCH 03/13] vinyl: store tuple comparison hints in tx write set' \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox