Tarantool development patches archive
 help / color / mirror / Atom feed
From: Vladimir Davydov <vdavydov.dev@gmail.com>
To: Kirill Shcherbatov <kshcherbatov@tarantool.org>
Cc: tarantool-patches@freelists.org
Subject: Re: [tarantool-patches] Re: [PATCH v1 1/1] Implement mp_stack_top for mp_stack class
Date: Wed, 3 Apr 2019 18:40:03 +0300	[thread overview]
Message-ID: <20190403154003.kdpt3vgbqtch3sjg@esperanza> (raw)
In-Reply-To: <4377f916-eb85-44c4-2124-cb4b14d5a6d4@tarantool.org>

On Wed, Apr 03, 2019 at 06:16:25PM +0300, Kirill Shcherbatov wrote:
> > or something like that. BTW, if you agree, let's also rename 'curr' to
> > 'idx' or 'index' - 'curr' looks kinda ugly and since now we are going to
> > access it directly, we'd better rename it IMO.
> > 
> > What do you think?
> 
> I am not shure that it is good concept. Consider a part of MP_PRINT macro
> 
> 	while (!mp_stack_is_empty(&stack)) {
> 		struct mp_frame *frame = mp_stack_top(&stack);
> 		enum mp_type type = frame->type;
> 		bool stop = !mp_frame_advance(frame);
> 		if (frame->idx == 0 || frame->count == 0)
> 			PRINTF(type == MP_ARRAY ? "[" : "{");
> 		if (stop) {
> 			PRINTF(type == MP_ARRAY ? "]" : "}");
> 			mp_stack_pop(&stack);
> 			continue;
> 		} else if (frame->idx != 0) {
> 			PRINTF(type == MP_MAP && frame->idx % 2 == 1 ? ": " : ", ");
> 		}
> 		goto next;
> 	}
> 
> To my opinion, the code got worse.

Yeah, you're right, with the 'stop' flag it doesn't look good.
However, we could rewrite it in a slightly different fashion.
So here's what we have now for comparison:

	while (!mp_stack_is_empty(&stack)) {
		enum mp_type type = mp_stack_type(&stack);
		int curr = mp_stack_advance(&stack);
		if (curr == 0 || mp_stack_count(&stack) == 0)
			PRINTF(type == MP_ARRAY ? "[" : "{");
		if (curr == -1) {
			PRINTF(type == MP_ARRAY ? "]" : "}");
			mp_stack_pop(&stack);
			continue;
		} else if (curr != 0) {
			PRINTF(type == MP_MAP && curr % 2 == 1 ? ": " : ", ");
		}
		goto next;
	}

Here's what we could turn this into using the new API:

	while (!mp_stack_is_empty(&stack)) {
		enum mp_frame *frame = mp_stack_top(&stack);
		if (frame->idx < 0)
			PRINTF(type == MP_ARRAY ? "[" : "{");
		if (!mp_frame_advance(frame)) {
			PRINTF(type == MP_ARRAY ? "]" : "}");
			mp_stack_pop(&stack);
			continue;
		} else if (frame->idx != 0) {
			PRINTF(type == MP_MAP && frame->idx % 2 == 1 ? ": " : ", ");
		}
		goto next;
	}

Now it's not that bad, don't you agree? We even managed to get rid of
the empty array/map check.

  reply	other threads:[~2019-04-03 15:40 UTC|newest]

Thread overview: 8+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2019-04-02 15:49 Kirill Shcherbatov
2019-04-03 12:12 ` Vladimir Davydov
2019-04-03 15:16   ` [tarantool-patches] " Kirill Shcherbatov
2019-04-03 15:40     ` Vladimir Davydov [this message]
2019-04-03 17:49       ` Kirill Shcherbatov
2019-04-04 15:42         ` Vladimir Davydov
2019-04-05 17:17           ` Kirill Shcherbatov
2019-04-07 12:02             ` Vladimir Davydov

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20190403154003.kdpt3vgbqtch3sjg@esperanza \
    --to=vdavydov.dev@gmail.com \
    --cc=kshcherbatov@tarantool.org \
    --cc=tarantool-patches@freelists.org \
    --subject='Re: [tarantool-patches] Re: [PATCH v1 1/1] Implement mp_stack_top for mp_stack class' \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox