From: Vladimir Davydov <vdavydov.dev@gmail.com>
To: Cyrill Gorcunov <gorcunov@gmail.com>
Cc: tml <tarantool-patches@freelists.org>
Subject: Re: [PATCH 1/2] lib/core/fiber: Rename stack_direction to stack_growsdown
Date: Wed, 27 Mar 2019 12:35:10 +0300 [thread overview]
Message-ID: <20190327093510.f6jtxo35kwsv7ywg@esperanza> (raw)
In-Reply-To: <20190319193845.31221-2-gorcunov@gmail.com>
On Tue, Mar 19, 2019 at 10:38:44PM +0300, Cyrill Gorcunov wrote:
> Since growsdown (or growsup) is more clear and common name.
> ---
> src/lib/core/fiber.c | 16 ++++++++--------
> 1 file changed, 8 insertions(+), 8 deletions(-)
>
> diff --git a/src/lib/core/fiber.c b/src/lib/core/fiber.c
> index c55b3ab39..922a0bfe8 100644
> --- a/src/lib/core/fiber.c
> +++ b/src/lib/core/fiber.c
> @@ -105,7 +105,7 @@ __thread struct cord *cord_ptr = NULL;
> pthread_t main_thread_id;
>
> static size_t page_size;
> -static int stack_direction;
> +static bool stack_growsdown;
>
> enum {
> /* The minimum allowable fiber stack size in bytes */
> @@ -808,7 +808,7 @@ fiber_stack_recycle(struct fiber *fiber)
> * it anyway.
> */
> void *start, *end;
> - if (stack_direction < 0) {
> + if (stack_growsdown) {
TBO I like stack_direction more as it's looks symmetrical, so to say.
I'd refrain from changing this if there's no other reason rather than
personal taste.
next prev parent reply other threads:[~2019-03-27 9:35 UTC|newest]
Thread overview: 18+ messages / expand[flat|nested] mbox.gz Atom feed top
2019-03-19 19:38 [RFC 0/2] lib/core/fiber: Allow to extend stack size via env variable Cyrill Gorcunov
2019-03-19 19:38 ` [PATCH 1/2] lib/core/fiber: Rename stack_direction to stack_growsdown Cyrill Gorcunov
2019-03-27 9:35 ` Vladimir Davydov [this message]
2019-03-27 9:48 ` Cyrill Gorcunov
2019-03-27 10:20 ` Vladimir Davydov
2019-03-27 10:30 ` Cyrill Gorcunov
2019-03-19 19:38 ` [PATCH 2/2] lib/core/fiber: Allow to extend default stack size Cyrill Gorcunov
2019-03-27 9:35 ` Vladimir Davydov
2019-03-27 9:46 ` Cyrill Gorcunov
2019-03-27 10:15 ` Vladimir Davydov
2019-03-27 10:23 ` Cyrill Gorcunov
2019-04-01 17:41 ` Cyrill Gorcunov
2019-04-01 18:58 ` Konstantin Osipov
2019-04-01 19:19 ` Cyrill Gorcunov
2019-04-01 20:51 ` Konstantin Osipov
2019-04-01 22:05 ` Cyrill Gorcunov
2019-04-02 7:14 ` Konstantin Osipov
2019-04-02 8:09 ` Cyrill Gorcunov
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20190327093510.f6jtxo35kwsv7ywg@esperanza \
--to=vdavydov.dev@gmail.com \
--cc=gorcunov@gmail.com \
--cc=tarantool-patches@freelists.org \
--subject='Re: [PATCH 1/2] lib/core/fiber: Rename stack_direction to stack_growsdown' \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox