From: Vladimir Davydov <vdavydov.dev@gmail.com>
To: Vladislav Shpilevoy <v.shpilevoy@tarantool.org>
Cc: tarantool-patches@freelists.org
Subject: Re: [PATCH 4/8] box: remove orphan check from box_is_ro()
Date: Mon, 13 Aug 2018 11:34:30 +0300 [thread overview]
Message-ID: <20180813083430.ofl75nzppuixwwpa@esperanza> (raw)
In-Reply-To: <07b102e6b0abd42b550e718fd366927144b0c527.1533679264.git.v.shpilevoy@tarantool.org>
On Wed, Aug 08, 2018 at 01:03:47AM +0300, Vladislav Shpilevoy wrote:
> Box_is_ro now checks both for 'read_only' and 'orphan' modes, but
> in promotion only 'read_only' is needed. And now there is no a
> method to get the current 'read_only' value. After replacing
> box_is_ro with box_is_writable it is possible to reimplement
> box_is_ro as a getter for 'read_only' option.
> ---
> src/box/box.cc | 10 ++++++++--
> src/box/box.h | 3 +++
> src/box/lua/info.c | 2 +-
> 3 files changed, 12 insertions(+), 3 deletions(-)
>
> diff --git a/src/box/box.cc b/src/box/box.cc
> index 6eb358442..d8fbc6252 100644
> --- a/src/box/box.cc
> +++ b/src/box/box.cc
> @@ -216,17 +216,23 @@ box_set_ro(bool ro)
> fiber_cond_broadcast(&ro_cond);
> }
>
> +bool
> +box_is_writable(void)
> +{
> + return !is_ro && !is_orphan;
> +}
> +
> bool
> box_is_ro(void)
> {
> - return is_ro || is_orphan;
> + return is_ro;
> }
>
> int
> box_wait_ro(bool ro, double timeout)
> {
> double deadline = ev_monotonic_now(loop()) + timeout;
> - while (box_is_ro() != ro) {
> + while (!box_is_writable() != ro) {
> if (fiber_cond_wait_deadline(&ro_cond, deadline) != 0)
> return -1;
> if (fiber_is_cancelled()) {
So now we have box_wait_ro() that checks box_is_writable() !=
box.cfg.read_only and we have box_is_ro() that returns the value
of box.cfg.read_only. Looks ugly.
I think that the promotion algorithm shouldn't flip box.cfg.read_only.
Instead it should use its own flag and box_is_ro() should be defined as
bool box_is_ro() { return is_ro || is_oprhan || is_slave; }
That would be consistent with the orphan state.
next prev parent reply other threads:[~2018-08-13 8:34 UTC|newest]
Thread overview: 13+ messages / expand[flat|nested] mbox.gz Atom feed top
2018-08-07 22:03 [PATCH 0/8] box.ctl.promote Vladislav Shpilevoy
2018-08-07 22:03 ` [PATCH 1/8] rfc: describe box.ctl.promote protocol Vladislav Shpilevoy
2018-08-07 22:03 ` [PATCH 2/8] box: rename process_rw to process_dml Vladislav Shpilevoy
2018-08-13 8:20 ` Vladimir Davydov
2018-08-07 22:03 ` [PATCH 3/8] Add 'exact_field_count' parameter to options decoder Vladislav Shpilevoy
2018-08-13 8:30 ` Vladimir Davydov
2018-08-07 22:03 ` [PATCH 4/8] box: remove orphan check from box_is_ro() Vladislav Shpilevoy
2018-08-13 8:34 ` Vladimir Davydov [this message]
2018-08-07 22:03 ` [PATCH 5/8] Fix gcov on Mac Vladislav Shpilevoy
2018-08-07 22:03 ` [PATCH 6/8] box: introduce _promotion space Vladislav Shpilevoy
2018-08-07 22:03 ` [PATCH 7/8] box: introduce box.ctl.promote Vladislav Shpilevoy
2018-08-13 8:58 ` Vladimir Davydov
2018-08-07 22:03 ` [PATCH 8/8] box: introduce promotion GC Vladislav Shpilevoy
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20180813083430.ofl75nzppuixwwpa@esperanza \
--to=vdavydov.dev@gmail.com \
--cc=tarantool-patches@freelists.org \
--cc=v.shpilevoy@tarantool.org \
--subject='Re: [PATCH 4/8] box: remove orphan check from box_is_ro()' \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox