Tarantool development patches archive
 help / color / mirror / Atom feed
From: Vladimir Davydov <vdavydov.dev@gmail.com>
To: Vladislav Shpilevoy <v.shpilevoy@tarantool.org>
Cc: tarantool-patches@freelists.org
Subject: Re: [PATCH 2/8] box: rename process_rw to process_dml
Date: Mon, 13 Aug 2018 11:20:44 +0300	[thread overview]
Message-ID: <20180813082044.my6iydxsfzrp45o6@esperanza> (raw)
In-Reply-To: <92068d7f9e7fe5f5c912d7899e1c68707479fadf.1533679264.git.v.shpilevoy@tarantool.org>

On Wed, Aug 08, 2018 at 01:03:45AM +0300, Vladislav Shpilevoy wrote:
> diff --git a/src/box/iproto.cc b/src/box/iproto.cc
> index bb7d2b868..f8b419c26 100644
> --- a/src/box/iproto.cc
> +++ b/src/box/iproto.cc
> @@ -1368,7 +1368,7 @@ tx_process1(struct cmsg *m)
>  	struct obuf_svp svp;
>  	struct obuf *out;
>  	tx_inject_delay();
> -	if (box_process1(&msg->dml, &tuple) != 0)
> +	if (box_process_dml(&msg->dml, &tuple) != 0)
>  		goto error;
>  	out = msg->connection->tx.p_obuf;
>  	if (iproto_prepare_select(out, &svp) != 0)

Now tx_process1 calls not box_process1, as it used to, but
box_process_dml. IMO this doesn't look any better than what
we presently have.

  reply	other threads:[~2018-08-13  8:20 UTC|newest]

Thread overview: 13+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2018-08-07 22:03 [PATCH 0/8] box.ctl.promote Vladislav Shpilevoy
2018-08-07 22:03 ` [PATCH 1/8] rfc: describe box.ctl.promote protocol Vladislav Shpilevoy
2018-08-07 22:03 ` [PATCH 2/8] box: rename process_rw to process_dml Vladislav Shpilevoy
2018-08-13  8:20   ` Vladimir Davydov [this message]
2018-08-07 22:03 ` [PATCH 3/8] Add 'exact_field_count' parameter to options decoder Vladislav Shpilevoy
2018-08-13  8:30   ` Vladimir Davydov
2018-08-07 22:03 ` [PATCH 4/8] box: remove orphan check from box_is_ro() Vladislav Shpilevoy
2018-08-13  8:34   ` Vladimir Davydov
2018-08-07 22:03 ` [PATCH 5/8] Fix gcov on Mac Vladislav Shpilevoy
2018-08-07 22:03 ` [PATCH 6/8] box: introduce _promotion space Vladislav Shpilevoy
2018-08-07 22:03 ` [PATCH 7/8] box: introduce box.ctl.promote Vladislav Shpilevoy
2018-08-13  8:58   ` Vladimir Davydov
2018-08-07 22:03 ` [PATCH 8/8] box: introduce promotion GC Vladislav Shpilevoy

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20180813082044.my6iydxsfzrp45o6@esperanza \
    --to=vdavydov.dev@gmail.com \
    --cc=tarantool-patches@freelists.org \
    --cc=v.shpilevoy@tarantool.org \
    --subject='Re: [PATCH 2/8] box: rename process_rw to process_dml' \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox