* [tarantool-patches] [PATCH] Refactoring in string validation of log parametrs
@ 2018-07-10 8:10 Olga Arkhangelskaia
2018-07-10 11:44 ` Vladimir Davydov
0 siblings, 1 reply; 2+ messages in thread
From: Olga Arkhangelskaia @ 2018-07-10 8:10 UTC (permalink / raw)
To: tarantool-patches; +Cc: Olga Arkhangelskaia
Log type check happens twise. This patch deletes
unnecessary check
Signed-off-by: Olga Arkhangelskaia <arkholga@tarantool.org>
---
src/box/box.cc | 5 -----
1 file changed, 5 deletions(-)
diff --git a/src/box/box.cc b/src/box/box.cc
index 033829a7f..464018f35 100644
--- a/src/box/box.cc
+++ b/src/box/box.cc
@@ -342,11 +342,6 @@ box_check_say()
diag_last_error(diag_get())->errmsg);
}
- if (say_check_init_str(log) == -1) {
-
- diag_raise();
- }
-
if (type == SAY_LOGGER_SYSLOG) {
struct say_syslog_opts opts;
if (say_parse_syslog_opts(log, &opts) < 0) {
--
2.14.3 (Apple Git-98)
^ permalink raw reply [flat|nested] 2+ messages in thread
* Re: [tarantool-patches] [PATCH] Refactoring in string validation of log parametrs
2018-07-10 8:10 [tarantool-patches] [PATCH] Refactoring in string validation of log parametrs Olga Arkhangelskaia
@ 2018-07-10 11:44 ` Vladimir Davydov
0 siblings, 0 replies; 2+ messages in thread
From: Vladimir Davydov @ 2018-07-10 11:44 UTC (permalink / raw)
To: Olga Arkhangelskaia; +Cc: tarantool-patches
On Tue, Jul 10, 2018 at 11:10:05AM +0300, Olga Arkhangelskaia wrote:
> Log type check happens twise. This patch deletes
> unnecessary check
>
> Signed-off-by: Olga Arkhangelskaia <arkholga@tarantool.org>
> ---
> src/box/box.cc | 5 -----
> 1 file changed, 5 deletions(-)
>
> diff --git a/src/box/box.cc b/src/box/box.cc
> index 033829a7f..464018f35 100644
> --- a/src/box/box.cc
> +++ b/src/box/box.cc
> @@ -342,11 +342,6 @@ box_check_say()
> diag_last_error(diag_get())->errmsg);
> }
>
> - if (say_check_init_str(log) == -1) {
> -
> - diag_raise();
> - }
> -
The check is done twice indeed, which is obviously pointless. However,
I think that instead of removing the call to say_check_init_str(), we'd
better move the whole check to say.c for the sake of encapsulation, i.e.
- rename say_check_init_str to say_check_cfg
- pass values of 'log', 'log_format', and 'log_nonblock' to it
- move all checks from box_check_say to say_check_cfg; after this patch
box_check_say should only retrieve configuration options and pass
them to say_check_cfg
^ permalink raw reply [flat|nested] 2+ messages in thread
end of thread, other threads:[~2018-07-10 11:44 UTC | newest]
Thread overview: 2+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2018-07-10 8:10 [tarantool-patches] [PATCH] Refactoring in string validation of log parametrs Olga Arkhangelskaia
2018-07-10 11:44 ` Vladimir Davydov
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox