Tarantool development patches archive
 help / color / mirror / Atom feed
From: Vladimir Davydov <vdavydov.dev@gmail.com>
To: Olga Arkhangelskaia <arkholga@tarantool.org>
Cc: tarantool-patches@freelists.org
Subject: Re: [tarantool-patches] [PATCH] Refactoring in string validation of log parametrs
Date: Tue, 10 Jul 2018 14:44:53 +0300	[thread overview]
Message-ID: <20180710114453.4p4sh2qkmt5xomxi@esperanza> (raw)
In-Reply-To: <20180710081005.88750-1-arkholga@tarantool.org>

On Tue, Jul 10, 2018 at 11:10:05AM +0300, Olga Arkhangelskaia wrote:
> Log type check happens twise. This patch deletes
> unnecessary check
> 
> Signed-off-by: Olga Arkhangelskaia <arkholga@tarantool.org>
> ---
>  src/box/box.cc | 5 -----
>  1 file changed, 5 deletions(-)
> 
> diff --git a/src/box/box.cc b/src/box/box.cc
> index 033829a7f..464018f35 100644
> --- a/src/box/box.cc
> +++ b/src/box/box.cc
> @@ -342,11 +342,6 @@ box_check_say()
>  			  diag_last_error(diag_get())->errmsg);
>  	}
>  
> -	if (say_check_init_str(log) == -1) {
> -
> -		diag_raise();
> -	}
> -

The check is done twice indeed, which is obviously pointless. However,
I think that instead of removing the call to say_check_init_str(), we'd
better move the whole check to say.c for the sake of encapsulation, i.e.

 - rename say_check_init_str to say_check_cfg
 - pass values of 'log', 'log_format', and 'log_nonblock' to it
 - move all checks from box_check_say to say_check_cfg; after this patch
   box_check_say should only retrieve configuration options and pass
   them to say_check_cfg

      reply	other threads:[~2018-07-10 11:44 UTC|newest]

Thread overview: 2+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2018-07-10  8:10 Olga Arkhangelskaia
2018-07-10 11:44 ` Vladimir Davydov [this message]

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20180710114453.4p4sh2qkmt5xomxi@esperanza \
    --to=vdavydov.dev@gmail.com \
    --cc=arkholga@tarantool.org \
    --cc=tarantool-patches@freelists.org \
    --subject='Re: [tarantool-patches] [PATCH] Refactoring in string validation of log parametrs' \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox