Tarantool development patches archive
 help / color / mirror / Atom feed
From: Vladimir Davydov <vdavydov.dev@gmail.com>
To: Kirill Shcherbatov <kshcherbatov@tarantool.org>
Cc: tarantool-patches@freelists.org
Subject: Re: [tarantool-patches] Re: [PATCH v1 1/1] lib/bitset: rename bitset structs
Date: Tue, 3 Jul 2018 15:52:41 +0300	[thread overview]
Message-ID: <20180703125241.nqmufiqi56s4dqnv@esperanza> (raw)
In-Reply-To: <2a09bc5d-8b80-d387-7ff2-2ccb4b14d2d8@tarantool.org>

On Tue, Jul 03, 2018 at 03:24:29PM +0300, Kirill Shcherbatov wrote:
> > If you're renaming struct bitset to struct tt_bitset, you should also
> > rename all its methods (bitset_create => tt_bitset_create and so forth).
> Ok, I've renamed all bitset structures and methods
> ======================================
> 
> ---
>  src/box/memtx_bitset.c      | 108 ++++++++-------
>  src/box/memtx_bitset.h      |   2 +-
>  src/lib/bitset/bitset.c     |  84 ++++++------
>  src/lib/bitset/bitset.h     |  29 ++--
>  src/lib/bitset/expr.c       |  28 ++--
>  src/lib/bitset/expr.h       |  19 +--
>  src/lib/bitset/index.c      | 122 ++++++++---------
>  src/lib/bitset/index.h      |  54 ++++----
>  src/lib/bitset/iterator.c   | 115 ++++++++--------
>  src/lib/bitset/iterator.h   |  25 ++--
>  src/lib/bitset/page.c       |  27 ++--
>  src/lib/bitset/page.h       |  71 +++++-----
>  test/unit/bitset_basic.c    |  66 ++++-----
>  test/unit/bitset_index.c    | 158 +++++++++++-----------
>  test/unit/bitset_iterator.c | 316 ++++++++++++++++++++++----------------------
>  15 files changed, 630 insertions(+), 594 deletions(-)
> 
> diff --git a/src/box/memtx_bitset.c b/src/box/memtx_bitset.c
> index 9216ed8..33c4b47 100644
> --- a/src/box/memtx_bitset.c
> +++ b/src/box/memtx_bitset.c
> @@ -43,7 +43,7 @@
>  #ifndef OLD_GOOD_BITSET
>  #include "small/matras.h"
>  
> -struct bitset_hash_entry {
> +struct tt_bitset_hash_entry {

I don't think you should rename any structures or functions defined in
memtx_bitset.c - they don't conflict and they are not related to struct
bitset.

  reply	other threads:[~2018-07-03 12:52 UTC|newest]

Thread overview: 7+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2018-07-03 10:29 Kirill Shcherbatov
2018-07-03 10:37 ` Vladimir Davydov
2018-07-03 12:24   ` [tarantool-patches] " Kirill Shcherbatov
2018-07-03 12:52     ` Vladimir Davydov [this message]
2018-07-03 13:24       ` Kirill Shcherbatov
2018-07-03 16:25         ` Vladimir Davydov
2018-07-03 17:10           ` Konstantin Osipov

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20180703125241.nqmufiqi56s4dqnv@esperanza \
    --to=vdavydov.dev@gmail.com \
    --cc=kshcherbatov@tarantool.org \
    --cc=tarantool-patches@freelists.org \
    --subject='Re: [tarantool-patches] Re: [PATCH v1 1/1] lib/bitset: rename bitset structs' \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox