From: Konstantin Osipov <kostja@tarantool.org>
To: Vladimir Davydov <vdavydov.dev@gmail.com>
Cc: tarantool-patches@freelists.org
Subject: Re: [PATCH 12/12] vinyl: allow to modify key definition if it does not require rebuild
Date: Thu, 5 Apr 2018 17:32:09 +0300 [thread overview]
Message-ID: <20180405143209.GA17166@atlas> (raw)
In-Reply-To: <20180402084649.dxtykpka5tylrgn2@esperanza>
I'm pushing this patch, but I dislike the strong similarity of two
msgpack keys in vylog (VY_LOG_MODIFY_LSM and
VY_LOG_KEY_MODIFY_LSN).
Please find a name to distance the two keys from each other in the
way they named, so it's harder to mistake one for another.
* Vladimir Davydov <vdavydov.dev@gmail.com> [18/04/02 11:49]:
> + VY_LOG_KEY_MODIFY_LSN = 13,
> };
>
> /** vy_log_key -> human readable name. */
> @@ -98,6 +99,7 @@ static const char *vy_log_key_name[] = {
> [VY_LOG_KEY_GC_LSN] = "gc_lsn",
> [VY_LOG_KEY_TRUNCATE_COUNT] = "truncate_count",
> [VY_LOG_KEY_CREATE_LSN] = "create_lsn",
> + [VY_LOG_KEY_MODIFY_LSN] = "modify_lsn",
> };
>
> /** vy_log_type -> human readable name. */
> @@ -115,6 +117,7 @@ static const char *vy_log_type_name[] = {
> [VY_LOG_DUMP_LSM] = "dump_lsm",
> [VY_LOG_SNAPSHOT] = "snapshot",
> [VY_LOG_TRUNCATE_LSM] = "truncate_lsm",
> + [VY_LOG_MODIFY_LSM] = "modify_lsm",
> };
--
Konstantin Osipov, Moscow, Russia, +7 903 626 22 32
http://tarantool.io - www.twitter.com/kostja_osipov
next prev parent reply other threads:[~2018-04-05 14:32 UTC|newest]
Thread overview: 20+ messages / expand[flat|nested] mbox.gz Atom feed top
2018-04-01 9:05 [PATCH 00/12] vinyl: allow to extend key def of non-empty index Vladimir Davydov
2018-04-01 9:05 ` [PATCH 01/12] index: add commit_modify virtual method Vladimir Davydov
2018-04-01 9:05 ` [PATCH 02/12] alter: require rebuild of all secondary vinyl indexes if pk changes Vladimir Davydov
2018-04-01 9:05 ` [PATCH 03/12] alter: do not rebuild secondary indexes on compatible " Vladimir Davydov
2018-04-05 12:30 ` Konstantin Osipov
2018-04-01 9:05 ` [PATCH 04/12] space: make space_swap_index method virtual Vladimir Davydov
2018-04-01 9:05 ` [PATCH 05/12] vinyl: do not reallocate tuple formats on alter Vladimir Davydov
2018-04-01 11:12 ` [tarantool-patches] " v.shpilevoy
2018-04-01 11:24 ` Vladimir Davydov
2018-04-01 9:05 ` [PATCH 06/12] vinyl: zap vy_lsm_validate_formats Vladimir Davydov
2018-04-01 9:05 ` [PATCH 07/12] vinyl: zap vy_mem_update_formats Vladimir Davydov
2018-04-01 9:05 ` [PATCH 08/12] vinyl: remove pointless is_nullable initialization for disk_format Vladimir Davydov
2018-04-01 9:05 ` [PATCH 09/12] vinyl: use source tuple format when copying field map Vladimir Davydov
2018-04-01 9:05 ` [PATCH 10/12] vinyl: rename vy_log_record::commit_lsn to create_lsn Vladimir Davydov
2018-04-01 9:05 ` [PATCH 11/12] vinyl: do not write VY_LOG_DUMP_LSM record to snapshot Vladimir Davydov
2018-04-01 9:05 ` [PATCH 12/12] vinyl: allow to modify key definition if it does not require rebuild Vladimir Davydov
2018-04-02 8:46 ` Vladimir Davydov
2018-04-05 14:32 ` Konstantin Osipov [this message]
2018-04-05 14:45 ` Konstantin Osipov
2018-04-05 14:48 ` Konstantin Osipov
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20180405143209.GA17166@atlas \
--to=kostja@tarantool.org \
--cc=tarantool-patches@freelists.org \
--cc=vdavydov.dev@gmail.com \
--subject='Re: [PATCH 12/12] vinyl: allow to modify key definition if it does not require rebuild' \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox