From: "Timur Safin" <tsafin@tarantool.org> To: 'Alexander Turenko' <alexander.turenko@tarantool.org> Cc: tarantool-patches@dev.tarantool.org, v.shpilevoy@tarantool.org Subject: Re: [Tarantool-patches] [PATCH 2.X v4 3/4] module api: introduced luaT_toibuf instead of luaL_checkibuf Date: Fri, 16 Oct 2020 00:07:05 +0300 [thread overview] Message-ID: <053001d6a337$22f88750$68e995f0$@tarantool.org> (raw) In-Reply-To: <20201014035039.glx2veliqncoyp5z@tkn_work_nb> Renamed function in the test, and slightly reworded commit message: commit e0e1421c660dcae8bcced91f392a2d1093ecf30e Author: Timur Safin <tsafin@tarantool.org> Date: Sun Oct 11 16:08:02 2020 +0300 module api: luaT_toibuf instead of luaL_checkibuf * made `luaL_checkibuf` public and then renamed to `luaT_toibuf` to follow naming convention (it's not raising error, simply returning ibuf structure). Part of #5384 ... diff --git a/test/app-tap/module_api.c b/test/app-tap/module_api.c index 17048081f..1c5723693 100644 --- a/test/app-tap/module_api.c +++ b/test/app-tap/module_api.c @@ -155,6 +155,15 @@ test_checkint64(lua_State *L) return 1; } +static int +test_toibuf(lua_State *L) +{ + struct ibuf *buf; + buf = luaT_toibuf(L, -1); + lua_pushboolean(L, buf != NULL); + return 1; +} + static int test_touint64(lua_State *L) { @@ -1242,6 +1251,7 @@ luaopen_module_api(lua_State *L) {"test_pushint64", test_pushint64 }, {"test_checkuint64", test_checkuint64 }, {"test_checkint64", test_checkint64 }, + {"toibuf", test_toibuf}, {"test_touint64", test_touint64 }, {"test_toint64", test_toint64 }, {"test_fiber", test_fiber }, diff --git a/test/app-tap/module_api.test.lua b/test/app-tap/module_api.test.lua index ab5c89c8c..c1aff6797 100755 --- a/test/app-tap/module_api.test.lua +++ b/test/app-tap/module_api.test.lua @@ -38,6 +38,26 @@ local function test_pushcdata(test, module) test:is(gc_counter, 1, 'pushcdata gc') end +local function test_buffers(test, module) + test:plan(9) + local ffi = require('ffi') + local buffer = require('buffer') + + local bufalloc = buffer.static_alloc("char", 128) + local ibuf = buffer.ibuf() + local pbuf = ibuf:alloc(128) + + test:ok(not module.toibuf(nil), 'toibuf of nil') + test:ok(not module.toibuf({}), 'toibuf of {}') + test:ok(not module.toibuf(1LL), 'toibuf of 1LL') + test:ok(not module.toibuf(box.NULL), 'toibuf of box.NULL') + test:ok(not module.toibuf(buffer.reg1), 'toibuf of reg1') + test:ok(not module.toibuf(bufalloc), 'toibuf of allocated buffer') + test:ok(module.toibuf(buffer.IBUF_SHARED), "toibuf of ibuf*") + test:ok(module.toibuf(ibuf), 'toibuf of ibuf') + test:ok(not module.toibuf(pbuf), 'toibuf of pointer to ibuf data') +end + local function test_tuple_validate(test, module) test:plan(12) : From: Alexander Turenko <alexander.turenko@tarantool.org> : Subject: Re: [PATCH 2.X v4 3/4] module api: introduced luaT_toibuf instead : of luaL_checkibuf : : > module api: introduced luaT_toibuf instead of luaL_checkibuf : : We usually try to fit into 50 symbols. Okay, sometimes we overrun it a : bit (and I was one of persons who asked to don't make it hard limit), : where it is hard to give a short description, but it is not the case, : right? : : BTW, imperative mood ('introduce') is suggested for a commit message : header (just header, not the entire body). : : (I would name it 'module api/lua: expose luaT_toibuf()' if you want my : opinion on this essential topic.) : : > * made `luaL_checkibuf` public; : > * renamed it to `luaT_toibuf` to follow naming convention : > (it's not raising error, and is casting to ibuf type). : : Did you mean 'returns a pointer to' by 'is casting to'? It tooks some : time to get the idea. Hmm, but lua_check<...> also returns a pointer. : : I don't push you to anything, just noted that I'm a bit confused here as : a reader. : : > +static int : > +test_checkibuf(lua_State *L) : > +{ : > + struct ibuf *buf; : > + buf = luaT_toibuf(L, -1); : > + lua_pushboolean(L, buf != NULL); : > + return 1; : > +} : : I don't bother enough about the test to insist on it now, but it looks : just as inconsistency. Why not test_toibuf()? : : > +local function test_buffers(test, module) : > + test:plan(9) : > + local ffi = require('ffi') : > + local buffer = require('buffer') : > + : > + local bufalloc = buffer.static_alloc("char", 128) : > + local ibuf = buffer.ibuf() : > + local pbuf = ibuf:alloc(128) : > + : > + test:ok(not module.checkibuf(nil), 'checkibuf of nil') : > + test:ok(not module.checkibuf({}), 'checkibuf of {}') : > + test:ok(not module.checkibuf(1LL), 'checkibuf of 1LL') : > + test:ok(not module.checkibuf(box.NULL), 'checkibuf of box.NULL') : > + test:ok(not module.checkibuf(buffer.reg1), 'checkibuf of reg1') : > + test:ok(not module.checkibuf(bufalloc), 'checkibuf of allocated : buffer') : > + test:ok(module.checkibuf(buffer.IBUF_SHARED), "checkibuf of ibuf*") : > + test:ok(module.checkibuf(ibuf), 'checkibuf of ibuf') : > + test:ok(not module.checkibuf(pbuf), 'checkibuf of pointer to ibuf : data') : : And here too: why 'checkibuf of nil'? The subject of the test is : luaT_isibuf().
next prev parent reply other threads:[~2020-10-15 21:07 UTC|newest] Thread overview: 24+ messages / expand[flat|nested] mbox.gz Atom feed top 2020-10-13 23:01 [Tarantool-patches] [PATCH 2.X v4 0/4] module api: extend for external merger Lua module Timur Safin 2020-10-13 23:01 ` [Tarantool-patches] [PATCH 2.X v4 1/4] module api: export box_tuple_validate Timur Safin 2020-10-15 21:38 ` Alexander Turenko 2020-10-15 21:47 ` Timur Safin 2020-10-15 22:03 ` Vladislav Shpilevoy 2020-10-13 23:01 ` [Tarantool-patches] [PATCH 2.X v4 2/4] module api: export box_key_def_dup Timur Safin 2020-10-13 23:01 ` [Tarantool-patches] [PATCH 2.X v4 3/4] module api: introduced luaT_toibuf instead of luaL_checkibuf Timur Safin 2020-10-14 3:50 ` Alexander Turenko 2020-10-15 21:07 ` Timur Safin [this message] 2020-10-15 22:04 ` Vladislav Shpilevoy 2020-10-13 23:01 ` [Tarantool-patches] [PATCH 2.X v4 4/4] module api: box_ibuf_* wrappers Timur Safin 2020-10-14 3:31 ` Alexander Turenko 2020-10-15 21:35 ` Timur Safin 2020-10-15 21:42 ` Alexander Turenko 2020-10-15 21:44 ` Timur Safin 2020-10-15 21:52 ` Alexander Turenko 2020-10-15 22:07 ` Vladislav Shpilevoy 2020-10-15 22:20 ` Alexander Turenko 2020-10-15 22:27 ` Timur Safin 2020-10-15 22:47 ` Alexander Turenko 2020-10-15 22:37 ` Alexander Turenko 2020-10-15 22:48 ` Alexander Turenko 2020-10-15 22:39 ` [Tarantool-patches] [PATCH 2.X v4.1] " Timur Safin 2020-10-16 6:10 ` [Tarantool-patches] [PATCH 2.X v4 0/4] module api: extend for external merger Lua module Alexander Turenko
Reply instructions: You may reply publicly to this message via plain-text email using any one of the following methods: * Save the following mbox file, import it into your mail client, and reply-to-all from there: mbox Avoid top-posting and favor interleaved quoting: https://en.wikipedia.org/wiki/Posting_style#Interleaved_style * Reply using the --to, --cc, and --in-reply-to switches of git-send-email(1): git send-email \ --in-reply-to='053001d6a337$22f88750$68e995f0$@tarantool.org' \ --to=tsafin@tarantool.org \ --cc=alexander.turenko@tarantool.org \ --cc=tarantool-patches@dev.tarantool.org \ --cc=v.shpilevoy@tarantool.org \ --subject='Re: [Tarantool-patches] [PATCH 2.X v4 3/4] module api: introduced luaT_toibuf instead of luaL_checkibuf' \ /path/to/YOUR_REPLY https://kernel.org/pub/software/scm/git/docs/git-send-email.html * If your mail client supports setting the In-Reply-To header via mailto: links, try the mailto: link
This is a public inbox, see mirroring instructions for how to clone and mirror all data and code used for this inbox