[Tarantool-patches] [PATCH 1/4] fiber: rename ref to fiber_ref

Бабин Олег olegrok at tarantool.org
Thu Sep 2 21:00:31 MSK 2021


Thanks for your review. New commit message:
 
    fiber: rename ref to storage_ref
    
     Ref is a lua reference to fiber storage. This patch just renames
     storage.lua.ref to storage.lua.storage_ref to underline that
     it's not a reference to fiber itself and needed only for fiber
     storage. 
>Четверг, 2 сентября 2021, 18:47 +03:00 от Igor Munkin <imun at tarantool.org>:
> 
>Oleg,
>
>Thanks for the patch! LGTM since the changes are trivial, but consider
>the nits below.
>
>On 11.08.21,  olegrok at tarantool.org wrote:
>> From: Oleg Babin < babinoleg at mail.ru >
>>
>> Ref is a lua reference to fiber storage. This patch just renames
>> storage.lua.ref to storage_ref to underline that it's not a
>
>Minor: This line seems ambiguous (at least to me). You're writing about
>storage.lua.ref, so the renamed field should be storage.lua.storage_ref.
>Feel free to ignore.
>
>> reference to fiber itself and needed only for fiber storage.
>> ---
>> src/lib/core/fiber.h | 2 +-
>> src/lua/fiber.c | 10 +++++-----
>> 2 files changed, 6 insertions(+), 6 deletions(-)
>>
>> diff --git a/src/lib/core/fiber.h b/src/lib/core/fiber.h
>> index b85625ba7..593847df7 100644
>> --- a/src/lib/core/fiber.h
>> +++ b/src/lib/core/fiber.h
>> @@ -626,7 +626,7 @@ struct fiber {
>> /**
>> * Optional fiber.storage Lua reference.
>> */
>> - int ref;
>> + int storage_ref;
>
>Typo: You're writing about <fiber_ref> in the commit subject, but the
>patch is about <storage_ref>.
>
>> } lua;
>> /**
>> * Iproto sync.
>
><snipped>
>
>> --
>> 2.32.0
>>
>
>--
>Best regards,
>IM 
 
 
--
Oleg Babin
 
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.tarantool.org/pipermail/tarantool-patches/attachments/20210902/d0e16ecc/attachment.htm>


More information about the Tarantool-patches mailing list