[Tarantool-patches] [PATCH] test: bump lua-Harness suite

Sergey Kaplun skaplun at tarantool.org
Mon Jul 5 10:48:39 MSK 2021


Hi!

Thanks for the patch!

Side note: please add to "To:" field somebody (usually two persons) you
want to review your changes.

Please separate patchset to the commits of the upstream (with mentioning
cherry-picked commit with full hash to avoid hash clashing -- you can
see examples in the git log). It is easier to review unrelated changes
one by one.

On 02.07.21, Maxim Kokryashkin via Tarantool-patches wrote:
> As our experience has been considered by the maintainer of lua-Harness and the issues we faced are finally fixed in mainline repo, we should bump lua-Harness suite up to 7040458.

We have 72-symbol line width in the commit message body [1], please
reformat it.

> 
> Changes:
>  - The patch `fperrad/lua-Harness at 1be25a8` from lua-Harness suite is the same as the patch `tarantool/luajit at 8376885` from `tarantool/luajit`, except for `get_lua_binary_name()`, which was renamed to `_retrieve_progname()` in `fperadd/lua-Harness`.
> 
> - The patch `fperrad/lua-Harness at 24a570c` from lua-Harness suite is completely the same as the patch `tarantool/luajit at 789820a` from `tarantool/luajit`, so no changes are required.
> 
> - The patch `fperrad/lua-Harness at 60da289` is similar to the patch `tarantool/luajit at d11c5bb`, but `make_specific_checks()` was renamed to `_dofile()` by maintainer. Another difference is that it seems like there is no definition for `_dofile()` in mainline lua-Harness, so it should be user-defined somewhere. If it is not, then `_dofile()` will act like `dofile()`. Considering this, we should keep `make_specific_checks` implementation from `tarantool/luajit at d11c5bb`, but rename it to `_dofile` and move to `tap.lua`.
> 
> - The patch `fperrad/lua-Harness at 6c2aa87` makes 309-os.t check `os.getenv()` function by examining HOME environment variable instead of USER, so we don't need to set USERNAME explicitly anymore, as it stated in POSIX standard that every user must have HOME varibale set. Therefore, `tarantool/luajit at 45ed138` should be replaced with `fperrad/lua-Harness at 6c2aa87`.
> 
> - The patch `fperrad/lua-Harness at 8041c45` renames `tap` module to `test_assertion` to avoid name collisions, hence, we can just apply this patch.
> 
> Github branch: https://github.com/tarantool/luajit/tree/fckxorg/gh-5970

Please provide all patch description between "---" and diff files
mentions [*] (see below), to avoid confusion -- it is not a part
of the commit message.

> 
> Closes : #5970

Please use
| Part of tarantool/tarantool#5970
for the first patches and
| Resolves tarantool/tarantool#5970
for the last patch instead (it will be closed after bump LuaJIT version
in the Tarantool).

> ---

<<< [*] Exactly here.

>  test/lua-Harness-tests/090-tap.t                     |  2 +-
>  test/lua-Harness-tests/091-profile.t                 |  2 +-
>  test/lua-Harness-tests/101-boolean.t                 |  4 ++--
>  test/lua-Harness-tests/102-function.t                |  4 ++--
>  test/lua-Harness-tests/103-nil.t                     |  4 ++--
>  test/lua-Harness-tests/104-number.t                  |  4 ++--
>  test/lua-Harness-tests/105-string.t                  |  4 ++--
>  test/lua-Harness-tests/106-table.t                   |  4 ++--
>  test/lua-Harness-tests/107-thread.t                  |  4 ++--
>  test/lua-Harness-tests/108-userdata.t                |  4 ++--
>  test/lua-Harness-tests/200-examples.t                |  2 +-
>  test/lua-Harness-tests/201-assign.t                  |  2 +-
>  test/lua-Harness-tests/202-expr.t                    |  2 +-
>  test/lua-Harness-tests/203-lexico.t                  | 10 +++++-----
>  test/lua-Harness-tests/204-grammar.t                 |  2 +-
>  test/lua-Harness-tests/211-scope.t                   |  2 +-
>  test/lua-Harness-tests/212-function.t                |  2 +-
>  test/lua-Harness-tests/213-closure.t                 |  2 +-
>  test/lua-Harness-tests/214-coroutine.t               |  2 +-
>  test/lua-Harness-tests/221-table.t                   |  2 +-
>  test/lua-Harness-tests/222-constructor.t             |  2 +-
>  test/lua-Harness-tests/223-iterator.t                |  2 +-
>  test/lua-Harness-tests/231-metatable.t               |  4 ++--
>  test/lua-Harness-tests/232-object.t                  |  2 +-
>  test/lua-Harness-tests/241-standalone.t.disabled     |  4 ++--
>  test/lua-Harness-tests/242-luac.t                    |  4 ++--
>  test/lua-Harness-tests/301-basic.t                   |  6 +++---
>  test/lua-Harness-tests/303-package.t                 |  6 +++---
>  test/lua-Harness-tests/304-string.t                  |  2 +-
>  test/lua-Harness-tests/305-utf8.t                    |  4 ++--
>  test/lua-Harness-tests/306-table.t                   |  2 +-
>  test/lua-Harness-tests/307-math.t                    |  2 +-
>  test/lua-Harness-tests/308-io.t                      |  4 ++--
>  test/lua-Harness-tests/309-os.t                      |  8 ++++----
>  test/lua-Harness-tests/310-debug.t                   |  2 +-
>  test/lua-Harness-tests/311-bit32.t                   |  2 +-
>  test/lua-Harness-tests/314-regex.t                   |  2 +-
>  test/lua-Harness-tests/320-stdin.t                   |  4 ++--
>  test/lua-Harness-tests/401-bitop.t                   |  2 +-
>  test/lua-Harness-tests/402-ffi.t                     |  2 +-
>  test/lua-Harness-tests/403-jit.t                     |  2 +-
>  test/lua-Harness-tests/404-ext.t                     |  4 ++--
>  test/lua-Harness-tests/411-luajit.t.disabled         |  4 ++--
>  test/lua-Harness-tests/CMakeLists.txt                |  5 -----
>  .../{tap.lua => test_assertion.lua}                  | 12 ++++++++++++
>  45 files changed, 82 insertions(+), 75 deletions(-)
>  rename test/lua-Harness-tests/{tap.lua => test_assertion.lua} (95%)

<snipped>

> 

[1]: https://github.com/tarantool/tarantool/wiki/Code-review-procedure#commit-message

-- 
Best regards,
Sergey Kaplun


More information about the Tarantool-patches mailing list