[Tarantool-patches] [DRAFT v1] replication: track information about replica

Sergey Kaplun skaplun at tarantool.org
Thu Jul 2 22:40:48 MSK 2020


Hi! Thanks for the review!

On 02.07.20, Cyrill Gorcunov wrote:
> On Mon, Jun 29, 2020 at 11:31:34PM +0300, Sergey Kaplun wrote:
> ...
> >  
> > +static int
> > +relay_on_state_f(struct trigger *trigger, void *event)
> > +{
> 
> Sergey, I'll review the patch with more attention tomorrow, still
> here are some notes which I can point early.
> 
>  - please don't name the trigger function with _f postfix, we usually
>    do this for cord thread runners (I know here are a few exceptions
>    but they are simply misnamed)
> 

Yup, thanks!

> > +	struct relay *relay = (struct relay *)event;
> > +	(void)trigger;
> 
> You can easily exit early
> 
> 	if (relay_get_state(relay) == RELAY_OFF)
> 		return 0;
> 
> shifting the rest of the code left. Still up to you I do not insist.
> 

Nice point! Early return looks much better!

> 
> Do we really need to call diag_raise() here?
> 
> > +		int rc;
> > +		switch (relay_get_state(relay)) {
> ...
> > +		}
> > +		if (rc != 0)
> > +			diag_raise();
> 
> And here. IIRC usually triggers simply return -1 on error.
> The left of the patch is trimmed for now.

I think we should not raise an error inside relay. Is say_error enough
if something goes wrong?

I will send new version with separate letter.

-- 
Best regards,
Sergey Kaplun


More information about the Tarantool-patches mailing list