[Tarantool-patches] [DRAFT v1] replication: track information about replica

Cyrill Gorcunov gorcunov at gmail.com
Thu Jul 2 18:53:47 MSK 2020


On Mon, Jun 29, 2020 at 11:31:34PM +0300, Sergey Kaplun wrote:
...
>  
> +static int
> +relay_on_state_f(struct trigger *trigger, void *event)
> +{

Sergey, I'll review the patch with more attention tomorrow, still
here are some notes which I can point early.

 - please don't name the trigger function with _f postfix, we usually
   do this for cord thread runners (I know here are a few exceptions
   but they are simply misnamed)

> +	struct relay *relay = (struct relay *)event;
> +	(void)trigger;

You can easily exit early

	if (relay_get_state(relay) == RELAY_OFF)
		return 0;

shifting the rest of the code left. Still up to you I do not insist.

> +	if (relay_get_state(relay) != RELAY_OFF) {
> +		struct replica *replica = relay_replica(relay);
> +		const struct tt_uuid *uuid = &replica->uuid;
> +		assert(replica_by_uuid(uuid) != NULL);
> +		assert(replica->id != REPLICA_ID_NIL);
> +		if (boxk(IPROTO_UPDATE, BOX_CLUSTER_ID, "[%u]["
> +		         "[%s%u%lf]" /* last row time */
> +		         "[%s%u%s]" /* vclock */
> +		         "[%s%u%s]" /* relay state */
> +		         "]",
> +		         (unsigned) replica->id,
> +		         "=", 3, relay_last_row_time(relay),
> +		         "=", 4, vclock_to_string(relay_vclock(relay)),
> +		         "=", 5, relay_get_state_str(relay)
> +		        ) != 0) {
> +			diag_raise();
> +		}

Do we really need to call diag_raise() here?

> +		int rc;
> +		switch (relay_get_state(relay)) {
...
> +		}
> +		if (rc != 0)
> +			diag_raise();

And here. IIRC usually triggers simply return -1 on error.
The left of the patch is trimmed for now.


More information about the Tarantool-patches mailing list