[PATCH 1/2] lib/core/fiber: Rename stack_direction to stack_growsdown

Vladimir Davydov vdavydov.dev at gmail.com
Wed Mar 27 13:20:37 MSK 2019


On Wed, Mar 27, 2019 at 12:48:49PM +0300, Cyrill Gorcunov wrote:
> On Wed, Mar 27, 2019 at 12:35:10PM +0300, Vladimir Davydov wrote:
> > >  enum {
> > >  	/* The minimum allowable fiber stack size in bytes */
> > > @@ -808,7 +808,7 @@ fiber_stack_recycle(struct fiber *fiber)
> > >  	 * it anyway.
> > >  	 */
> > >  	void *start, *end;
> > > -	if (stack_direction < 0) {
> > > +	if (stack_growsdown) {
> > 
> > TBO I like stack_direction more as it's looks symmetrical, so to say.
> 
> Symmetrical with what? :)

+1 / -1 you now :)

  direction < 0
  direction > 0

instead of

  growsdown
  !growsdown

> 
> > I'd refrain from changing this if there's no other reason rather than
> > personal taste.
> 
> It is not personal taste but rather a common naming (mman syscall).
> Though I don't insist.

I wouldn't mind if it was committed. Just that I don't really like
committing minor changes like this so as not to pollute the git history
without a strong reason. Up to Kirill or Kostja.



More information about the Tarantool-patches mailing list